Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2017, 11:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Колонка цены и остатка в форме выбора номенклатуры  (Прочитано 332 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kot488

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Продую вывести колонки на форму выбора, в форме списка все работает замечательно. На форму добавил три колонки ЦенаСНДС, ЦенаБезНДС и Остаток.
Но нечего не выводит(

Вот при открытии
Цитировать
Процедура ПриОткрытии()

   //Восстанавливаем значения флажков и колонок
   
   Если ВосстановитьЗначение("ФлажокЦенаСНДС")<> Неопределено Тогда
     Если ВосстановитьЗначение("ФлажокЦенаСНДС") Тогда
        ЭлементыФормы.СправочникСписок.Колонки.ЦенаСНДС.Видимость = Истина;
        ЭлементыФормы.ФлажокЦенаСНДС.Значение = Истина;
     Иначе
        ЭлементыФормы.СправочникСписок.Колонки.ЦенаСНДС.Видимость = Ложь;
        ЭлементыФормы.ФлажокЦенаСНДС.Значение = Ложь;
     КонецЕсли;
   КонецЕсли; 
    
   Если ВосстановитьЗначение("ФлажокЦенаБезНДС")<> Неопределено Тогда
     Если ВосстановитьЗначение("ФлажокЦенаБезНДС") Тогда
         ЭлементыФормы.СправочникСписок.Колонки.ЦенаБезНДС.Видимость = Истина;
        ЭлементыФормы.ФлажокЦенаБезНДС.Значение = Истина;
     Иначе
         ЭлементыФормы.СправочникСписок.Колонки.ЦенаБезНДС.Видимость = Ложь;
        ЭлементыФормы.ФлажокЦенаБезНДС.Значение = Ложь;
     КонецЕсли;
   КонецЕсли;
   
   Если  ВосстановитьЗначение("ФлажокОстаток")<> Неопределено Тогда
     Если ВосстановитьЗначение("ФлажокОстаток") Тогда
        ЭлементыФормы.СправочникСписок.Колонки.Остаток.Видимость = Истина;
        ЭлементыФормы.ФлажокОстаток.Значение = Истина;
     Иначе
         ЭлементыФормы.СправочникСписок.Колонки.Остаток.Видимость = Ложь;
        ЭлементыФормы.ФлажокОстаток.Значение = Ложь;
     КонецЕсли;
   КонецЕсли;

Вот при получении данных
Цитировать
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
 Если ЭлементыФормы.ФлажокОстаток.Значение или ЭлементыФормы.ФлажокЦенаБезНДС.Значение или
      ЭлементыФормы.ФлажокЦенаСНДС.Значение Тогда   
      Для Каждого Строка Из ОформленияСтрок Цикл      
         РезПоиска = Строка.ДанныеСтроки.Ссылка;
         Если ЗначениеЗаполнено(РезПоиска) Тогда
            Если не РезПоиска.ЭтоГруппа Тогда
               Если ЭлементыФормы.ФлажокОстаток.Значение = Истина Тогда   
                  Остатки = РегистрыНакопления.ПартииТоваровНаСкладах;
                  Фильтр = Новый Структура;
                  Фильтр.Вставить("Номенклатура",РезПоиска);
                  ТабОстатков = Остатки.Остатки(,Фильтр,
                  "Номенклатура", "Количество");
                  Строка.Ячейки.Остаток.Значение = 0;
                  Для Каждого СтрОст Из ТабОстатков Цикл
                     Строка.Ячейки.Остаток.Значение = СтрОст.Количество;
                     Прервать
                  КонецЦикла;
               КонецЕсли;   
               
               
            
         КонецЕсли;      
      КонецЕсли;
       КонецЦикла;               
   КонецЕсли   
   КонецПроцедуры


И при закрытии сохранение галочек что бы при открытии не проставлять их опять но не пойму почему не подтягивает.

Поставил точку остановки на Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок), но не срабатывает, где то не дописал что то , не поможете где ошибся?


Оффлайн kot488

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Модераторы удалите тему, разобрался уже


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 263
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 947
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
"фильтрация" номенклатуры

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 5689
Последний ответ 11 Мар 2014, 16:09
от mashencev_anton
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1027
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Номенклатуры типов "расход" и "услуга. Как использовать?

Автор joyerРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2207
Последний ответ 29 Июн 2011, 21:11
от joyer

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
alex0402
73 Сообщений
alexandr_ll
37 Сообщений
LexaK
29 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
crow1983
27 Сообщений
sertak sertak
23 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
15 Сообщений
Vzonder
15 Сообщений

* Кто онлайн

  • Точка Гостей: 1037
  • Точка Скрытых: 0
  • Точка Пользователей: 16
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal