Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Мар 2017, 04:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выпадающий список в документе из данных табличной части справочника  (Прочитано 552 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tatiana22

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-23
  • Сайт: 
Здравствуйте!
Имеются следующие объекты:
Справочник ПричинаДефекта имеет стандартный реквизит Наименование и реквизит ПодразделениеВиновник.
Справочник ПроизводственныйДефект имеет реквизит Наименование, реквизит ВнешнееПроявлениеНесоответствия (тип - строка), табличную часть ПричиныВозникновенияНесоответствия с реквизитом ПрчичинаНесоответствия (тип - СправочникСсылка.ПричинаДефекта).
Документ Акт, кроме своих реквизитов (это сейчас не важно) имеет табличную часть СписокНесоответствующейПродукции с реквизитами: НаименованиеНесоответствия (СправочникСсылка.ПроизводственныйДефект), ОписаниеВнешнегоПроявления (тип - строка, заполняется автоматически при заполнении НаименованиеНесоответствия), ПричинаНесоответствия (тип - СправочникСсылка.ПричинаДефекта).
Надо: реализовать выпадающий список ПричинаДефекта в табличной части документа Акт. Т.е. в каждом элементе справочника ПроизводственныйДефект есть табличная часть с различными ПричинаДефекта (их может быть несколько). Я хочу в документе Акт добавить реквизит справочника - Наименование, считать все причины из него и записать в ячейку документа ПричинаДефекта для соответствующего дефекта, как выпадающий список (без возможности редактирования). Таким образом, пользователь будет добавлять дефект и затем из выпадающего списка выбирать ту причину, которая ему нужна (из определенного перечня, для этого дефекта). Может кто подскажет, можно ли так сделать?

Написала код:
&НаКлиенте
Процедура СписокНесоответствующейПродукцииПричинаНесоответствияНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ТекСтрока = Элемент.СписокНесоответствующейПродукции.ТекущиеДанные;
ДанныеВыбора = ПолучитьСписокНаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьСписокНаСервере()
ДанныеВыбора = Новый СписокЗначений;
Запрос = Новый Запрос("ВЫБРАТЬ
| ПричинаНесоответствия.Ссылка
|ИЗ
| Справочник.ПроизводственныйДефект.ПричиныВозникновенияНесоответствия КАК ПричинаНесоответствия");
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ДанныеВыбора.Добавить(Выборка.Ссылка);
КонецЦикла;
Возврат ДанныеВыбора;
КонецФункции

Но что-то здесь не так. Подскажите, как правильно реализовать.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Или настройте для элемента режим выбора из списка и заполняйте список выбора или устанавливайте отбор динамического списка в форме выбора.


 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6346
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3299
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1253
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 5479
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5748
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
alex0402
124 Сообщений
MuI_I_Ika MuI_I_Ika
54 Сообщений
Norfolk
52 Сообщений
LexaK
47 Сообщений
alexandr_ll
20 Сообщений
друган
20 Сообщений
Константин5825
18 Сообщений
AsadRoman
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 226
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal