Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2019, 15:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Можно ли програмно изменить одну из колонок таблицы формы регистра сведений при создании формы  (Прочитано 2234 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rassvetniy

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-24
  • Сайт: 
  • Профессия: Ученик 1С
День добрый.
Есть регистр сведений и его форма списка, в регистре есть реквезит количество = 0, можно ли при открытии формы его заполнить данными из другой таблицы?
что то пробный код ничего не дал:
в цикле для каждого пишет нет итератора ошибка
&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПриОткрытииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
   Для каждого элм из ЭтаФорма.Список Цикл   // тут ошибка
   Запрос = Новый Запрос;
      Запрос.Текст = "ВЫБРАТЬ
   |Остатки.КоличествоОстаток,
|ИЗ
   |РегистрНакопления.Остатки.Остатки КАК Остатки ГДЕ Остатки.Номенклатура=&ссылка И Остатки.Цена=&ссылка1 ";   
     Запрос.УстановитьПараметр("Ссылка", Элм.Номенклатура);
      Запрос.УстановитьПараметр("Ссылка", Элм.ЦенаРозн);
     РезультатЗапроса = Запрос.Выполнить();
     ВыборкаЗаписи = РезультатЗапроса.Выбрать();
    ВыборкаЗаписи.Следующий();      
    Элм.количество = ВыборкаЗаписи.КоличествоОстаток;
    конецЦикла;

КонецПроцедуры


Оффлайн Rassvetniy

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-24
  • Сайт: 
  • Профессия: Ученик 1С
в этом фрагменте тоже нет итератора:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
   Для каждого элм из Список Цикл
      сообщить(элм.номенклатура);
      конецЦикла;
   
   //ПриОткрытииНаСервере();
КонецПроцедуры
как тогда обойти в цикле строки табличной части формы???

Оффлайн vitasw

  • *****
  • Сообщений: 2593
  • РЕПУТАЦИЯ: 317
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн Rassvetniy

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-24
  • Сайт: 
  • Профессия: Ученик 1С
Можно. Меняйте запрос дин. списка.
а это как? всмысле где его писать тот запрос?
Добавлено: 20 Фев 2016, 20:43

свойства списка - настройка, произвольный запрос - наверное там менять, есть визуальный конструктор ... но непонятно почему цикл Для каждого не работает?
Добавлено: 20 Фев 2016, 20:56

впринципе то что хотел реализовать получилось, в конструкторе запроса списка...
но интересно это вручную меняя событие при создании формы на сервере можно сделать? а еще более интересно чего таки цикл для каждого в модуле формы у меня ни в какую ничего не видит

Последний раз редактировалось: Rassvetniy; 20 Фев 2016, 20:56. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2593
  • РЕПУТАЦИЯ: 317
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
а еще более интересно чего таки цикл для каждого в модуле формы у меня ни в какую ничего не видит

Вопрос звучит примерно как: когда я протираю лобовое стекло в машине почему-то багажник НЕ открывается.
Ваш цикл и не должен ничего видеть. Данные есть только в запросе дин. списка, все прочее - это только отображаемый текст.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5648
Последний ответ 24 Дек 2015, 15:34
от дфтын
Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5898
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
УНФ планировщик выдает на план-графике вместо контрагентов <Точка 1>, <Точка 2> и т.д. Как можно отобразить наименования контрагентов вместо точек?

Автор olesya9393Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1332
Последний ответ 09 Янв 2017, 12:55
от olesya9393
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 9397
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Регистр сведений "Товары организаций", измерение "АналитикаУчетаНоменклатуры"

Автор GanG031Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 392
Последний ответ 20 Дек 2018, 14:35
от GanG031

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

1:С Консультант от Vertikal_MSK
[Сегодня в 09:44]


1:С Консультант от Vertikal_MSK
[Сегодня в 09:43]


Программист 1С от aitiks
[09 Дек 2019, 19:01]


Программист 1С УТ от Vladimir 652
[06 Дек 2019, 15:33]

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
58 Сообщений
wise wise
46 Сообщений
alexandr_ll
42 Сообщений
MuI_I_Ika MuI_I_Ika
29 Сообщений
LexaK
28 Сообщений
Chgdz
23 Сообщений
antipod
23 Сообщений
depb
16 Сообщений
DmitriyF DmitriyF
14 Сообщений
Yotram
13 Сообщений

* Кто онлайн

  • Точка Гостей: 685
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal