Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июл 2017, 19:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: при записи документа  (Прочитано 591 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Олька1992

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-19
  • Сайт: 
  • Профессия: Программист 1С
в справочник ФизЛица добавила реквизит булево пенсионер, теперь нужно в документе увольнение чтобы при записи появлялось сообщение "это физ лицо является пенсионером", как это воплотить, подскажите плиз)
 в справочнике ФизЛица, если вытаскивать сотрудника запросом, является ссылка, а сам сотрудник является типом строка!


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
чтобы кадровик всплакнул когда увольнял пенсионера? :D
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Тамерлан Тарханов

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-25
  • Сайт: 
  • Профессия: Программист 8.1
В модуль Формы добавь:
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
   ТекСтрока = Элементы.Сотрудник.ТекущиеДанные;
   Сотрудник = ТекСтрока.Сотрудник;
   Если ПередЗаписьюНаСервере(Сотрудник) = 1 тогда
   Результат = Вопрос("Это физ лицо является пенсионером, уволить?",РежимДиалогаВопрос.ДаНет);
   Если Результат = КодВозвратаДиалога.Нет тогда
   Отказ = Истина;
   КонецЕсли;
   КонецЕсли;
КонецПроцедуры


&НаСервереБезКонтекста
Функция ПередЗаписьюНаСервере(Сотрудник)
   Спр = Справочники.ФизическиеЛица.НайтиПоНаименованию(Сотрудник);
   Если Спр.Персионер = Истина тогда
   Сообщение = 1;
Иначе Сообщение = 0;
   КонецЕсли;
   Возврат Сообщение;
КонецФункции

Подходит для случая, когда один сотрудник в одном документе, если нет то цикл используй

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
В модуль Формы добавь:
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
   ТекСтрока = Элементы.Сотрудник.ТекущиеДанные;
   Сотрудник = ТекСтрока.Сотрудник;
   Если ПередЗаписьюНаСервере(Сотрудник) = 1 тогда
   Результат = Вопрос("Это физ лицо является пенсионером, уволить?",РежимДиалогаВопрос.ДаНет);
   Если Результат = КодВозвратаДиалога.Нет тогда
   Отказ = Истина;
   КонецЕсли;
   КонецЕсли;
КонецПроцедуры


&НаСервереБезКонтекста
Функция ПередЗаписьюНаСервере(Сотрудник)
   Спр = Справочники.ФизическиеЛица.НайтиПоНаименованию(Сотрудник);
   Если Спр.Персионер = Истина тогда
   Сообщение = 1;
Иначе Сообщение = 0;
   КонецЕсли;
   Возврат Сообщение;
КонецФункции

Подходит для случая, когда один сотрудник в одном документе, если нет то цикл используй

Н-даааааа, носеветовали тут. От таких советчиков потом всплакнуть хочется.... Тут столько криворукости, что даже комментировать не хочется.

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а не проще приизминении строки тч делать? да и писать меньше
 Если Строка.Сотрудник.ФизическоеЛицо.Пенсионер Тогда
    Сообщить("Выбранные сотрудник:" + Строка.Сотрудник. +" - Пенсионер!");
     
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Тамерлан Тарханов

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-25
  • Сайт: 
  • Профессия: Программист 8.1
Точно, при изменении проще


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4189
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14662
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3762
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 286
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7227
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
105 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
Golickoff Golickoff
49 Сообщений
ilyay ilyay
49 Сообщений
AIFrame
47 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 262
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal