Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Июл 2017, 03:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 8.3 обычное приложение. Сохранение файла Эксель  (Прочитано 875 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Natain14

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 2
  • КПД: 4%
  • Регистрация: 2015-06-16
  • Сайт: 
Добрый день, подскажите, пожалуйста, можно ли при сохранении файла Эксель, если файл с таким именем уже существует, то в конце имени добавлять номер версии файла, например, Книга1(1), Книга1(2)...
Была мысль добавить регистр для хранения версий, но передумала, т.к. пользователь может переименовать файл. Или через попытку в цикле проверять существование файла через ПутьФайла.Существует() и добавлять к версии +1

Но может есть какой-нибудь стандартный метод?


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ПутьФайла.Существует() 
вполне себе стандратно
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
через попытку в цикле проверять существование файла
НайтиФайлы() не предлагать?

Оффлайн Natain14

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 2
  • КПД: 4%
  • Регистрация: 2015-06-16
  • Сайт: 
ПутьФайла.Существует() 
вполне себе стандратно

Просто сейчас у меня получилось вот так.  Мне не нравится, что количество версий ограничено в данном случае 200, а дальше будет выходить ошибка. И в том случае, если при сохранении возникнет ошибка не связанная с именем, то он ведь скорее всего обойдет весь этот цикл? Хм... или не обойдет...он же у меня в попытке, так что вылетит наверное по исключению... В общем, может можно это решение как-то усовершенствовать или изменить?

Для к=0 по 200 цикл
         ИмяФайлаДляПроверки = Новый Файл(ИмяФайла+?(к=0,".xls"," ("+к+").xls"));
         Если не ИмяФайлаДляПроверки.Существует() тогда
         
         Книга.SaveAs(ИмяФайла+?(к=0,".xls"," ("+к+").xls"),18);
         ExcelПриложение.Quit();        
      
         Сообщить("Файл выгружен успешно: " +ИмяФайла+?(к=0,""," ("+к+")"));    
         ЗапуститьПриложение(ИмяФайла+?(к=0,".xls"," ("+к+").xls"));

         Прервать;
         КонецЕсли;
      КонецЦикла;

Онлайн Kironten

  • *****
  • Сообщений: 818
  • РЕПУТАЦИЯ: 173
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
ФайлНайден = Истина;
к=0;
Пока ФайлНайден Цикл
//Для к=0 по 200 цикл
   
    ИмяФайлаДляПроверки = Новый Файл(ИмяФайла+?(к=0,".xls"," ("+к+").xls"));
   
    Если не ИмяФайлаДляПроверки.Существует() тогда
Книга.SaveAs(ИмяФайла+?(к=0,".xls"," ("+к+").xls"),18);
        ФайлНайден = Ложь;
ExcelПриложение.Quit(); 

Сообщить("Файл выгружен успешно: " +ИмяФайла+?(к=0,""," ("+к+")"));
ЗапуститьПриложение(ИмяФайла+?(к=0,".xls"," ("+к+").xls"));

//Прервать;
    КонецЕсли;

    Если к = 1000 Тогда
        Сообщить("Что-то больно дохрена выходит. Давайте закругляться!");
        Прервать;
    КонецЕсли;
     к = к + 1;
КонецЦикла;


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 7831
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Ошибка КД "Файла не существует"

Автор arkanruРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 978
Последний ответ 31 Авг 2015, 11:19
от arkanru
Cоздание Excel afqkf по оформлению из другого файла Excel

Автор bugsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2501
Последний ответ 23 Авг 2011, 14:26
от bugs
Задание типа файла при сохранении таб.документа "Сохранить копию" во внешний фа

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3826
Последний ответ 22 Дек 2011, 15:34
от sergeevds
Загрузка из файла в Зарплата и кадры справочник "Физические лица"

Автор ЕгорийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2908
Последний ответ 10 Авг 2011, 06:49
от Almas

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
92 Сообщений
oleg-x
73 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
40 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 250
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal