Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июл 2017, 19:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: заполнение полей регистра сведений  (Прочитано 524 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alexregnif

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-15
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите, пожалуйста.
Пытаюсь программно заполнить независымый непереодический регистр.
есть одно измерение- порядковый номер и один ресурс - Число
задача - забить цикл, чтобы, например, порядковый номер шел с 1 по 10, а само число и интервалом плюс два, те 1 3 5 7 ...все происходит при нажатии на кнопку.

Процедура Команда1(Команда)
   новаястрока=рег();
   КонецПроцедуры
&Насервере
   Функция Рег();
       ф1=0;
       ф2=0;
       ф3=0 ;
      
   рег = РегистрыСведений.ВыборЧисла.СоздатьМенеджерЗаписи();
   рег.Прочитать();

   Для  Шага=1 По 10 цикл
   рег.Число=ф1;
      ф2=ф1+2;
      ф3=Ф2+2;
      ф1=ф2;
      ф2=ф3;   
   КонецЦикла;
 рег.Записать() ;
   КонецФункции

заполняется только первая строка и уже конечным результатом, те если цикл по 10 то десятым числом - 18. как сделать чтобы добавлялось 10 строк?
и еще проблема, при нажатии на кнопку результат сразу не выводится, хотя его можно наблюдать перезагрузив отладчик.
Что не так в коде, подскажите. заранее благодарю.







Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
лучше через НаборЗаписей.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 6733
Последний ответ 16 Авг 2012, 21:50
от Will
Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4526
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2328
Последний ответ 30 Ноя 2011, 07:10
от has
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14662
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3762
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
105 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
ilyay ilyay
49 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
47 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
LexaK
22 Сообщений

* Кто онлайн

  • Точка Гостей: 267
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal