Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Янв 2017, 17:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: заполнение полей регистра сведений  (Прочитано 403 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alexregnif

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-15
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите, пожалуйста.
Пытаюсь программно заполнить независымый непереодический регистр.
есть одно измерение- порядковый номер и один ресурс - Число
задача - забить цикл, чтобы, например, порядковый номер шел с 1 по 10, а само число и интервалом плюс два, те 1 3 5 7 ...все происходит при нажатии на кнопку.

Процедура Команда1(Команда)
   новаястрока=рег();
   КонецПроцедуры
&Насервере
   Функция Рег();
       ф1=0;
       ф2=0;
       ф3=0 ;
      
   рег = РегистрыСведений.ВыборЧисла.СоздатьМенеджерЗаписи();
   рег.Прочитать();

   Для  Шага=1 По 10 цикл
   рег.Число=ф1;
      ф2=ф1+2;
      ф3=Ф2+2;
      ф1=ф2;
      ф2=ф3;   
   КонецЦикла;
 рег.Записать() ;
   КонецФункции

заполняется только первая строка и уже конечным результатом, те если цикл по 10 то десятым числом - 18. как сделать чтобы добавлялось 10 строк?
и еще проблема, при нажатии на кнопку результат сразу не выводится, хотя его можно наблюдать перезагрузив отладчик.
Что не так в коде, подскажите. заранее благодарю.







Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
лучше через НаборЗаписей.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 5736
Последний ответ 16 Авг 2012, 21:50
от Will
Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2768
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2078
Последний ответ 30 Ноя 2011, 07:10
от has
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 12691
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2603
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
55 Сообщений
MuI_I_Ika MuI_I_Ika
49 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
31 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 777
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal