Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 11:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (внешняя обработка)  (Прочитано 391 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 146
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, уважаемые! Суть в следующем: пишу обработку, которая выгружает определенные данные в текстовый файл. Управляемое приложение 8.3. Вот собственно говоря код:
<code>
&НаСервере
Процедура ВыполнитьВФайл(Команда)
   
   
   Запрос = Новый Запрос();
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Период,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сотрудник,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.СоставнаяЧасть,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Индексируется,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сумма,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сотрудник.Код КАК Табель
   |ИЗ
   |   РегистрНакопления.ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий КАК ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий";   
   
   Выборка = Запрос.Выполнить();
   
   Текст = Новый ТекстовыйДокумент();
   ВыборкаИзРезультатаЗапроса = Выборка.Выбрать();
   Пока ВыборкаИзРезультатаЗапроса.Следующий() Цикл
      Текст.ДобавитьСтроку(""+ВыборкаИзРезультатаЗапроса.Период +";"+ВыборкаИзРезультатаЗапроса.Сотрудник +";"+ВыборкаИзРезультатаЗапроса.Сотрудник.Код +";"+ВыборкаИзРезультатаЗапроса.СоставнаяЧасть+";"+ВыборкаИзРезультатаЗапроса.Индексируется +";"+ВыборкаИзРезультатаЗапроса.Сумма);

   КонецЦикла;
   Текст.Записать("D:\1.txt");


КонецПроцедуры </code>

Проверил сам запрос в консоле запросов - все правильно выбирает. По записи в файл тоже вроде бы ошибок нету. Но когда запускаю обработку, то ничего не происходит. Точку остановку поставить не могу, не получается(. Подскажите, в чем проблема? заранее спасибо! Обработка для ЗУП 3.0.


Оффлайн GanG031

  • ***
  • Сообщений: 146
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
прикладываю саму обработку: https://yadi.sk/d/8KAKNq8xor9Xf
Добавлено: 15 Фев 2016, 09:52

Все, разобрался! Сделал так:

&НаСервере
Процедура ВыполнитьВФайлНаСервере()

   Запрос = Новый Запрос();
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Период,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сотрудник,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.СоставнаяЧасть,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Индексируется,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сумма,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сотрудник.Код КАК Табель
   |ИЗ
   |   РегистрНакопления.ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий КАК ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий";   
   
   Выборка = Запрос.Выполнить();
   
   Текст = Новый ТекстовыйДокумент();
   ВыборкаИзРезультатаЗапроса = Выборка.Выбрать();
   Пока ВыборкаИзРезультатаЗапроса.Следующий() Цикл
      Текст.ДобавитьСтроку(""+ВыборкаИзРезультатаЗапроса.Период +";"+ВыборкаИзРезультатаЗапроса.Сотрудник +";"+ВыборкаИзРезультатаЗапроса.Сотрудник.Код +";"+ВыборкаИзРезультатаЗапроса.СоставнаяЧасть+";"+ВыборкаИзРезультатаЗапроса.Индексируется +";"+ВыборкаИзРезультатаЗапроса.Сумма);
   КонецЦикла;
   
   Текст.Записать("D:\1.txt");


КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьВФайл(Команда)
   ВыполнитьВФайлНаСервере();
КонецПроцедуры

Последний раз редактировалось: GanG031; 15 Фев 2016, 09:52. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
93 Сообщений
oleg-x
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
45 Сообщений
AIFrame
41 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal