Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Мар 2017, 02:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (внешняя обработка)  (Прочитано 361 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 139
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, уважаемые! Суть в следующем: пишу обработку, которая выгружает определенные данные в текстовый файл. Управляемое приложение 8.3. Вот собственно говоря код:
<code>
&НаСервере
Процедура ВыполнитьВФайл(Команда)
   
   
   Запрос = Новый Запрос();
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Период,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сотрудник,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.СоставнаяЧасть,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Индексируется,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сумма,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сотрудник.Код КАК Табель
   |ИЗ
   |   РегистрНакопления.ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий КАК ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий";   
   
   Выборка = Запрос.Выполнить();
   
   Текст = Новый ТекстовыйДокумент();
   ВыборкаИзРезультатаЗапроса = Выборка.Выбрать();
   Пока ВыборкаИзРезультатаЗапроса.Следующий() Цикл
      Текст.ДобавитьСтроку(""+ВыборкаИзРезультатаЗапроса.Период +";"+ВыборкаИзРезультатаЗапроса.Сотрудник +";"+ВыборкаИзРезультатаЗапроса.Сотрудник.Код +";"+ВыборкаИзРезультатаЗапроса.СоставнаяЧасть+";"+ВыборкаИзРезультатаЗапроса.Индексируется +";"+ВыборкаИзРезультатаЗапроса.Сумма);

   КонецЦикла;
   Текст.Записать("D:\1.txt");


КонецПроцедуры </code>

Проверил сам запрос в консоле запросов - все правильно выбирает. По записи в файл тоже вроде бы ошибок нету. Но когда запускаю обработку, то ничего не происходит. Точку остановку поставить не могу, не получается(. Подскажите, в чем проблема? заранее спасибо! Обработка для ЗУП 3.0.


Оффлайн GanG031

  • ***
  • Сообщений: 139
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
прикладываю саму обработку: https://yadi.sk/d/8KAKNq8xor9Xf
Добавлено: 15 Фев 2016, 09:52

Все, разобрался! Сделал так:

&НаСервере
Процедура ВыполнитьВФайлНаСервере()

   Запрос = Новый Запрос();
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Период,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сотрудник,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.СоставнаяЧасть,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Индексируется,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сумма,
   |   ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий.Сотрудник.Код КАК Табель
   |ИЗ
   |   РегистрНакопления.ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий КАК ДанныеОНачисленияхДляРасчетаСреднегоЗаработкаОбщий";   
   
   Выборка = Запрос.Выполнить();
   
   Текст = Новый ТекстовыйДокумент();
   ВыборкаИзРезультатаЗапроса = Выборка.Выбрать();
   Пока ВыборкаИзРезультатаЗапроса.Следующий() Цикл
      Текст.ДобавитьСтроку(""+ВыборкаИзРезультатаЗапроса.Период +";"+ВыборкаИзРезультатаЗапроса.Сотрудник +";"+ВыборкаИзРезультатаЗапроса.Сотрудник.Код +";"+ВыборкаИзРезультатаЗапроса.СоставнаяЧасть+";"+ВыборкаИзРезультатаЗапроса.Индексируется +";"+ВыборкаИзРезультатаЗапроса.Сумма);
   КонецЦикла;
   
   Текст.Записать("D:\1.txt");


КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьВФайл(Команда)
   ВыполнитьВФайлНаСервере();
КонецПроцедуры

Последний раз редактировалось: GanG031; 15 Фев 2016, 09:52. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
alex0402
124 Сообщений
MuI_I_Ika MuI_I_Ika
54 Сообщений
Norfolk
52 Сообщений
LexaK
47 Сообщений
друган
20 Сообщений
alexandr_ll
20 Сообщений
AsadRoman
18 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 229
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal