Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Окт 2017, 12:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Значение не является значением объектного типа (Пустая)  (Прочитано 3725 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Выходит вот такая ошибка, не могу понять в чем причина. Помогите плз

Функция ПечатьРеализацияТоваровУслуг()

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ТекДокумент", СсылкаНаОбъект);
Запрос.УстановитьПараметр("Дата", СсылкаНаОбъект.Дата);

Запрос.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| РеализацияТоваровУслуг.Номер,
| РеализацияТоваровУслуг.Дата КАК ДатаДокумента,
| РеализацияТоваровУслуг.Организация.НаименованиеПолное КАК Организация,
| РеализацияТоваровУслуг.Контрагент,
| РеализацияТоваровУслуг.Склад,
| ВЫБОР
| КОГДА РеализацияТоваровУслуг.Ответственный.ФизЛицо <> ЗНАЧЕНИЕ(Справочник.ФизическиеЛица.ПустаяСсылка)
| ТОГДА Ответственный.ФизЛицо
| ИНАЧЕ Ответственный
| КОНЕЦ КАК Ответственный,
| ОтветственныеЛицаСрезПоследних.ФизическоеЛицо КАК МОЛ,
| РеализацияТоваровУслуг.ВалютаДокумента,
| РеализацияТоваровУслуг.ВалютаДокумента.Представление КАК ВалютаПредставление,
| РеализацияТоваровУслуг.Организация.БИН КАК ИИН
|ИЗ
| Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОтветственныеЛица.СрезПоследних(&Дата, ) КАК ОтветственныеЛицаСрезПоследних
| ПО РеализацияТоваровУслуг.Склад = ОтветственныеЛицаСрезПоследних.СтруктурнаяЕдиница
|ГДЕ
| РеализацияТоваровУслуг.Ссылка = &ТекДокумент";

Шапка = Запрос.Выполнить().Выбрать();
Шапка.Следующий();

ЗапросПоТоварам = Новый Запрос();
ЗапросПоТоварам.УстановитьПараметр("ТекДокумент", СсылкаНаОбъект);
ЗапросПоТоварам.Текст =
"ВЫБРАТЬ
| РеализацияТоваровУслугТовары.НомерСтроки,
| РеализацияТоваровУслугТовары.Номенклатура,
| РеализацияТоваровУслугТовары.ЕдиницаИзмерения.Наименование КАК ЕдиницаИзмеренияНаименование,
| РеализацияТоваровУслугТовары.Номенклатура.Код КАК ТоварКод,
| СУММА(РеализацияТоваровУслугТовары.Количество) КАК Количество,
| РеализацияТоваровУслугТовары.Цена,
| СУММА(РеализацияТоваровУслугТовары.Сумма) КАК Сумма,
| СУММА(РеализацияТоваровУслугТовары.СуммаНДС) КАК СуммаНДС,
| СУММА(ВЫБОР
| КОГДА РеализацияТоваровУслугТовары.Ссылка.УчитыватьНДС
| И РеализацияТоваровУслугТовары.Ссылка.СуммаВключаетНДС
| ИЛИ (НЕ РеализацияТоваровУслугТовары.Ссылка.УчитыватьНДС)
| ТОГДА РеализацияТоваровУслугТовары.Сумма
| ИНАЧЕ ВЫБОР
| КОГДА РеализацияТоваровУслугТовары.Ссылка.УчитыватьНДС
| И (НЕ РеализацияТоваровУслугТовары.Ссылка.СуммаВключаетНДС)
| ТОГДА РеализацияТоваровУслугТовары.Сумма + РеализацияТоваровУслугТовары.СуммаНДС
| КОНЕЦ
| КОНЕЦ) КАК СуммаСНДС
|ИЗ
| Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
|ГДЕ
| РеализацияТоваровУслугТовары.Ссылка = &ТекДокумент
|
|СГРУППИРОВАТЬ ПО
| РеализацияТоваровУслугТовары.НомерСтроки,
| РеализацияТоваровУслугТовары.Номенклатура,
| РеализацияТоваровУслугТовары.ЕдиницаИзмерения.Наименование,
| РеализацияТоваровУслугТовары.Номенклатура.Код,
| РеализацияТоваровУслугТовары.Цена
|
|УПОРЯДОЧИТЬ ПО
| НомерСтроки
    |ИТОГИ
| СУММА(СуммаНДС),
| СУММА(СуммаСНДС)
|ПО
| ОБЩИЕ";

ВыборкаСтрокТоварыИтоги = ЗапросПоТоварам.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
ВыборкаСтрокТоварыИтоги.Следующий();

ВыборкаСтрокТовары = ВыборкаСтрокТоварыИтоги.Выбрать();

//СтруктурнаяЕдиницаОрганизация = ОбщегоНазначения.ПолучитьСтруктурнуюЕдиницу(Шапка.Организация, Шапка.СтруктурноеПодразделение);


Макет = ПолучитьМакет("З2");

ТабДокумент = Новый ТабличныйДокумент;

// Зададим параметры макета
ТабДокумент.ПолеСверху         = 0;
ТабДокумент.ПолеСлева          = 10;
ТабДокумент.ПолеСнизу          = 0;
ТабДокумент.ПолеСправа         = 0;
ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
   
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПередачаТоваров_З2";

// Выводим общие реквизиты шапки
ОбластьМакета = Макет.ПолучитьОбласть("Шапка");

//СведенияОбОрганизации = ОбщегоНазначения.СведенияОЮрФизЛице(СтруктурнаяЕдиницаОрганизация, Шапка.ДатаДокумента);

ОбластьМакета.Параметры.Заполнить(Шапка);
ОбластьМакета.Параметры.ПредставлениеОрганизации = СокрЛП(Шапка.Организация);
ОбластьМакета.Параметры.ПредставлениеОтправителя = СокрЛП(Шапка.Организация);
ОбластьМакета.Параметры.ОрганизацияРНН_БИН       = СокрЛП(Шапка.ИИН);
ОбластьМакета.Параметры.НомерДокумента           = ПолучитьНомерНаПечать(СсылкаНаОбъект, глСписокПрефиксовУзлов);


ОтветственныйДляПечати  = "";
ДолжностьОтветственного = "";

Если ТипЗнч(Шапка.Ответственный) = Тип("СправочникСсылка.ФизическиеЛица") Тогда
ДанныеОтветственного = ДанныеФизЛица(Шапка.Организация, Шапка.Ответственный, СсылкаНаОбъект.Дата);
ОтветственныйДляПечати = ДанныеОтветственного.Представление;
ДолжностьОтветственного = ДанныеОтветственного.Должность;
Иначе
ОтветственныйДляПечати = Шапка.Ответственный;
КонецЕсли;

ОбластьМакета.Параметры.ОтветственныйЗаПоставку = ОтветственныйДляПечати;

ПредставлениеПолучателя = ОписаниеОрганизации(СведенияОЮрФизЛице(Шапка.Контрагент, Шапка.ДатаДокумента), "ПолноеНаименование,");
ОбластьМакета.Параметры.ПредставлениеПолучателя = ПредставлениеПолучателя;

ТабДокумент.Вывести(ОбластьМакета);

// Выводим заголовок таблицы
ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
ЗаголовокТаблицы.Параметры.Валюта = Шапка.ВалютаПредставление;
ТабДокумент.Вывести(ЗаголовокТаблицы);

КоличествоСтрок = ВыборкаСтрокТовары.Количество();

// Выводим многострочную часть документа
ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаблицы");

Пока ВыборкаСтрокТовары.Следующий() Цикл

Если НЕ ЗначениеЗаполнено(ВыборкаСтрокТовары.Номенклатура) Тогда
Сообщить("В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.", СтатусСообщения.Важное);
Продолжить;
КонецЕсли;
       
Если Не ПроверитьВыводДляТабличногоДокумента(ТабДокумент, ОбластьМакета) Тогда
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
            ТабДокумент.Вывести(ЗаголовокТаблицы);
КонецЕсли;

ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);
ОбластьМакета.Параметры.НомерПП = ВыборкаСтрокТовары.НомерСтроки;
ОбластьМакета.Параметры.ТоварНаименование = ВыборкаСтрокТовары.Номенклатура.НаименованиеПолное;
       
ТабДокумент.Вывести(ОбластьМакета);

КонецЦикла;

// Выводим итоги по документу
ОбластьМакета = Макет.ПолучитьОбласть("Итого");
ОбластьМакета.Параметры.Валюта = Шапка.ВалютаПредставление;

ОбластьМакета.Параметры.КоличествоПорядковыхНомеровЗаписейПрописью = ЧислоПрописью(КоличествоСтрок, ,",,,,,,,,0");
ОбластьМакета.Параметры.СуммаПрописью = СформироватьСуммуПрописью(?(ЗначениеЗаполнено(ВыборкаСтрокТоварыИтоги.СуммаСНДС),ВыборкаСтрокТоварыИтоги.СуммаСНДС,0), Шапка.ВалютаДокумента);

ТабДокумент.Вывести(ОбластьМакета);

// вывод подписей
ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
ОбластьМакета.Параметры.Заполнить(Шапка);
             
Руководители = ОтветственныеЛицаОрганизаций(Шапка.Организация, Шапка.ДатаДокумента,);
Бухгалтер    = ?(НЕ ЗначениеЗаполнено(Руководители.ГлавныйБухгалтер), "Не предусмотрен", Руководители.ГлавныйБухгалтер);
ОбластьМакета.Параметры.ГлБухгалтер = Бухгалтер;

ОбластьМакета.Параметры.ОтпускРазрешил = ОтветственныйДляПечати;
ОбластьМакета.Параметры.ОтпускРазрешилДолжность = ДолжностьОтветственного;

//ОбластьМакета.Параметры.Доверенность = СокрЛП(Шапка.Доверенность);
//ОбластьМакета.Параметры.ЧерезКого    = СокрЛП(Шапка.ЧерезКого);

// заполняем МОЛ
Если ЗначениеЗаполнено(Шапка.Склад) Тогда
ДанныеМОЛ = ДанныеФизЛица(Шапка.Организация, Шапка.МОЛ, Шапка.ДатаДокумента);
ОбластьМакета.Параметры.МОЛОтпустил = ДанныеМОЛ.Представление;
КонецЕсли;
ТабДокумент.Вывести(ОбластьМакета);

Возврат ТабДокумент;

КонецФункции // Печать()



Оффлайн pavl_vs

  • *****
  • Сообщений: 1052
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7

Оффлайн LexaK

  • *****
  • Сообщений: 1259
  • РЕПУТАЦИЯ: 345
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
у вас СсылкаНаОбъект не заполнена, поэтому такая ошибка,
уберите эту строку из программы,
сообщения об ошибке не будет, но и результата тоже :dfbbdrfb:
проверьте в отладчике вашу переменную - СсылкаНаОбъект!
     Запрос.УстановитьПараметр("Дата", СсылкаНаОбъект.Дата);

проверьте в отладчике(или сообщением)  вашу переменную - СсылкаНаОбъект!
     //Запрос.УстановитьПараметр("Дата", СсылкаНаОбъект.Дата);
    Сообщиить("Документ: " + СсылкаНаОбъект);



Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1098
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
пока проблема единственная...

это код из внешней печатной формы?
тогда функция должна называться просто Печать() и должна быть экспортная.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
пока проблема единственная...

это код из внешней печатной формы?
тогда функция должна называться просто Печать() и должна быть экспортная.

да из внешней печатной формы, функция Печать() экспортная есть, оттуда я вызываю данную фунцкию
Добавлено: 11 Фев 2016, 07:49

Абылайхан, ошибка в чем?

Описано в названии темы
Добавлено: 11 Фев 2016, 07:51

у вас СсылкаНаОбъект не заполнена, поэтому такая ошибка,
уберите эту строку из программы,
сообщения об ошибке не будет, но и результата тоже :dfbbdrfb:
проверьте в отладчике вашу переменную - СсылкаНаОбъект!
     Запрос.УстановитьПараметр("Дата", СсылкаНаОбъект.Дата);

проверьте в отладчике(или сообщением)  вашу переменную - СсылкаНаОбъект!
     //Запрос.УстановитьПараметр("Дата", СсылкаНаОбъект.Дата);
    Сообщиить("Документ: " + СсылкаНаОбъект);

Ну как же, это реквизит внешн печатной формы, которая обращается к данному обьекту, а как я должен обратиться к данному документу тогда?

Последний раз редактировалось: Абылайхан; 11 Фев 2016, 07:51. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1098
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Значит
    в какую-то из общих функций проваливается и там косячит.
Для этого
    локализуем проблему с помощью "Сообщить()". расставляем по коду и смотрим какие вывелись, какие нет.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Значит
    в какую-то из общих функций проваливается и там косячит.
Для этого
    локализуем проблему с помощью "Сообщить()". расставляем по коду и смотрим какие вывелись, какие нет.

Спасибо, так и оказалось.


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6490
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2943
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 865
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 992
Последний ответ 02 Дек 2016, 12:58
от Jalib
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7979
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
91 Сообщений
alex0402
43 Сообщений
AIFrame
42 Сообщений
Oldman06
31 Сообщений
vitasw
29 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
29 Сообщений
Golickoff Golickoff
27 Сообщений
Liv98 Liv98
20 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
DmitriyF DmitriyF
14 Сообщений

* Кто онлайн

  • Точка Гостей: 1078
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal