Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 19:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подчинённые справочники  (Прочитано 1551 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет.
Добавил 2 новых справочника (Таблицы,Таблицы1)
Эти 2 справочника подчинены справочнику Склады
В чём собственно проблема, справочник склады имеет (ну скажем) склад под название Резервуар 1
К этому складу подчинены 2 спр (Таблицы, Таблицы1) в которых есть какие то данные (Ну там объём, температура и т.д)
Я не могу достучаться до этих 2-ух новых справочников из документа
\Для Каждого Строка ИЗ ТабличнаяЧасть1  Цикл
    СпрСклады = Справочники.Склады.СоздатьЭлемент();
    СпрТабл = Справочники.Таблицы.СоздатьЭлемент();
   СпрТабл2= Справочники.Таблицы1.СоздатьЭлемент();
Побывал вот так но что то не пошло)))
Выборка = Справочники.Склады.Выбрать( , Владелец);
    Если Выборка.Следующий() = Истина Тогда
       Бла бла бла
    КонецЕсли;
Пишет что владельца не видит


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Выборка = Справочники.Склады.Выбрать( , Владелец);
и

Эти 2 справочника подчинены справочнику Склады
ничего не смущает?

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Выборка = Справочники.Склады.Выбрать( , Владелец);
и

Эти 2 справочника подчинены справочнику Склады
ничего не смущает?
Спасибо

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Что значит достучаться?

какой сакральный смысл вот в этом?
Для Каждого Строка ИЗ ТабличнаяЧасть1  Цикл
    СпрСклады = Справочники.Склады.СоздатьЭлемент();
    СпрТабл = Справочники.Таблицы.СоздатьЭлемент();
   СпрТабл2= Справочники.Таблицы1.СоздатьЭлемент();

и в этом?
Выборка = Справочники.Склады.Выбрать( , Владелец);
    Если Выборка.Следующий() = Истина Тогда
       Бла бла бла
    КонецЕсли;

естественно на Владелец ругается.
хотя бы потому, что у Склада нету никакого владельца...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Что значит достучаться?

какой сакральный смысл вот в этом?
Для Каждого Строка ИЗ ТабличнаяЧасть1  Цикл
    СпрСклады = Справочники.Склады.СоздатьЭлемент();
    СпрТабл = Справочники.Таблицы.СоздатьЭлемент();
   СпрТабл2= Справочники.Таблицы1.СоздатьЭлемент();

и в этом?
Выборка = Справочники.Склады.Выбрать( , Владелец);
    Если Выборка.Следующий() = Истина Тогда
       Бла бла бла
    КонецЕсли;

естественно на Владелец ругается.
хотя бы потому, что у Склада нету никакого владельца...
Смысл всего это,ЕСТЬ Градуированная таблица (СпрТаблицы) + Таблица миллиметров(СпрТаблицы1)
Пользователь заходит в документ проставляет номенклатуру + склад + УровеньНаНачало Смены
(УровеньНаНачалоэто и есть тот реквизит по которому потом будет всё считаться)
Нажимает кнопку рассчитать, и поехал расчёт, Все данные для расчёта забиты в этих 2-ух справочниках.
Я понял что у склада нету владельца,

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
точно точно должны быть подчиненные справочники?
не регистры сведений, не регистры накопления?

подчиненный справочник заполняется...
    НовыйЭлемент = Справочники.СпрТаблицы.СоздатьЭлемент();
    НовыйЭлемент.Владелец = Склад;
    ...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
точно точно должны быть подчиненные справочники?
не регистры сведений, не регистры накопления?

подчиненный справочник заполняется...
    НовыйЭлемент = Справочники.СпрТаблицы.СоздатьЭлемент();
    НовыйЭлемент.Владелец = Склад;
    ...
Можно было и регистры, я уже все понял, как мне до них достучатся, они заполнены в семёрки, щас перекину, и будет усё ок.))))
если я что то непонятно объяснил вот код из семёрки.
//Перем СпрТабл;
Процедура Вычислить()
   ВыбратьСтроки();
   Пока ПолучитьСтроку()=1 Цикл
    СпрСклады= СоздатьОбъект("Справочник.Склады");
    СпрТабл = СоздатьОбъект("Справочник.Таблицы");
   СпрТабл2= СоздатьОбъект("Справочник.Таблицы2");
   Если СпрСклады.НайтиЭлемент(Резервуар)=1 Тогда
       ТекРезервуар=СпрСклады.ТекущийЭлемент();
      СпрТабл.ИспользоватьВладельца(ТекРезервуар);
      СпрТабл2.ИспользоватьВладельца(ТекРезервуар);
      //
      СпрТабл.ВыбратьЭлементы();
      СпрТабл2.ВыбратьЭлементы();
      Пока СпрТабл.ПолучитьЭлемент()=1 Цикл
         ТекЭлемент=СпрТабл.ТекущийЭлемент();
            Если УровеньНач=ТекЭлемент.Уровень Тогда
            ОбъемНач=ТекЭлемент.Объем;
            МассаНач=ПлотностьНач*ОбъемНач;
            КонецЕсли;
            Если УровеньКон=ТекЭлемент.Уровень Тогда
            ОбъемКон=ТекЭлемент.Объем;
            МассаКон=ПлотностьКон*ОбъемКон;
         КонецЕсли;
      КонецЦикла;
      Пока СпрТабл2.ПолучитьЭлемент()=1 Цикл
         ТекЭлемент=СпрТабл2.ТекущийЭлемент();
         Если ммНач=ТекЭлемент.Уровень2 Тогда
            Объем2Нач=ТекЭлемент.Объем2;
            ОбъемНач=ОбъемНач+Объем2Нач;
            МассаНач=ПлотностьНач*ОбъемНач;   
         КонецЕсли;
             Если ммКон=ТекЭлемент.Уровень2 Тогда
            Объем2Кон=ТекЭлемент.Объем2;
            ОбъемКон=ОбъемКон+Объем2Кон;
            МассаКон=ПлотностьКон*ОбъемКон;   
         КонецЕсли;
      КонецЦикла;
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры 
                 

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну и?
даже готовый код есть, пусть и с 7ки.
осталось только правильно портировать.

кстати вопрос о целесообразности справочников - снимается.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Запрет на изменение "справочники - предприятие"

Автор maskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 960
Последний ответ 25 Июл 2016, 09:09
от SGIRG
Как сравнить Справочники.Номенклатура.СтавкаНДС = "18%";

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 350
Последний ответ 25 Окт 2017, 10:14
от Ivan94
Всем привет, подскажите пожалуйста как загрузить в БП 3.0 стандартные справочники(например виды номенклатур), буду премного благодарен

Автор DemlifeРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 690
Последний ответ 21 Мар 2016, 11:37
от Demlife
Всем привет, подскажите пожалуйста как загрузить в БП 3.0 стандартные справочники(например виды номенклатур), буду премного благодарен

Автор DemlifeРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 574
Последний ответ 21 Мар 2016, 11:37
от Demlife
Помогите пожалуйста в написании модуля формы Справочники.Организации! (ученик)

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1313
Последний ответ 17 Авг 2015, 11:25
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 283
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal