Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Мар 2017, 13:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Доработка ВПФ  (Прочитано 452 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sashasasha89

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-06
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте. Не судите строка только начинаю изучать 1с. Во внешнию печатную форму нужно добавить дополнительный реквизит. Макет подправил. Ссылку на реквизит нашел. Но не получается его подтянуть. Пожалуйста подскажите? http://i75.fastpic.ru/big/2016/0205/f7/01ef687765ae09600c9e1d1b1cd3e8f7.jpg


Оффлайн sashasasha89

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-06
  • Сайт: 
  • Профессия: Бухгалтер
Re: Доработка ВПФ
« Ответ #1: 06 Фев 2016, 10:41 »
Необходимо добавить Договор в печатную форму.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1096
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Доработка ВПФ
« Ответ #2: 06 Фев 2016, 12:07 »
могу ошибаться, но СсылкаНаОбъект - это для ВПФ для обычного приложения (для 10.3 и т.д.).
текущий печатаемый документ сидит в МассивОбъектов
вот из него и надо получать реквизиты
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн sashasasha89

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-06
  • Сайт: 
  • Профессия: Бухгалтер
Re: Доработка ВПФ
« Ответ #3: 06 Фев 2016, 12:15 »
Так?
Функция Печать() Экспорт
   перем КоллекцияПечатныхФорм;
   
   МассивОбъектов =новый массив;
   МассивОбъектов.Добавить(СсылкаНаОбъект);
   ОбъектыПечати =Неопределено;
   ТабДок = СформироватьПечатнуюФормуУПД(МассивОбъектов,ОбъектыПечати, Неопределено, );
   УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "УПДдляИП", "УПД для ИП", ТабДок);
   Возврат ТабДок;
КонецФункции

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1096
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Доработка ВПФ
« Ответ #4: 06 Фев 2016, 13:15 »
Нет.
Массив объектов "приходит снаружи".
Я практически не занимаюсь ВПФ для управляемого приложения, поэтому фиг знает, как там что устроено.
Главное что вы дорабатываете уже существующую ВПФ - разве нельзя посмотреть как там обращаются к реквизитам документа?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн sashasasha89

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-06
  • Сайт: 
  • Профессия: Бухгалтер
Re: Доработка ВПФ
« Ответ #5: 06 Фев 2016, 14:38 »
Так я с этого и начал. Пока что то не как поэтому и обратился за подсказкой к знающим людям.
Добавлено: 06 Фев 2016, 14:57

Сейчас провел эксперимент: вместо
ПараметрыШапки.Вставить("Договор", "Договор: "  + ДанныеПечати.Договор);
заменил на
ПараметрыШапки.Вставить("Договор", "Договор: "  + ДанныеПечати.Основание);
и основание в печатную форму подтянулось.

Добавлено: 06 Фев 2016, 15:06

Не правильно написал.
Сейчас провел эксперимент: вместо
ПараметрыШапки.Вставить("Договор", "Договор: "  + СсылкаНаОбъект.Договор);
заменил на
ПараметрыШапки.Вставить("Договор", "Договор: "  + ДанныеПечати.Основание);
и основание в печатную форму подтянулось.
Добавлено: 06 Фев 2016, 15:18

Так же Дату подтягивает. Через один реквизит работает. Хотя когда в табло делаешь то там все подтягиваются.
ПараметрыШапки.Вставить("Договор", "Договор: " + СсылкаНаОбъект.Дата);

Последний раз редактировалось: sashasasha89; 06 Фев 2016, 15:18. Причина: Объединение сообщений

Оффлайн sashasasha89

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-06
  • Сайт: 
  • Профессия: Бухгалтер
Re: Доработка ВПФ
« Ответ #6: 21 Фев 2016, 10:47 »
Как я понимаю у меня управляемая форма. Я СсылкаНаОбъект используется в обычных формах. Подскажите как можно вытащить значения реквизита? Как вытащить через массив?
Другие реквизиты вытаскиваются так:
ПараметрыШапки.Вставить("ПредставлениеПокупателя", "Покупатель: "
      + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПокупателе, "ПолноеНаименование", Ложь));

В ФормированиеПечатныхФорм есть код для договора:

Функция ПредставлениеОбъектаПечати(ДанныеПолучателя,ПреобразовыватьПредставлениеДокумента = Ложь)
   
   ТипСсылки = ТипЗнч(ДанныеПолучателя.СсылкаНаОбъектПечати);
   
   Если ТипСсылки = Тип("СправочникСсылка.ДоговорыКонтрагентов") Тогда
      Возврат НСтр("ru = 'Договор'") + " '" +  ДанныеПолучателя.ПредставлениеОбъектаПечати + "'";
   ИначеЕсли ТипСсылки = Тип("СправочникСсылка.СоглашенияСКлиентами") Тогда
      Возврат НСтр("ru = 'Соглашение с клиентом'") + " '" +  ДанныеПолучателя.ПредставлениеОбъектаПечати + "'";
   ИначеЕсли ТипСсылки = Тип("СправочникСсылка.СделкиСКлиентами") Тогда
      Возврат НСтр("ru = 'Сделка с клиентом'") + " '" +  ДанныеПолучателя.ПредставлениеОбъектаПечати + "'";
   ИначеЕсли ТипСсылки = Тип("СправочникСсылка.Партнеры") Тогда
      Возврат "";
   Иначе
      Если ПреобразовыватьПредставлениеДокумента Тогда
         
         НомерДокумента = ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(ДанныеПолучателя.НомерДокумента, Ложь, Истина);
         ДатаДокумента  = ДанныеПолучателя.ДатаДокумента;
         
         ПредставлениеДокумента = НСтр("ru='%Синоним% №%Номер% от %Дата%'");
         ПредставлениеДокумента = СтрЗаменить(ПредставлениеДокумента, "%Номер%", НомерДокумента);
         ПредставлениеДокумента = СтрЗаменить(ПредставлениеДокумента, "%Дата%", Формат(ДатаДокумента, "ДЛФ=D"));
         ПредставлениеДокумента = СтрЗаменить(ПредставлениеДокумента, "%Синоним%", ДанныеПолучателя.СинонимОбъектаМетаданных);
         Возврат ПредставлениеДокумента;
         
      Иначе
         Возврат ДанныеПолучателя.ПредставлениеОбъектаПечати;
      КонецЕсли;
   КонецЕсли;
   
КонецФункции

, но у меня не получается его вытащить.


Теги:
 

Доработка "ЛичнаяКарточкаФормаТ2" в ЗУП

Автор EiolveРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1232
Последний ответ 21 Июл 2012, 02:50
от Dethmontt
доработка в УТ10.3 документа "ОприходованиеТоваров"

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 297
Последний ответ 28 Ноя 2016, 08:42
от Jalib
Доработка УТ. Добавление поля в справочник "Номенклатура".

Автор grizelРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 8146
Последний ответ 16 Ноя 2010, 11:38
от Eugeneer
Доработка типового отчета "Ведомость по товарам на складах" на УТ 11.1.2.22

Автор lelikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 717
Последний ответ 24 Авг 2016, 10:51
от lelik
Перенесено: Требуется доработка 1С (написание отчетов и их печатных форм)

Автор cska-fanat-kzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1010
Последний ответ 06 Май 2014, 04:13
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
alex0402
124 Сообщений
MuI_I_Ika MuI_I_Ika
55 Сообщений
Norfolk
52 Сообщений
LexaK
51 Сообщений
alexandr_ll
25 Сообщений
друган
20 Сообщений
AsadRoman
18 Сообщений
Константин5825
18 Сообщений
ef0din
16 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal