Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2017, 15:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С УТ 11: отчет Комплектующие в сборке  (Прочитано 411 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cwiki

  • Модератор
  • *****
  • Сообщений: 8287
  • РЕПУТАЦИЯ: 10
  • КПД: 0%
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Программист 8.1
В этой задаче для хранения данных о том, какие именно комплектующие находятся на сборке — воспользуйтесь регистром сведений, назвав его «КомплектующиеНаСборке», Подчиненен регистратору — документ с именем «Сборка товаров». Измерение — «Номенклатура», Ресурс — «Количество»:

Скрин 1

После этого создайте новый общий модуль, а поле этого – подписку на событие:

Подписка будет иметь название «СборкаВРаботе», небходимый источник — Документ с именем «Сборка товаров», а событие — обработчик проведения:

Скрин 2

С целью подписки наилучшим вариантом будет создать новый общий модуль. Такой ход объясняется тем, что потом можно будет меньше менять саму конфигурацию.

После сделанного обработчике события пропишите нижеуказанный программный код:

Процедура СборкаСобранаОбработкаПроведения(Источник, Отказ, РежимПроведения) Экспорт
Если Источник.Статус = Перечисления.СтатусыСборокТоваров.ВРаботе Тогда
НаборЗаписей = Источник.Движения.КомплектующиеНаСборке;
Для Каждого Строка Из Источник.Товары Цикл
НоваяСтрока = НаборЗаписей.Добавить();
НоваяСтрока.Номенклатура = Строка.Номенклатура;
НоваяСтрока.Количество = Строка.Количество;
НоваяСтрока.Регистратор = Источник.Ссылка;
КонецЦикла;
НаборЗаписей.Записать();
КонецЕсли;
КонецПроцедуры

В ходе проведения документа под названием  «Сборка товаров» в статусе с именем «В работе» в регистр запишутся комплектующие, которые сейчас находятся на сборке.

Как создать отчета «Комплектующие в сборке»?

На основе заданных записей регистра сведений построить отчет очень легко.  Осуществим это на СКД.

Источник данный — запрос.

Запрос:

ВЫБРАТЬ
КомплектующиеНаСборке.Номенклатура,
СУММА(КомплектующиеНаСборке.Количество) КАК Количество
ИЗ
РегистрСведений.КомплектующиеНаСборке КАК КомплектующиеНаСборке
СГРУППИРОВАТЬ ПО
КомплектующиеНаСборке.Номенклатура

После этого настройте простое оформление.

И в результате получите простой отчет по тем позициям, которые в данный момент находятся на сборке:

Скрин 3


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
96 Сообщений
Dethmontt Dethmontt
71 Сообщений
alex0402
69 Сообщений
MuI_I_Ika MuI_I_Ika
61 Сообщений
wise wise
47 Сообщений
Сергей Федоров Сергей Федоров
41 Сообщений
ilyay ilyay
39 Сообщений
BuhRust
22 Сообщений
ilnur75
20 Сообщений
videomause
20 Сообщений

* Кто онлайн

  • Точка Гостей: 915
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal