Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июл 2017, 13:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обратиться к документу из модуля объекта  (Прочитано 961 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dirijabl

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-03
  • Сайт: 
Доброго времени суток. Подскажите пожалуйста, как из модуля объекта ВПФ обратиться к документу, из которого эта печатная форма вызывается?


Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Обычно добавляю реквизит в обработку с именем "СсылкаНаОбъект" и типом этого документа.
И в модуле обработки обратиться можно как "СсылкаНаОбъект".
Всё просто.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн Dirijabl

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-03
  • Сайт: 
В модуле формы- да. Но нужно именно из модуля объекта, где процедура формирования печатной формы. Если ВПФ просто вызывается из документа по кнопке Печать, а не как отдельная обработка, разве Ссылка на объект заполняется и в принципе модуль формы используется? Ну или у меня почему-то не заполняется...

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
вот пример
Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();

ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();
ПараметрыРегистрации.Версия = "1.0";
ПараметрыРегистрации.БезопасныйРежим = Ложь;

МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Справочник.Сотрудники"); //Указываем документ к которому делаем внешнюю печ. форму
ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);

ПараметрыРегистрации.Вставить("Наименование", "Справка в свободной форме (3 месяца)[Антивор]"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок

НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
НоваяКоманда.Представление = НСтр("ru = 'Справка в свободной форме (3 месяца)[Антивор]'");
НоваяКоманда.Идентификатор = "СправкаВСвободнойФорме";
НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
НоваяКоманда.ПоказыватьОповещение = Истина;
НоваяКоманда.Модификатор = "ПечатьMXL";

Возврат ПараметрыРегистрации;
КонецФункции

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт


УстановитьПривилегированныйРежим(Истина);

УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "СправкаВСвободнойФорме", "Справка в свободной форме за 3 месяца", СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати));

УстановитьПривилегированныйРежим(Ложь)

КонецПроцедуры // Печать()

Функция  СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати)
  тут заполняете пф
КонецФункции

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Dirijabl

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-03
  • Сайт: 
Все примерно так, как в образце, но... конкретнее опишу проблему. Есть Процедура ЗаполнитьРеквизитыПодвалаУПД(ОбластьПодвала, ДанныеПечати, СведенияОбОрганизации, СведенияОКонтрагенте), которая потом вызывается в процедуре Сформировать печатную форму. В первой процедуре есть запрос, где надо установить параметр - ссылку на документ, из которого вызывается печатная форма. Можно было бы написать Запрос.УстановитьПараметр("Документ",ДанныеПечати.Ссылка), но в туда попадает то нужный документ реализация, то счет-фактура. А мне нужна именно реализация, из которой впф вызывается! В связи с чем вопрос, можно ли обратиться к документу как-то по-другому? СсылкаНаОбъект срабатывает если открывать через файл-открыть, есть ли какой-то аналог для модуля объекта?

   

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
МассивОбъектов -  массив с документами которые выводятся на печать, передавайте его между процедурами
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Нда... Как всегда условие задачи непонятно. Сперва была ВПФ и модуль объекта, а потом уже обычная процедура в модуле объекта. Ты уж определись что конкретно нужно.:dfbsdfbsdf:
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс


Теги:
 

{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1897
Последний ответ 09 Дек 2015, 19:33
от Oks
Метод объекта не обнаружен. Но метод есть.

Автор ВитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 7397
Последний ответ 10 Фев 2015, 21:54
от vitasw
Ошибка "Поле объекта не обнаружено"

Автор KSV67Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3778
Последний ответ 29 Май 2014, 22:11
от KSV67
Общий реквизит или одинаковый реквизит для каждого объекта

Автор Соловьева Ольга_ИнтерсРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 787
Последний ответ 15 Июн 2015, 14:23
от cska-fanat-kz
Проблема "Метод объекта не обнаружен"

Автор aleks159Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1558
Последний ответ 13 Дек 2016, 16:34
от aleks159

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
92 Сообщений
oleg-x
80 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений
xproh
21 Сообщений

* Кто онлайн

  • Точка Гостей: 901
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal