Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Май 2017, 03:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проведен документ или нет?  (Прочитано 1178 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 3
  • КПД: 6%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
Подскажите, как можно проверить проведен документ или нет?

Есть форма дока)
В модуле формы ПриОткрытии() проверить проведен документ или нет)

Что-то типа
Если Проведен Тогда
  ...
КонецЕсли;

Не получается, ссылается на неизвестную переменную


Оффлайн pavl_vs

  • *****
  • Сообщений: 970
  • РЕПУТАЦИЯ: 154
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
В модуле формы ПриОткрытии() проверить проведен документ или нет)
....
Правильно так:
Если ЭтотОбъект.Проведен Тогда
    Сообщить("Проведен")
Иначе
    Сообщить("Не проведен")
КонецЕсли;
Ключевое здесь - ЭтотОбъект.

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 3
  • КПД: 6%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
Правильно так:
Если ЭтотОбъект.Проведен Тогда
    Сообщить("Проведен")
Иначе
    Сообщить("Не проведен")
КонецЕсли;
Ключевое здесь - ЭтотОбъект.

Аналогичный ответ компилятора))

Не получается, ссылается на неизвестную переменную

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Скорее всего он у вас ругается, если это новый документ, следовательно
Если Не Параметры.Ключ.Пустая() Тогда
   
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн pavl_vs

  • *****
  • Сообщений: 970
  • РЕПУТАЦИЯ: 154
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Анатолий Анпилогов, Rasty, мое предложение
Если ЭтотОбъект.Проведен Тогда
будучи встроенным, как хотелось ТС, в процедуру ПриОткрытии, работает без проблем. В случае формирования "Нового" идет по пути ИНАЧЕ.

ЗКБУ 1.0.90.1 на платформе 8.3.5.1482; документ "ВводПостоянногоНачисленияИлиУдержания...";
БГУ 1.0.38.5 на той же платформе; документ "АвансПодотчетномуЛицу".

А что у Вас?

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 67
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
Было бы неплохо увидеть оригинал ошибки и еще пометку это управляемые формы или нет. На вкладке "Движения" окна объекта посмотрите какое значение у свойства "Проведение" (мало вероятно конечно, но кто знает)
Если я Вам помог, нажми - Спасибо!

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 3
  • КПД: 6%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
Конфа Типовая УТ!
Было бы неплохо увидеть оригинал ошибки и еще пометку это управляемые формы или нет.

&НаКлиенте
Процедура ПриОткрытии(Отказ)

Если ЭтотОбъект.Проведен Тогда

Сообщить("!!");

КонецЕсли;

КонецПроцедуры

Возникающая ошибка, уже в самом Предприятии при открытии дока (Платформа 8.3), в 8.2 Эту ошибку выдает сразу в отладчике


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
УТ какая? 10 или 11?

Оффлайн pavl_vs

  • *****
  • Сообщений: 970
  • РЕПУТАЦИЯ: 154
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Анатолий Анпилогов, что за привычка отвечать на часть вопросов!?
В цитате вопрос о типе формы, ну и?

Если все же обычные формы.
Очень может быть, что в УТ этот признак имеет несколько отличное написание, например, Проведено.
Это легко установить либо в Синтакс-помощнике, либо в самом модуле: при написании кода после печать символа точки возникает выпадающее меню и в нем ищем нужное.

Оффлайн 1Cnastroika

Наверное, это УТ 11, форма управляемая, и нужно писать
Если Объект.Проведен Тогда

Потому что если бы была УТ 10, обычные формы, то можно было бы писать:

Если Проведен Тогда


Теги:
 

Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4132
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7739
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2617
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 16772
Последний ответ 10 Ноя 2010, 14:08
от Lexius
Документ "Сторно" в 1с 8.2 бух 2.0

Автор cannabis_86Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 11798
Последний ответ 09 Июн 2011, 12:57
от defers

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
81 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
49 Сообщений
Dethmontt Dethmontt
49 Сообщений
alex0402
43 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilyay ilyay
27 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 217
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal