Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Мар 2017, 13:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получить документ на основании  (Прочитано 498 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dirijabl

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-03
  • Сайт: 
Добрый день. Конфигурация УТ 11, необходимо получить документ Счет на оплату клиенту, введенный на основании Заказа клиента. Код в модуле:
Запрос = Новый Запрос;   
   Запрос.Текст =
     "ВЫБРАТЬ
     |   СвязанныеДокументы.Ссылка КАК СсылкаНаДокумент
     |ИЗ
     |   КритерийОтбора.СвязанныеДокументы(&Документ) КАК СвязанныеДокументы
     |ГДЕ
     |   СвязанныеДокументы.Ссылка ССЫЛКА Документ.СчетНаОплатуКлиенту"  ;
   Запрос.УстановитьПараметр("Документ", ДанныеПечати.Основание);
   Результат=Запрос.Выполнить().Выгрузить();   
   Для каждого НужныйДокумент из Результат Цикл
   НужныйДокумент = Результат[0];
        КонецЦикла;
Судя по консоли, запрос должен выводить правильное значение, в модуле параметр установлен верно, а дальше наверное неправильно вывожу результат. Помогите пожалуйста.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1096
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
что мешает запрос сразу к документам Счет на оплату сделать?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн LexaK

  • *****
  • Сообщений: 1174
  • РЕПУТАЦИЯ: 313
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Небольшая ошибка в цикле, запрос может вернуть несколько ссылок на документы (либо не одной)
попробуйте такой цикл
Если Результат.Количество() = 0 Тогда
   Сообщить("Нет ссылок");
Иначе
   Для каждого НужныйДокумент из Результат Цикл
      Сообщить(НужныйДокумент.СсылкаНаДокумент);
      //здесь можете что-то сделать с НужныйДокумент.СсылкаНаДокумент
   КонецЦикла;
КонецЕсли;
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Dirijabl

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-03
  • Сайт: 
Пробую, срабатывает первый вариант, нет ссылок. Но почему? Если проверить именно запрос, он возвращает нужное значение (скрин). Но когда смотрю Результат через отладчик, ссылки на документ нет. Может все же неправильно обрабатываю?

Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
хах, вы смотрите индексы и колонки нажмите на результат и нажмите F2
Добавлено: 03 Фев 2016, 14:40

 
Для каждого НужныйДокумент из Результат Цикл
   НужныйДокумент = Результат[0];
КонецЦикла;
а вот это вообще лишнее, если вы уже решили выбирать только один документ, то достаточно этого
НужныйДокумент = Результат[0];
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Dirijabl

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-03
  • Сайт: 
если выбирать только один, не в цикле - {ВнешняяОбработка.УПД.МодульОбъекта(376)}: Индекс находится за границами массива
   НужныйДокумент = Результат[0];

Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
значит ничего нет в результате запроса
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 

Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4041
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7277
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2289
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 15937
Последний ответ 10 Ноя 2010, 14:08
от Lexius
Документ "Сторно" в 1с 8.2 бух 2.0

Автор cannabis_86Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 11659
Последний ответ 09 Июн 2011, 12:57
от defers

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
alex0402
121 Сообщений
Norfolk
52 Сообщений
MuI_I_Ika MuI_I_Ika
52 Сообщений
LexaK
46 Сообщений
alexandr_ll
20 Сообщений
друган
20 Сообщений
AsadRoman
20 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal