Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Мар 2017, 22:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выпадающий список с типом документа  (Прочитано 825 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nianen

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-02
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, помогите пожалуйста новичку. Искала везде, но так и не получилось сделать. Нужно сделать поле выбора с выпадающим списком - типами документа. Чтоб пользователь выбрал тип документа и период, и были показаны все документы за данный период. Знаю что это приблизительно делается через Метаданные, но как именно?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1096
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для каждого ТекДокумент Из Метаданные.Документы Цикл
    СписокДокументов.Добавить(ТекДокумент.Имя,ТекДокумент.Синоним,ЛОЖЬ);
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн nianen

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-02
  • Сайт: 
  • Профессия: Ученик 1С
Для каждого ТекДокумент Из Метаданные.Документы Цикл
    СписокДокументов.Добавить(ТекДокумент.Имя,ТекДокумент.Синоним,ЛОЖЬ);
КонецЦикла;
Извините, может сильно туплю - запустила в консоли, выпадающий список с типами документов есть, но выбрать тип не дает, только документ

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1096
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
"выбрать тип не дает, только документ"
переведите
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн nianen

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-02
  • Сайт: 
  • Профессия: Ученик 1С
"выбрать тип не дает, только документ"
переведите
Не дает выбрать тип "Заказ покупателя", а только любой документ из данного типа, например "Заказ покупателя за 12.01.2015". А мне для общей задачи нужно выбрать период и тип, после чего появятся все подходящие документы.

Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
установите тип реквизита строка, заполните список выбора так, как говорит вам cska. После выбора нужного типа из списка открываете его форму
ПолучитьФорму("Документ." + ИмяВашегоРеквизита + ".Форма.ФормаСписка").Открыть();
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1096
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для каждого ТекДокумент Из Метаданные.Документы Цикл
    СписокДокументов.Добавить(ТекДокумент.Имя,ТекДокумент.Синоним,ЛОЖЬ);
КонецЦикла;

это я вытащил с обработки.
там это формировался список значений на форме.
юзверь отмечал флагом нужный ему элемент списка = нужный ему вид документа.
затем...
    Для каждого ЭлСписка Из СписокДокументов Цикл
        Если ЭлСписка.Пометка Тогда
            ВыборкаДокументов = Документы[ЭлСписка.Значение].Выбрать();
            ....
        КонецЕсли;
    КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3881
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 13692
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3332
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6770
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3789
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
147 Сообщений
alex0402
117 Сообщений
Norfolk
51 Сообщений
LexaK
47 Сообщений
MuI_I_Ika MuI_I_Ika
37 Сообщений
друган
21 Сообщений
AsadRoman
20 Сообщений
alexandr_ll
19 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 268
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal