Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2017, 15:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (Внешняя обработка)  (Прочитано 305 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 143
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, уважаемые! Делаю внешнюю обработку. Управляемое приложение.Мне нужно, что бы в переменную спр занеслись данные объекта по какому то коду(при чем в форме обработки не выбирается какого, я сам пишу какого, будь то справочник, документ или что нибудь другое) Добавил форму, кнопку, в модуле формы пишу: &НаКлиенте
Процедура ВыполнитьДействие(Команда)
   
     спр = Справочники.Номенклатура.НайтиПоКоду(00000001);   
   
КонецПроцедуры


Но пишет, что переменная справочники не определена. Подскажите, в чем ошибка? заранее спасибо!


Оффлайн meNTor

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 6
  • КПД: 35%
  • Регистрация: 2016-01-24
  • Сайт: 
  • Профессия: Программист 1С
Это выполнять надо &НаСервере и передавать на Клиента

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 67
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
Короче делаете вот так:
&НаКлиенте
Процедура ВыполнитьДействие(Команда)
   
     спр = ПолучитьСправочникПоКоду(00000001);   
   
КонецПроцедуры

&НаСервере
Процедура ПолучитьСправочникПоКоду(Код)
    Возврат Справочники.Номенклатура.НайтиПоКоду(Код);   
КонецПроцедуры
Если я Вам помог, нажми - Спасибо!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
85 Сообщений
wise wise
63 Сообщений
Dethmontt Dethmontt
60 Сообщений
MuI_I_Ika MuI_I_Ika
52 Сообщений
alex0402
49 Сообщений
ilyay ilyay
32 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilnur75
23 Сообщений
Дмитрий Медведков
19 Сообщений
magnifico61
18 Сообщений

* Кто онлайн

  • Точка Гостей: 335
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal