Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июл 2017, 15:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (Внешняя обработка)  (Прочитано 330 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 146
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, уважаемые! Делаю внешнюю обработку. Управляемое приложение.Мне нужно, что бы в переменную спр занеслись данные объекта по какому то коду(при чем в форме обработки не выбирается какого, я сам пишу какого, будь то справочник, документ или что нибудь другое) Добавил форму, кнопку, в модуле формы пишу: &НаКлиенте
Процедура ВыполнитьДействие(Команда)
   
     спр = Справочники.Номенклатура.НайтиПоКоду(00000001);   
   
КонецПроцедуры


Но пишет, что переменная справочники не определена. Подскажите, в чем ошибка? заранее спасибо!


Оффлайн meNTor

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 6
  • КПД: 35%
  • Регистрация: 2016-01-24
  • Сайт: 
  • Профессия: Программист 1С
Это выполнять надо &НаСервере и передавать на Клиента

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 68
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
Короче делаете вот так:
&НаКлиенте
Процедура ВыполнитьДействие(Команда)
   
     спр = ПолучитьСправочникПоКоду(00000001);   
   
КонецПроцедуры

&НаСервере
Процедура ПолучитьСправочникПоКоду(Код)
    Возврат Справочники.Номенклатура.НайтиПоКоду(Код);   
КонецПроцедуры
Если я Вам помог, нажми - Спасибо!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
94 Сообщений
oleg-x
82 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений
Dethmontt Dethmontt
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal