Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Мар 2017, 17:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (Внешняя обработка)  (Прочитано 285 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 137
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, уважаемые! Делаю внешнюю обработку. Управляемое приложение.Мне нужно, что бы в переменную спр занеслись данные объекта по какому то коду(при чем в форме обработки не выбирается какого, я сам пишу какого, будь то справочник, документ или что нибудь другое) Добавил форму, кнопку, в модуле формы пишу: &НаКлиенте
Процедура ВыполнитьДействие(Команда)
   
     спр = Справочники.Номенклатура.НайтиПоКоду(00000001);   
   
КонецПроцедуры


Но пишет, что переменная справочники не определена. Подскажите, в чем ошибка? заранее спасибо!

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн meNTor

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 6
  • КПД: 35%
  • Регистрация: 2016-01-24
  • Сайт: 
  • Профессия: Программист 1С
Это выполнять надо &НаСервере и передавать на Клиента

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 348
  • РЕПУТАЦИЯ: 65
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Разработчик 1С
Короче делаете вот так:
&НаКлиенте
Процедура ВыполнитьДействие(Команда)
   
     спр = ПолучитьСправочникПоКоду(00000001);   
   
КонецПроцедуры

&НаСервере
Процедура ПолучитьСправочникПоКоду(Код)
    Возврат Справочники.Номенклатура.НайтиПоКоду(Код);   
КонецПроцедуры
Если я Вам помог, нажми - Спасибо!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
148 Сообщений
alex0402
118 Сообщений
Norfolk
51 Сообщений
LexaK
48 Сообщений
MuI_I_Ika MuI_I_Ika
44 Сообщений
AsadRoman
22 Сообщений
друган
21 Сообщений
SlimShady
19 Сообщений
alexandr_ll
19 Сообщений
Константин5825
18 Сообщений

* Кто онлайн

  • Точка Гостей: 821
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal