Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Ноя 2018, 14:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите правильно вывести данные в отчет  (Прочитано 8362 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Суть задачи состоит в следующем: нужно вывести все начисления и удержания сотрудника за период (например, несколько месяцев). Я делаю следующим образом: перечень всех начислений и удержаний выгружаю в разные таблицы значений. С помощью этих Таблиц Значений вывожу шапку таблицы в отчете. Теперь нужно под каждым начислением или удержанием вывести соответствующую сумму. Для этого делаю запрос, с помощью которого выбираю все начисления и соответствующие им суммы,группирую по периоду. Затем обхожу запрос по группировкам и одновременно в цикле обхожу записи Таблицы Значений, в которой перечень всех начислений и таким образом нахожу место куда вывести сумму.Потом тоже самое делаю для удержаний. С начислениями вроде все в порядке, выводится правильно. Проблема возникает с удержаниями,они выводятся в строчку,а должны в столбик. Как это исправить???? На скриншоте, во вложениях, показано как выводится счас и как должно выводится. Надеюсь объяснила понятно) Вот код:

СтрокаЗаголовок1=Макет.ПолучитьОбласть("Строка|ОбластьШапка");
    Номер=0;
   Сумма=0;
   Запрос=Новый Запрос;
   Запрос.Текст="ВЫБРАТЬ РАЗРЕШЕННЫЕ РАЗЛИЧНЫЕ
                |   ОсновныеДополнительныеНачисления.Период КАК Период,
                |   ОсновныеДополнительныеНачисления.ВидРасчета КАК ВидРасчета,
                |   СУММА(ОсновныеДополнительныеНачисления.Результат) КАК Результат,
                |   ОсновныеДополнительныеНачисления.ОтработаноДней КАК ОтработаноДней,
                |   ВзаиморасчетыСРаботникамиОрганизацийОстаткиИОбороты.СуммаВзаиморасчетовНачальныйОстаток КАК СуммаВзаиморасчетовНачальныйОстаток
                |ИЗ
                |   (ВЫБРАТЬ РАЗЛИЧНЫЕ
                |      НАЧАЛОПЕРИОДА(ОсновныеНачисленияРаботниковОрганизаций.ПериодРегистрации, МЕСЯЦ) КАК Период,
                |      ОсновныеНачисленияРаботниковОрганизаций.ВидРасчета КАК ВидРасчета,
                |      СУММА(ОсновныеНачисленияРаботниковОрганизаций.Результат) КАК Результат,
                |      ОсновныеНачисленияРаботниковОрганизаций.ОтработаноДней КАК ОтработаноДней,
                |      ОсновныеНачисленияРаботниковОрганизаций.ФизЛицо КАК ФизЛицо
                |   ИЗ
                |      РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК ОсновныеНачисленияРаботниковОрганизаций
                |   ГДЕ
                |      ОсновныеНачисленияРаботниковОрганизаций.ПериодРегистрации МЕЖДУ НАЧАЛОПЕРИОДА(&НачалоПериода, МЕСЯЦ) И КОНЕЦПЕРИОДА(&КонецПериода, МЕСЯЦ)
                |      И ОсновныеНачисленияРаботниковОрганизаций.Организация = &Организация
                |      И ОсновныеНачисленияРаботниковОрганизаций.ФизЛицо = &ФизЛицо
                |   
                |   СГРУППИРОВАТЬ ПО
                |      ОсновныеНачисленияРаботниковОрганизаций.ВидРасчета,
                |      НАЧАЛОПЕРИОДА(ОсновныеНачисленияРаботниковОрганизаций.ПериодРегистрации, МЕСЯЦ),
                |      ОсновныеНачисленияРаботниковОрганизаций.ОтработаноДней,
                |      ОсновныеНачисленияРаботниковОрганизаций.ФизЛицо
                |   
                |   ОБЪЕДИНИТЬ ВСЕ
                |   
                |   ВЫБРАТЬ РАЗЛИЧНЫЕ
                |      НАЧАЛОПЕРИОДА(ДополнительныеНачисленияРаботниковОрганизаций.ПериодРегистрации, МЕСЯЦ),
                |      ДополнительныеНачисленияРаботниковОрганизаций.ВидРасчета,
                |      СУММА(ДополнительныеНачисленияРаботниковОрганизаций.Результат),
                |      0,
                |      ДополнительныеНачисленияРаботниковОрганизаций.ФизЛицо
                |   ИЗ
                |      РегистрРасчета.ДополнительныеНачисленияРаботниковОрганизаций КАК ДополнительныеНачисленияРаботниковОрганизаций
                |   ГДЕ
                |      ДополнительныеНачисленияРаботниковОрганизаций.ПериодРегистрации МЕЖДУ НАЧАЛОПЕРИОДА(&НачалоПериода, МЕСЯЦ) И КОНЕЦПЕРИОДА(&КонецПериода, МЕСЯЦ)
                |      И ДополнительныеНачисленияРаботниковОрганизаций.Организация = &Организация
                |      И ДополнительныеНачисленияРаботниковОрганизаций.ФизЛицо = &ФизЛицо
                |   
                |   СГРУППИРОВАТЬ ПО
                |      ДополнительныеНачисленияРаботниковОрганизаций.ВидРасчета,
                |      НАЧАЛОПЕРИОДА(ДополнительныеНачисленияРаботниковОрганизаций.ПериодРегистрации, МЕСЯЦ),
                |      ДополнительныеНачисленияРаботниковОрганизаций.ФизЛицо
                |   
                |   ОБЪЕДИНИТЬ ВСЕ
                |   
                |   ВЫБРАТЬ
                |      НАЧАЛОПЕРИОДА(УдержанияРаботниковОрганизаций.ПериодРегистрации, МЕСЯЦ),
                |      УдержанияРаботниковОрганизаций.ВидРасчета,
                |      УдержанияРаботниковОрганизаций.Результат,
                |      0,
                |      УдержанияРаботниковОрганизаций.ФизЛицо
                |   ИЗ
                |      РегистрРасчета.УдержанияРаботниковОрганизаций КАК УдержанияРаботниковОрганизаций
                |   ГДЕ
                |      УдержанияРаботниковОрганизаций.ПериодРегистрации МЕЖДУ НАЧАЛОПЕРИОДА(&НачалоПериода, МЕСЯЦ) И КОНЕЦПЕРИОДА(&КонецПериода, МЕСЯЦ)
                |      И УдержанияРаботниковОрганизаций.Организация = &Организация
                |      И УдержанияРаботниковОрганизаций.ФизЛицо = &ФизЛицо
                |   
                |   СГРУППИРОВАТЬ ПО
                |      НАЧАЛОПЕРИОДА(УдержанияРаботниковОрганизаций.ПериодРегистрации, МЕСЯЦ),
                |      УдержанияРаботниковОрганизаций.ВидРасчета,
                |      УдержанияРаботниковОрганизаций.Результат,
                |      УдержанияРаботниковОрганизаций.ФизЛицо
                |   
                |   ОБЪЕДИНИТЬ ВСЕ
                |   
                |   ВЫБРАТЬ
                |      НАЧАЛОПЕРИОДА(НДФЛРасчетыСБюджетом.Период, МЕСЯЦ),
                |      ""НДФЛ"",
                |      НДФЛРасчетыСБюджетом.Налог,
                |      0,
                |      НДФЛРасчетыСБюджетом.ФизЛицо
                |   ИЗ
                |      РегистрНакопления.НДФЛРасчетыСБюджетом КАК НДФЛРасчетыСБюджетом
                |   ГДЕ
                |      НДФЛРасчетыСБюджетом.Период МЕЖДУ НАЧАЛОПЕРИОДА(&НачалоПериода, МЕСЯЦ) И КОНЕЦПЕРИОДА(&КонецПериода, МЕСЯЦ)
                |      И НДФЛРасчетыСБюджетом.Организация = &Организация
                |      И НДФЛРасчетыСБюджетом.ФизЛицо = &ФизЛицо
                |   
                |   СГРУППИРОВАТЬ ПО
                |      НАЧАЛОПЕРИОДА(НДФЛРасчетыСБюджетом.Период, МЕСЯЦ),
                |      НДФЛРасчетыСБюджетом.Налог,
                |      НДФЛРасчетыСБюджетом.ФизЛицо) КАК ОсновныеДополнительныеНачисления
                |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций.ОстаткиИОбороты(&НачалоПериода, &КонецПериода, Месяц, , ) КАК ВзаиморасчетыСРаботникамиОрганизацийОстаткиИОбороты
                |      ПО ОсновныеДополнительныеНачисления.ФизЛицо = ВзаиморасчетыСРаботникамиОрганизацийОстаткиИОбороты.Физлицо
                |         И ОсновныеДополнительныеНачисления.Период = ВзаиморасчетыСРаботникамиОрганизацийОстаткиИОбороты.Период
                |ГДЕ
                |   ВзаиморасчетыСРаботникамиОрганизацийОстаткиИОбороты.Организация = &Организация
                |   И ВзаиморасчетыСРаботникамиОрганизацийОстаткиИОбороты.Физлицо = &Физлицо
                |   И ВзаиморасчетыСРаботникамиОрганизацийОстаткиИОбороты.Период МЕЖДУ НАЧАЛОПЕРИОДА(&НачалоПериода, МЕСЯЦ) И КОНЕЦПЕРИОДА(&КонецПериода, МЕСЯЦ)
                |   И ОсновныеДополнительныеНачисления.Результат <> 0
                |
                |СГРУППИРОВАТЬ ПО
                |   ОсновныеДополнительныеНачисления.ВидРасчета,
                |   ОсновныеДополнительныеНачисления.Период,
                |   ОсновныеДополнительныеНачисления.ОтработаноДней,
                |   ВзаиморасчетыСРаботникамиОрганизацийОстаткиИОбороты.СуммаВзаиморасчетовНачальныйОстаток
                |
                |УПОРЯДОЧИТЬ ПО
                |   Период,
                |   ОтработаноДней УБЫВ
                |ИТОГИ
                |   МАКСИМУМ(ОтработаноДней)
                |ПО
                |   Период ПЕРИОДАМИ(МЕСЯЦ, &НачалоПериода, &КонецПериода),
                |   СуммаВзаиморасчетовНачальныйОстаток";
            
            
   Запрос.УстановитьПараметр("НачалоПериода",ЭлементыФормы.ДатаНачала.Значение);
   Запрос.УстановитьПараметр("КонецПериода",ЭлементыФормы.ДатаОкончания.Значение);
   Запрос.УстановитьПараметр("Организация",ЭлементыФормы.Организация.Значение);
   Запрос.УстановитьПараметр("Физлицо",СтрокаТЧ.Сотрудник.Физлицо);
   
   ВыборкаПоПериоду = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Период");
   Пока ВыборкаПоПериоду.Следующий() Цикл
       ВыборкаПоНачальномуОстатку = ВыборкаПоПериоду.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "СуммаВзаиморасчетовНачальныйОстаток");
       Пока ВыборкаПоНачальномуОстатку.Следующий() Цикл
   
            СтрокаЗаголовок1.Параметры.Номер=Номер+1;
            МесяцСтрока=ПредставлениеПериода(НачалоМесяца(ВыборкаПоНачальномуОстатку.Период), КонецМесяца(ВыборкаПоНачальномуОстатку.Период), "ФП = Истина");
            СтрокаЗаголовок1.Параметры.Месяц=МесяцСтрока;          
            СтрокаЗаголовок1.Параметры.ОтработаноДней=ВыборкаПоНачальномуОстатку.ОтработаноДней;            
            СтрокаЗаголовок1.Параметры.ДолгНаНачало=ВыборкаПоНачальномуОстатку.СуммаВзаиморасчетовНачальныйОстаток;
            ТабДокумент.Вывести(СтрокаЗаголовок1);
      
            ДетальныеЗаписи = ВыборкаПоНачальномуОстатку.Выбрать();         
                           
             ОбластьНачисления=Макет.ПолучитьОбласть("Строка|Начисления");
           
          
            Для каждого СтрокаНачисления Из Начисления Цикл
            
                ДетальныеЗаписи.Сбросить();
                СтруктураПоиска = Новый Структура("ВидРасчета", СтрокаНачисления.ВидРасчета);                     
                            
                 Если ДетальныеЗаписи.НайтиСледующий(СтруктураПоиска) Тогда               
                     ОбластьНачисления.Параметры.Результат = ДетальныеЗаписи.Результат;
                  Сумма=Сумма+ДетальныеЗаписи.Результат;
                  Иначе                 
                  ОбластьНачисления.Параметры.Результат = 0;               
                КонецЕсли;
            
              ТабДокумент.Присоединить(ОбластьНачисления);
             
           КонецЦикла;
          
            ИтогоНачисления=Макет.ПолучитьОбласть("Строка|ИтогоНачисления");
            ИтогоНачисления.Параметры.ВсегоНачислено=Сумма;
            ТабДокумент.Присоединить(ИтогоНачисления);
            Сумма=0;
            
         КонецЦикла;
         
     КонецЦикла;
      
/////////////////////////////////////////////////////////////////////////////////////////////

     ОбластьУдержания=Макет.ПолучитьОбласть("Строка|Удержания");
    
     Запрос=Новый Запрос;
     Запрос.Текст="ВЫБРАТЬ
               |   Удержания.Период КАК Период,
               |   Удержания.ВидРасчета,
               |   СУММА(Удержания.Результат) КАК Результат
               |ИЗ
               |   (ВЫБРАТЬ
               |      НАЧАЛОПЕРИОДА(УдержанияРаботниковОрганизаций.ПериодРегистрации, МЕСЯЦ) КАК Период,
               |      УдержанияРаботниковОрганизаций.ВидРасчета КАК ВидРасчета,
               |      УдержанияРаботниковОрганизаций.Результат КАК Результат
               |   ИЗ
               |      РегистрРасчета.УдержанияРаботниковОрганизаций КАК УдержанияРаботниковОрганизаций
               |   ГДЕ
               |      УдержанияРаботниковОрганизаций.ФизЛицо = &ФизЛицо
               |      И УдержанияРаботниковОрганизаций.Организация = &Организация
               |      И УдержанияРаботниковОрганизаций.ПериодРегистрации МЕЖДУ НАЧАЛОПЕРИОДА(&НачалоПериода, МЕСЯЦ) И КОНЕЦПЕРИОДА(&КонецПериода, МЕСЯЦ)
               |   
               |   СГРУППИРОВАТЬ ПО
               |      НАЧАЛОПЕРИОДА(УдержанияРаботниковОрганизаций.ПериодРегистрации, МЕСЯЦ),
               |      УдержанияРаботниковОрганизаций.ВидРасчета,
               |      УдержанияРаботниковОрганизаций.Результат
                |   
               |   ОБЪЕДИНИТЬ ВСЕ
               |   
               |   ВЫБРАТЬ
               |      НАЧАЛОПЕРИОДА(НДФЛРасчетыСБюджетом.Период, МЕСЯЦ),
               |      ""НДФЛ"",
               |      НДФЛРасчетыСБюджетом.Налог
               |   ИЗ
               |      РегистрНакопления.НДФЛРасчетыСБюджетом КАК НДФЛРасчетыСБюджетом
               |   ГДЕ
               |      НДФЛРасчетыСБюджетом.Организация = &Организация
               |      И НДФЛРасчетыСБюджетом.ФизЛицо = &ФизЛицо
               |      И НДФЛРасчетыСБюджетом.Период МЕЖДУ НАЧАЛОПЕРИОДА(&НачалоПериода, МЕСЯЦ) И КОНЕЦПЕРИОДА(&КонецПериода, МЕСЯЦ)
               |   
               |   СГРУППИРОВАТЬ ПО
               |      НАЧАЛОПЕРИОДА(НДФЛРасчетыСБюджетом.Период, МЕСЯЦ),
               |      НДФЛРасчетыСБюджетом.Налог) КАК Удержания
               |
               |СГРУППИРОВАТЬ ПО
               |   Удержания.Период,
               |   Удержания.ВидРасчета
               |ИТОГИ ПО
               |   Период";
               
               
   Запрос.УстановитьПараметр("НачалоПериода",ЭлементыФормы.ДатаНачала.Значение);
   Запрос.УстановитьПараметр("КонецПериода",ЭлементыФормы.ДатаОкончания.Значение);
   Запрос.УстановитьПараметр("Организация",ЭлементыФормы.Организация.Значение);
   Запрос.УстановитьПараметр("Физлицо",СтрокаТЧ.Сотрудник.Физлицо);
   
   ВыборкаПоПериоду = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Период");
   Пока ВыборкаПоПериоду.Следующий() Цикл
       ДетальныеЗаписи=ВыборкаПоПериоду.Выбрать();
      
       Для каждого СтрокаТЗУдержания Из ТЗУдержания Цикл
          ДетальныеЗаписи.Сбросить();
          СтруктураПоиска = Новый Структура("ВидРасчета", СтрокаТЗУдержания.ВидРасчета);                     
                            
               Если ДетальныеЗаписи.НайтиСледующий(СтруктураПоиска) Тогда               
                  ОбластьУдержания.Параметры.РезультатУд = ДетальныеЗаписи.Результат;
                  Сумма=Сумма+ДетальныеЗаписи.Результат;
               Иначе                 
                ОбластьУдержания.Параметры.РезультатУд = 0;               
               КонецЕсли;
            
              ТабДокумент.Присоединить(ОбластьУдержания);
             
      КонецЦикла;
          
            ИтогоУдержания=Макет.ПолучитьОбласть("Строка|ИтогоУдержания");
            ИтогоУдержания.Параметры.ВсегоУдержано=Сумма;
            ТабДокумент.Присоединить(ИтогоУдержания);
            Сумма=0;
         
       КонецЦикла;            


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1101
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Пока точно не могу сказать как, но надо составить запрос так чтобы в результате получалась каждая отдельная строка твоего отчета:
Начисление1, Начисление2, Начисление3,...,Удержание1, Удержание2,...

Вогнать этот запрос в функцию, возвращающую список значений (см. выше) а параметры - НачалоПериода и КонецПериода.

Далее гоняешь цикл: Месяц1, Месяц2, Месяц3,... и в нем вызываешь функцию с параметрами НачалоМесяца(Месяц1), КонецМесяца(Месяц1) и т.д.


А вообще в самом идеале - чтобы все это формировалось одним запросом, а уж потом его в СхемуКомпоновкиДанных и ввиде таблицы (строки - Месяцы; Колонки - Виды расчета)...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Подскажите, пожалуйста, как посчитать итог по каждой колонке табличного документа?

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Подскажите, пожалуйста, как посчитать итог по каждой колонке табличного документа?

Как мне кажется, наиболее верно - считать итоги сразу, при формировании табличного документа.
Но в принципе, можно посчитать и в табличном документе.
	ТабДок = ЭлементыФормы.ПолеТабличногоДокумента1;
    Макет = ПолучитьМакет("Макет");
ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
ТабДок.Вывести(ОбластьМакета);
ТабДок.Показать();

Сумма = 0;
Для НомерСтр = 1 ПО ТабДок.ВысотаТаблицы Цикл
Сумма = Сумма + ТабДок.Область("R" + НомерСтр + "C1").Текст;
КонецЦикла;

Сообщить(Сумма);

В данном коде нет ряда проверок: на пустое поле + для количества строк от 1000 (пробел в отображении числа 1 000).

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Что то у меня не получается((( Пытаюсь сделать так:

ОбластьПодвал=Макет.ПолучитьОбласть("Подвал|ОбластьШапка");      
      ТабДокумент.Вывести(ОбластьПодвал);
      
      ОбластьПодвал1=Макет.ПолучитьОбласть("Подвал|Начисления");
      
      ОбластьНачисления=Макет.ПолучитьОбласть("Строка|Начисления");
      
      Сумма = 0;
        Для НомерСтр = 1 По ТабДокумент.ВысотаТаблицы Цикл
      Сумма = Сумма + ОбластьНачисления.Параметры.Результат;
      ОбластьПодвал1.Параметры.Итого=Сумма;
      ТабДокумент.Присоединить(ОбластьПодвал1);
       КонецЦикла;

Считает какую то кривату(((

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Что то у меня не получается((( Пытаюсь сделать так:

ОбластьПодвал=Макет.ПолучитьОбласть("Подвал|ОбластьШапка");      
      ТабДокумент.Вывести(ОбластьПодвал);
      
      ОбластьПодвал1=Макет.ПолучитьОбласть("Подвал|Начисления");
      
      ОбластьНачисления=Макет.ПолучитьОбласть("Строка|Начисления");
      
      Сумма = 0;
        Для НомерСтр = 1 По ТабДокумент.ВысотаТаблицы Цикл
      Сумма = Сумма + ОбластьНачисления.Параметры.Результат;
      ОбластьПодвал1.Параметры.Итого=Сумма;
      ТабДокумент.Присоединить(ОбластьПодвал1);
       КонецЦикла;

Считает какую то кривату(((
А почему у вас НомерСтр = 1? У вас же с 16 начинается.
И для чего вам цикл я не очень понимаю, если НомерСтр вы в нем нигде не используете....
Я же привел пример.

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
ну я хочу пробежаться по строкам колонки, сложить суммы и вывести в итог. И так для каждой колонки.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Сумма = 0;
Для НомерСтр = 16 ПО ТабДок.ВысотаТаблицы Цикл
Сумма = Сумма + ТабДок.Область("R" + НомерСтр + "C1").Текст; // это для первой колонки (С1), для десятой будет ТабДок.Область("R" + НомерСтр + "C10!!!!!!!").Текст
КонецЦикла;

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Выдает ошибку(((

{Форма.Форма(498)}: Ошибка при вызове метода контекста (Область): Область не найдена: R16С6
      Сумма = Сумма + ТабДокумент.Область("R" + НомерСтр + "С6").Текст;

Оффлайн Люсёк

  • ***
  • Сообщений: 109
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2010-10-11
  • Сайт: 
Все получилось, спасибо))


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4944
Последний ответ 24 Дек 2015, 15:34
от дфтын
На фото демонстрируется личная карточка сотрудника, но во столбце "ЗА ЯКИЙ ПЕРІОД " не показывает ничего, как это можно решить, помогите пожалуйста

Автор cBeginnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 325
Последний ответ 26 Июл 2018, 17:44
от alex0402
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6204
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6486
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5560
Последний ответ 10 Сен 2015, 13:57
от Dm109

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
69 Сообщений
AIFrame AIFrame
59 Сообщений
wise wise
51 Сообщений
alex0402
46 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
46 Сообщений
alexandr_ll
45 Сообщений
BuhRust
30 Сообщений
LexaK
25 Сообщений
andron81_81
24 Сообщений
byte777
21 Сообщений

* Кто онлайн

  • Точка Гостей: 203
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal