Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Янв 2017, 09:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (Копирование строк из ТЧ документа в ТЧ другого документа в Обычном приложении)  (Прочитано 669 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 134
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, уважаемые форумчане! Суть вопроса следующая: нужно сделать обработку, которая копирует строки из табличной части одного документа, и вставляет их в табличную часть другого документа. Все это делается в обычном приложении. Набросал вот такой код:   

Процедура КнопкаВыполнитьНажатие(Кнопка)
   
   ДокументИсточник = Документы.уатОприходованиеТоваров.ПолучитьСсылку().ПолучитьОбъект();
   
   Запрос = Новый Запрос;
   Запрос.Текст =
   
    "ВЫБРАТЬ
    |   уатОприходованиеТоваров.Товары.(
    |      Номенклатура,
    |      ЕдиницаИзмерения,
    |      Количество,
    |      Коэффициент,
    |      Цена,
    |      Сумма
    |   )
    |ИЗ
    |   Документ.уатОприходованиеТоваров КАК уатОприходованиеТоваров";
   
      РезультатЗапроса = Запрос.Выполнить().Выбрать();
      
   
   
   Пока РезультатЗапроса.Следующий() Цикл
      
      
      ДокументПриемник = Документы.ОприходованиеТоваров.ПолучитьСсылку().ПолучитьОбъект();

      СтрокаТабличнойЧасти = ДокументПриемник.Товары.Добавить();
      СтрокаТабличнойЧасти.Номенклатура = РезультатЗапроса.Номенклатура;
      СтрокаТабличнойЧасти.ЕдиницаИзмерения = РезультатЗапроса.ЕдиницаИзмерения;
      СтрокаТабличнойЧасти.Количество = РезультатЗапроса.Количество;
      СтрокаТабличнойЧасти.Коэффициент = РезультатЗАпроса.Коэффициент;
      СтрокаТабличнойЧасти.Цена = РезультатЗапроса.Цена;
      СтрокаТабличнойЧасти.Сумма = РезультатЗапроса.Сумма;
      
   КонецЦикла;   
   
КонецПроцедуры



Проверить данный код пока не могу, по некоторым обстоятельствам. Подскажите пожалуйста, я правильно все написал, или же это работать не будет? Подскажите правильное решение. Заранее всем спасибо!

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ДокументПриемникОбъект = ДокументПриемник.ПолучитьОбъект();
Для каждого СтрокаТЧ Из ДокументИсточник.ТабличнаяЧасть Цикл
    НоваяСтрока = ДокументПриемникОбъект.Добавить();
    ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаТЧ);
КонецЦикла;
ДокументПриемникОбъект.Записать();
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Рассчет НДФЛ в документе "Начисление зарплаты" при вводе строк вручную

Автор AzgerdРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2884
Последний ответ 28 Янв 2013, 08:33
от Azgerd
Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3119
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2606
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
как настроить реглам.отчетность, чтобы из расшифровок строк попадать в оборотно-сальдовые ведомости

Автор ВофисРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1062
Последний ответ 06 Авг 2015, 09:36
от vitasw
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4850
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
alex0402
56 Сообщений
MuI_I_Ika MuI_I_Ika
49 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
28 Сообщений
sertak sertak
25 Сообщений
Vzonder
21 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal