Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
06 Мар 2021, 17:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (Копирование строк из ТЧ документа в ТЧ другого документа в Обычном приложении)  (Прочитано 5302 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 191
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, уважаемые форумчане! Суть вопроса следующая: нужно сделать обработку, которая копирует строки из табличной части одного документа, и вставляет их в табличную часть другого документа. Все это делается в обычном приложении. Набросал вот такой код:   

Процедура КнопкаВыполнитьНажатие(Кнопка)
   
   ДокументИсточник = Документы.уатОприходованиеТоваров.ПолучитьСсылку().ПолучитьОбъект();
   
   Запрос = Новый Запрос;
   Запрос.Текст =
   
    "ВЫБРАТЬ
    |   уатОприходованиеТоваров.Товары.(
    |      Номенклатура,
    |      ЕдиницаИзмерения,
    |      Количество,
    |      Коэффициент,
    |      Цена,
    |      Сумма
    |   )
    |ИЗ
    |   Документ.уатОприходованиеТоваров КАК уатОприходованиеТоваров";
   
      РезультатЗапроса = Запрос.Выполнить().Выбрать();
      
   
   
   Пока РезультатЗапроса.Следующий() Цикл
      
      
      ДокументПриемник = Документы.ОприходованиеТоваров.ПолучитьСсылку().ПолучитьОбъект();

      СтрокаТабличнойЧасти = ДокументПриемник.Товары.Добавить();
      СтрокаТабличнойЧасти.Номенклатура = РезультатЗапроса.Номенклатура;
      СтрокаТабличнойЧасти.ЕдиницаИзмерения = РезультатЗапроса.ЕдиницаИзмерения;
      СтрокаТабличнойЧасти.Количество = РезультатЗапроса.Количество;
      СтрокаТабличнойЧасти.Коэффициент = РезультатЗАпроса.Коэффициент;
      СтрокаТабличнойЧасти.Цена = РезультатЗапроса.Цена;
      СтрокаТабличнойЧасти.Сумма = РезультатЗапроса.Сумма;
      
   КонецЦикла;   
   
КонецПроцедуры



Проверить данный код пока не могу, по некоторым обстоятельствам. Подскажите пожалуйста, я правильно все написал, или же это работать не будет? Подскажите правильное решение. Заранее всем спасибо!


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Сообщений: 5748
  • РЕПУТАЦИЯ: 1105
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ДокументПриемникОбъект = ДокументПриемник.ПолучитьОбъект();
Для каждого СтрокаТЧ Из ДокументИсточник.ТабличнаяЧасть Цикл
    НоваяСтрока = ДокументПриемникОбъект.Добавить();
    ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаТЧ);
КонецЦикла;
ДокументПриемникОбъект.Записать();
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Рассчет НДФЛ в документе "Начисление зарплаты" при вводе строк вручную

Автор AzgerdРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 4686
Последний ответ 28 Янв 2013, 08:33
от Azgerd
Очищается один реквизит объекта на форме при изменении другого реквизита объекта на форме

Автор AsadRomanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 3781
Последний ответ 03 Авг 2018, 17:37
от AsadRoman
Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6567
Последний ответ 13 Апр 2012, 23:26
от Vit1501
1С 8.3 - Как присвоить стандартному реквизиту "Наименование" одного справочника, ссылку на реквизит другого справочника?

Автор АлирзаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3531
Последний ответ 09 Ноя 2017, 08:47
от alex0402
как настроить реглам.отчетность, чтобы из расшифровок строк попадать в оборотно-сальдовые ведомости

Автор ВофисРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3360
Последний ответ 06 Авг 2015, 09:36
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
LexaK
34 Сообщений
antoneus antoneus
32 Сообщений
Алексей_1985_06
29 Сообщений
BuhRust
20 Сообщений
ls600 ls600
18 Сообщений
kah
15 Сообщений
DNN
11 Сообщений
DmitriyF DmitriyF
11 Сообщений
Ивашка
9 Сообщений

* Кто онлайн

  • Точка Гостей: 227
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal