Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Янв 2017, 15:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: как правильно получить форму моего документа в управляемых формах  (Прочитано 349 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Raideres

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-02
  • Сайт: 
  • Профессия: Программист 8.1
&НаКлиенте
Процедура План(Команда)
ПланНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПланНаСервере()
НовДок =документы.ВЗ_СкользящийПланРеализацияУФ.СоздатьДокумент();
НовДок.Дата= текущаяДата();
//**************************************Признак ДОКУМЕНТА
НайдЭлемент = Справочники.ВЗ_Константы.НайтиПоНаименованию("ПризнакиСкользящегоГрафика");
Если не НайдЭлемент = Справочники.ВЗ_Константы.ПустаяСсылка() Тогда
НайдСтрока = НайдЭлемент.ДоступныеЗначения.Найти("План", "Значение");
Если НЕ НайдСтрока = Неопределено Тогда
НовДок.ПризнакДокумента = НайдСтрока.Значение;
Конецесли;
КонецЕСли;
//**************************************Ответственный и Область
ПользОбласть = Справочники.ВЗ_Константы.НайтиПоНаименованию("СоответсвиеПользователейОбластиПродаж");
НайдРегион = ПользОбласть.ДоступныеЗначения.Найти(ПараметрыСеанса.ТекущийПользователь,"Значение");
Если НайдРегион <> Неопределено тогда
новдок.ПризнакМеста = НайдРегион.Соответствие;
новдок.ОтветственныйКтоСоздал = НайдРегион.Значение;
КонецЕсли;

//******************АлкогольнаяПродукция*****
НайдЭлемент = Справочники.ВЗ_Константы.НайтиПоНаименованию("АлкогольнаяПродукция");
Если Не НайдЭлемент = Справочники.ВЗ_Константы.ПустаяСсылка() Тогда
ТзКонстанты =  НайдЭлемент.ДоступныеЗначения.Выгрузить();
КонецЕсли;

//*******************************************
Запрос = новый запрос;
Запрос.Текст = "ВЫБРАТЬ
| Номенклатура.Родитель,
| Номенклатура.Ссылка,
| Номенклатура.ЕдиницаИзмеренияМест КАК ЕдиницаИзмеренияМест
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.Родитель = &Родитель
|
|УПОРЯДОЧИТЬ ПО
| ЕдиницаИзмеренияМест";
//**************************************
//Кузнецк
ТЧКузнецк = НовДок.Кузнецк;

для каждого стрК из ТзКонстанты цикл
стр1 = ТЧКузнецк.Добавить();
стр1.Наименование = стрК.Значение;
конецЦикла;

//**************************************
ОбработкаПрерыванияПользователя();
новдок.ОстаткиВизит.Очистить();  ///убираем остатки

//***********************Открываем форму

НовДок.ЭтоНовый();


Форма=НовДок.ПолучитьФорму("ФормаДокумента");
Форма.Открыть();

КонецПроцедуры

на форме списка есть кнопка создать документ,в итоге создаю документ открывается но почему то форма документа ни я которую создал а другая выходит.ПолучитьФорму("ФормаДокумента"); имя правильное

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн Raideres

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-02
  • Сайт: 
  • Профессия: Программист 8.1

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 12690
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2603
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4847
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2910
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 906
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
55 Сообщений
MuI_I_Ika MuI_I_Ika
48 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
31 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 918
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal