Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2017, 17:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Учет перемещений продукции между складами - 1С 8.3  (Прочитано 920 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн laby

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-01-21
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Вот пытаюсь сделать программку учета ...

Имеется производство. Скажем 5 групп складов между которыми перемещается продукция.
Создал справочник иерархический Склады. Группа складов, движение может быть из группы Склады1 в группу Склады2, из Склады2 в Склады3, итд

Создал Документ Движение. В нем выбираю группы складов из и в какой идет движение.
Как мне сделать, чтобы при выборе из складов, в Склады заполнялось автоматически.

А по табличной части - чтобы из склада - выбирались склады той группы, которая выбрана в шапке документа, а не по всем группам. И соответственно в склад - выбор был только из группы складов, которая в шапке документа выбрана "В склады".

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн ПростоБосс

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2012-01-11
  • Сайт: 
  • Профессия: Программист 1С
Просто в процедуре ПриИзменении() для реквизита формы СоСклада нужно установить для реквизита НаСклад признак ВыборИзСписка в истину и список выбора для этого реквизита по тому отбору, который вас устраивает.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. каким то образом организуйте связь между группами складов
2. в табличной части при выборе склада должен накладываться отбор на соответствующую группу.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн laby

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-01-21
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ИзСкладовПриИзменении(Элемент)
   ИзСкладовПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ИзСкладовПриИзмененииНаСервере()
   НоваяСвязь = Новый СвязьПараметраВыбора("Отбор.Родитель", "Объект.ИзСкладов");
   НовыйМассив = Новый Массив();
   НовыйМассив.Добавить(НоваяСвязь);
   НовыеСвязи = Новый ФиксированныйМассив(НовыйМассив);
   Элементы.ПеремещениеИзСклада.СвязиПараметровВыбора = НовыеСвязи;
   
   Объект.ВСклады = Справочники.ПоследовательностиПеремещений.НайтиПоРеквизиту("ИзСкладов", Объект.ИзСкладов).ВСклады;
   ВСкладыПриИзмененииНаСервере();
КонецПроцедуры

&НаКлиенте
Процедура ВСкладыПриИзменении(Элемент)
   ВСкладыПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ВСкладыПриИзмененииНаСервере()
   НоваяСвязь = Новый СвязьПараметраВыбора("Отбор.Родитель", "Объект.ВСклады");
   НовыйМассив = Новый Массив();
   НовыйМассив.Добавить(НоваяСвязь);
   НовыеСвязи = Новый ФиксированныйМассив(НовыйМассив);
   Элементы.ПеремещениеВСклад.СвязиПараметровВыбора = НовыеСвязи;
КонецПроцедуры

Добавлено: 21 Янв 2016, 14:50

в текст строчку дописал а файл обновит время истекло.

Последний раз редактировалось: laby; 21 Янв 2016, 14:50. Причина: Объединение сообщений


Теги:
 

Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1780
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Общий модуль. Бух. учет. Модуль (26)

Автор mas-804Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1198
Последний ответ 05 Авг 2015, 14:41
от Mila24
ПБУ 3/2006 - ПОЛОЖЕНИЕ ПО БУХГАЛТЕРСКОМУ УЧЕТУ "УЧЕТ АКТИВОВ И ОБЯЗАТЕЛЬСТВ, СТОИМОСТЬ КОТОРЫХ ВЫРАЖЕНА В ИНОСТРАННОЙ ВАЛЮТЕ" [ПБУ 3]

Автор MuI_I_IkaРаздел Нормативная база

Ответов: 0
Просмотров: 2798
Последний ответ 08 Июл 2014, 16:09
от MuI_I_Ika
Отчет "ВедомостьПоЗатратам и Партионный учет"

Автор ValentusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 37
Просмотров: 17522
Последний ответ 28 Май 2010, 13:40
от Myti
восстановить учет после после уреза базы

Автор NarimanРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 3259
Последний ответ 16 Июн 2011, 15:02
от Nariman

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
95 Сообщений
alex0402
69 Сообщений
Dethmontt Dethmontt
67 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
61 Сообщений
ilyay ilyay
42 Сообщений
Сергей Федоров Сергей Федоров
34 Сообщений
magnifico61
25 Сообщений
ilnur75
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

  • Точка Гостей: 502
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal