Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 07:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Учет перемещений продукции между складами - 1С 8.3  (Прочитано 1370 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн laby

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-01-21
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Вот пытаюсь сделать программку учета ...

Имеется производство. Скажем 5 групп складов между которыми перемещается продукция.
Создал справочник иерархический Склады. Группа складов, движение может быть из группы Склады1 в группу Склады2, из Склады2 в Склады3, итд

Создал Документ Движение. В нем выбираю группы складов из и в какой идет движение.
Как мне сделать, чтобы при выборе из складов, в Склады заполнялось автоматически.

А по табличной части - чтобы из склада - выбирались склады той группы, которая выбрана в шапке документа, а не по всем группам. И соответственно в склад - выбор был только из группы складов, которая в шапке документа выбрана "В склады".


Оффлайн ПростоБосс

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2012-01-11
  • Сайт: 
  • Профессия: Программист 1С
Просто в процедуре ПриИзменении() для реквизита формы СоСклада нужно установить для реквизита НаСклад признак ВыборИзСписка в истину и список выбора для этого реквизита по тому отбору, который вас устраивает.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. каким то образом организуйте связь между группами складов
2. в табличной части при выборе склада должен накладываться отбор на соответствующую группу.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн laby

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-01-21
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ИзСкладовПриИзменении(Элемент)
   ИзСкладовПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ИзСкладовПриИзмененииНаСервере()
   НоваяСвязь = Новый СвязьПараметраВыбора("Отбор.Родитель", "Объект.ИзСкладов");
   НовыйМассив = Новый Массив();
   НовыйМассив.Добавить(НоваяСвязь);
   НовыеСвязи = Новый ФиксированныйМассив(НовыйМассив);
   Элементы.ПеремещениеИзСклада.СвязиПараметровВыбора = НовыеСвязи;
   
   Объект.ВСклады = Справочники.ПоследовательностиПеремещений.НайтиПоРеквизиту("ИзСкладов", Объект.ИзСкладов).ВСклады;
   ВСкладыПриИзмененииНаСервере();
КонецПроцедуры

&НаКлиенте
Процедура ВСкладыПриИзменении(Элемент)
   ВСкладыПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ВСкладыПриИзмененииНаСервере()
   НоваяСвязь = Новый СвязьПараметраВыбора("Отбор.Родитель", "Объект.ВСклады");
   НовыйМассив = Новый Массив();
   НовыйМассив.Добавить(НоваяСвязь);
   НовыеСвязи = Новый ФиксированныйМассив(НовыйМассив);
   Элементы.ПеремещениеВСклад.СвязиПараметровВыбора = НовыеСвязи;
КонецПроцедуры

Добавлено: 21 Янв 2016, 14:50

в текст строчку дописал а файл обновит время истекло.

Последний раз редактировалось: laby; 21 Янв 2016, 14:50. Причина: Объединение сообщений


Теги:
 

Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2411
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Общий модуль. Бух. учет. Модуль (26)

Автор mas-804Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1587
Последний ответ 05 Авг 2015, 14:41
от Mila24
ПБУ 3/2006 - ПОЛОЖЕНИЕ ПО БУХГАЛТЕРСКОМУ УЧЕТУ "УЧЕТ АКТИВОВ И ОБЯЗАТЕЛЬСТВ, СТОИМОСТЬ КОТОРЫХ ВЫРАЖЕНА В ИНОСТРАННОЙ ВАЛЮТЕ" [ПБУ 3]

Автор MuI_I_IkaРаздел Нормативная база

Ответов: 0
Просмотров: 3269
Последний ответ 08 Июл 2014, 16:09
от MuI_I_Ika
При старте системы выдает ошибку ВнешняяОбработка.Платформа.МодульОбъекта(111):Значение не является значением объектного типа(ТипМножественноеЧисло) конфигурация Полный учет в отделе ИТ(2017.3.1)

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 461
Последний ответ 20 Сен 2017, 09:10
от Геннадий ОбьГЭС
Обмен данными между 1С УТ (базовая) 8.2 редакция 10.3 и Розница (базовая) редакция 1.0

Автор Андрей ОлимпиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 4985
Последний ответ 17 Мар 2015, 20:16
от дфтын

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 298
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal