Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Мар 2017, 05:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выделить ЧекиККМ в форме списка по условию  (Прочитано 238 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Михаил Демин

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-25
  • Сайт: 
Хочу сделать в форме списка ЧековККМ подсветку определенных чеков. Для этого выбираю из регистра накопления ссылки на чеки. Но вот как их выделить не пойму

Делаю это в модуле формы списка чековККМ
 &НаСервере
 Процедура ПометитьСДолгами()
    Запрос = Новый Запрос;
Запрос.Текст ="ВЫБРАТЬ
  | ЕСТЬNULL(СУММА(ДолгиКлиентовОстатки.СуммаОстаток), 0)   КАК Остаток,
  | ДолгиКлиентовОстатки.ЧекККМ  КАК Чек
  |ИЗ
  | РегистрНакопления.ДолгиКлиентов.Остатки КАК ДолгиКлиентовОстатки
  |
  |СГРУППИРОВАТЬ ПО
  | ДолгиКлиентовОстатки.ЧекККМ" ;

Результат = Запрос.Выполнить();
Выборка=Результат.Выбрать();

Пока Выборка.Следующий() цикл
Если Выборка.Остаток>0 Тогда
                Чек=Выборка.Чек;
//тут чтото надо дописать

КонецЕсли;
КонецЦикла;

КонецПроцедуры

Пробовал Элементы.Номер1.ЦветФона = WebЦвета.Оранжевый; но она изменяет фон у всех чеков


Оффлайн 1Cnastroika

Открыть форму списка. Открыть палитру свойств реквизита "ЧекиККМ" тип ДинамическийСписок. Нажать кнопку Настройка списка: Открыть.На закладке "Условное оформление" добавить стиль оформления и условие для оформляемых строк.


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1109
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1766
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1919
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Модуль к форме "Настройка заполнения"

Автор oyufedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3873
Последний ответ 17 Янв 2014, 16:35
от oyufed
Отображение HTML-макета в форме с HTML-полем.

Автор spikee666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2880
Последний ответ 21 Авг 2014, 17:51
от spikee666

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
alex0402
114 Сообщений
Norfolk
51 Сообщений
LexaK
45 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
друган
21 Сообщений
alexandr_ll
20 Сообщений
AsadRoman
20 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 305
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal