Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Мар 2017, 15:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: v8.3: Как программно сформировать внешнюю печатную форму документа  (Прочитано 1040 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zerbite

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-26
  • Сайт: 
  • Профессия: Программист 1С
Доброго дня, всем.

Имеется обработка в которой есть реквизит Объект.ПрихНакл, в которой хранится ссылка на документ ПоступлениеТоваровУслуг, для этого документа прописана внешняя печатная форма "Приемо-сдаточный акт", из документа все печатает. а как эту форму сформировать из обработки, или с любого другого случайного места?


Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 40
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Сделать в обработке кнопку "Печать" - > скопировать обработчик из внешней печатной формы. Довести код до ума.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн zerbite

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-26
  • Сайт: 
  • Профессия: Программист 1С
Сделать в обработке кнопку "Печать" - > скопировать обработчик из внешней печатной формы. Довести код до ума.
в обработке уже есть кнопка печать
только что в нее записать не пойму, и информации адекватной тоже найти не могу.

Добавлено: 15 Янв 2016, 11:21

во внешней печ.форме есть вот такие строки
// Функция формирует печатную форму Приемо-сдаточный акт документа.
//
Функция СформироватьПечатнуюФормуПриемоСдаточногоАкта(МассивОбъектов, ОбъектыПечати)  Экспорт //Нетиповое

КолонкаКодов = ФормированиеПечатныхФорм.ИмяДополнительнойКолонки();
ВыводитьКоды = ЗначениеЗаполнено(КолонкаКодов);

ИспользоватьРучныеСкидки = ПолучитьФункциональнуюОпцию("ИспользоватьРучныеСкидкиВЗакупках");

ТабличныйДокумент = Новый ТабличныйДокумент;
ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПоступлениеТоваровУслуг_Акт";

Запрос = Новый Запрос("ВЫБРАТЬ
                      | ПоступлениеТоваровУслуг.Ссылка КАК Ссылка,
                      | ПоступлениеТоваровУслуг.Номер КАК Номер,
                      | ПоступлениеТоваровУслуг.Дата КАК Дата,
                      | ПоступлениеТоваровУслуг.Контрагент КАК Контрагент,
                      | ПоступлениеТоваровУслуг.Организация КАК Организация,
                      | ПоступлениеТоваровУслуг.Валюта КАК Валюта,
                      | ТранспортноеСредство.Значение КАК ТС,
                      | ВидЛома.Значение КАК ВидЛома,
                      | АктСобств.Значение КАК АктСобств
                      |ИЗ
                      | Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ПоступлениеТоваровУслугДополнительныеРеквизиты.Значение КАК Значение,
                      | ПоступлениеТоваровУслугДополнительныеРеквизиты.Ссылка КАК Ссылка
                      | ИЗ
                      | Документ.ПоступлениеТоваровУслуг.ДополнительныеРеквизиты КАК ПоступлениеТоваровУслугДополнительныеРеквизиты
                      | ГДЕ
                      | ПоступлениеТоваровУслугДополнительныеРеквизиты.Свойство = &СвойствоТранспортноеСредство
                      | И ПоступлениеТоваровУслугДополнительныеРеквизиты.Ссылка В(&МассивДокументов)) КАК ТранспортноеСредство
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ТранспортноеСредство.Ссылка
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ПоступлениеТоваровУслугДополнительныеРеквизиты.Ссылка КАК Ссылка,
                      | ПоступлениеТоваровУслугДополнительныеРеквизиты.Значение КАК Значение
                      | ИЗ
                      | Документ.ПоступлениеТоваровУслуг.ДополнительныеРеквизиты КАК ПоступлениеТоваровУслугДополнительныеРеквизиты
                      | ГДЕ
                      | ПоступлениеТоваровУслугДополнительныеРеквизиты.Свойство = &СвойствоВидЛома
                      | И ПоступлениеТоваровУслугДополнительныеРеквизиты.Ссылка В(&МассивДокументов)) КАК ВидЛома
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВидЛома.Ссылка
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ПоступлениеТоваровУслугДополнительныеРеквизиты.Значение КАК Значение,
                      | ПоступлениеТоваровУслугДополнительныеРеквизиты.Ссылка КАК Ссылка
                      | ИЗ
                      | Документ.ПоступлениеТоваровУслуг.ДополнительныеРеквизиты КАК ПоступлениеТоваровУслугДополнительныеРеквизиты
                      | ГДЕ
                      | ПоступлениеТоваровУслугДополнительныеРеквизиты.Ссылка В(&МассивДокументов)
                      | И ПоступлениеТоваровУслугДополнительныеРеквизиты.Свойство = &СвойствоАктСобств) КАК АктСобств
                      | ПО ПоступлениеТоваровУслуг.Ссылка = АктСобств.Ссылка
                      |ГДЕ
                      | ПоступлениеТоваровУслуг.Ссылка В(&МассивДокументов)
                      | И ПоступлениеТоваровУслуг.Проведен
                      |
                      |УПОРЯДОЧИТЬ ПО
                      | Ссылка
                      |;
                      |
                      |////////////////////////////////////////////////////////////////////////////////
                      |ВЫБРАТЬ
                      | ВложенныйЗапрос.Ссылка КАК Ссылка,
                      | ВложенныйЗапрос.Номенклатура КАК Номенклатура,
                      | ВложенныйЗапрос.Характеристика КАК Характеристика,
                      | ВложенныйЗапрос.ВесБрутто КАК ВесБрутто,
                      | ВложенныйЗапрос.Цена КАК Цена,
                      | ВложенныйЗапрос.Количество КАК Количество,
                      | ВложенныйЗапрос.Сумма КАК Сумма,
                      | ВложенныйЗапрос.НомерСтроки КАК НомерСтроки,
                      | ВложенныйЗапрос.ВесТары КАК ВесТары,
                      | ВложенныйЗапрос.Засоренность КАК Засоренность
                      |ИЗ
                      | (ВЫБРАТЬ
                      | ПоступлениеТоваровУслуг.Ссылка КАК Ссылка,
                      | ПоступлениеТоваровУслуг.Номенклатура КАК Номенклатура,
                      | ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 1
                      | ТОГДА Засоренность1.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 2
                      | ТОГДА Засоренность2.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 3
                      | ТОГДА Засоренность3.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 4
                      | ТОГДА Засоренность4.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 5
                      | ТОГДА Засоренность5.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 6
                      | ТОГДА Засоренность6.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 7
                      | ТОГДА Засоренность7.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 8
                      | ТОГДА Засоренность8.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 9
                      | ТОГДА Засоренность9.Значение
                      | ИНАЧЕ Засоренность10.Значение
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ КАК Засоренность,
                      | ПоступлениеТоваровУслуг.Характеристика КАК Характеристика,
                      | ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 1
                      | ТОГДА ВесБрутто1.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 2
                      | ТОГДА ВесБрутто2.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 3
                      | ТОГДА ВесБрутто3.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 4
                      | ТОГДА ВесБрутто4.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 5
                      | ТОГДА ВесБрутто5.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 6
                      | ТОГДА ВесБрутто6.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 7
                      | ТОГДА ВесБрутто7.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 8
                      | ТОГДА ВесБрутто8.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 9
                      | ТОГДА ВесБрутто9.Значение
                      | ИНАЧЕ ВесБрутто10.Значение
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ КАК ВесБрутто,
                      | ПоступлениеТоваровУслуг.Цена КАК Цена,
                      | ПоступлениеТоваровУслуг.КоличествоУпаковок КАК Количество,
                      | ПоступлениеТоваровУслуг.Сумма КАК Сумма,
                      | ПоступлениеТоваровУслуг.НомерСтроки КАК НомерСтроки,
                      | ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 1
                      | ТОГДА ВесТары1.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 2
                      | ТОГДА ВесТары2.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 3
                      | ТОГДА ВесТары3.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 4
                      | ТОГДА ВесТары4.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 5
                      | ТОГДА ВесТары5.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 6
                      | ТОГДА ВесТары6.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 7
                      | ТОГДА ВесТары7.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 8
                      | ТОГДА ВесТары8.Значение
                      | ИНАЧЕ ВЫБОР
                      | КОГДА ПоступлениеТоваровУслуг.НомерСтроки = 9
                      | ТОГДА ВесТары9.Значение
                      | ИНАЧЕ ВесТары10.Значение
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ
                      | КОНЕЦ КАК ВесТары
                      | ИЗ
                      | Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность1
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность1
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность1.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность2
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность2
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность2.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность3
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность3
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность3.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность4
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность4
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность4.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность5
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность5
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность5.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность6
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность6
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность6.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность7
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность7
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность7.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность8
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность8
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность8.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность9
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность9
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность9.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоЗасоренность10
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК Засоренность10
                      | ПО ПоступлениеТоваровУслуг.Ссылка = Засоренность10.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто1
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто1
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто1.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто2
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто2
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто2.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто3
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто3
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто3.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто4
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто4
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто4.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто5
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто5
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто5.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто6
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто6
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто6.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто7
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто7
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто7.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто8
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто8
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто8.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто9
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто9
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто9.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесБрутто10
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесБрутто10
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесБрутто10.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары1
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары1
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары1.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары2
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары2
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары2.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары3
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары3
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары3.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары4
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары4
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары4.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары5
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары5
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары5.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары6
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары6
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары6.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары7
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары7
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары7.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары8
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары8
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары8.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары9
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары9
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары9.Объект
                      | ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                      | ДополнительныеСведения.Объект КАК Объект,
                      | ДополнительныеСведения.Значение КАК Значение
                      | ИЗ
                      | РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
                      | ГДЕ
                      | ДополнительныеСведения.Свойство = &СвойствоВесТары10
                      | И ДополнительныеСведения.Объект В(&МассивДокументов)) КАК ВесТары10
                      | ПО ПоступлениеТоваровУслуг.Ссылка = ВесТары10.Объект
                      | ГДЕ
                      | ПоступлениеТоваровУслуг.Ссылка В(&МассивДокументов)
                      | И ПоступлениеТоваровУслуг.Ссылка.Проведен
                      | И ПоступлениеТоваровУслуг.Номенклатура.ТипНоменклатуры = ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.Товар)) КАК ВложенныйЗапрос
                      |
                      |УПОРЯДОЧИТЬ ПО
                      | ВложенныйЗапрос.Ссылка,
                      | НомерСтроки
                      |ИТОГИ
                      | СУММА(Сумма)
                      |ПО
                      | Ссылка");

Запрос.УстановитьПараметр("МассивДокументов", МассивОбъектов);
Запрос.УстановитьПараметр("СвойствоТранспортноеСредство", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Транспортное средство"));
Запрос.УстановитьПараметр("СвойствоВидЛома", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВидЛома"));
Запрос.УстановитьПараметр("СвойствоАктСобств", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("АктСобств"));
Запрос.УстановитьПараметр("СвойствоЗасоренность1", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность1"));
Запрос.УстановитьПараметр("СвойствоЗасоренность2", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность2"));
Запрос.УстановитьПараметр("СвойствоЗасоренность3", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность3"));
Запрос.УстановитьПараметр("СвойствоЗасоренность4", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность4"));
Запрос.УстановитьПараметр("СвойствоЗасоренность5", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность5"));
Запрос.УстановитьПараметр("СвойствоЗасоренность6", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность6"));
Запрос.УстановитьПараметр("СвойствоЗасоренность7", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность7"));
Запрос.УстановитьПараметр("СвойствоЗасоренность8", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность8"));
Запрос.УстановитьПараметр("СвойствоЗасоренность9", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность9"));
Запрос.УстановитьПараметр("СвойствоЗасоренность10", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Засоренность10"));
Запрос.УстановитьПараметр("СвойствоВесБрутто1", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто1"));
Запрос.УстановитьПараметр("СвойствоВесБрутто2", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто2"));
Запрос.УстановитьПараметр("СвойствоВесБрутто3", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто3"));
Запрос.УстановитьПараметр("СвойствоВесБрутто4", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто4"));
Запрос.УстановитьПараметр("СвойствоВесБрутто5", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто5"));
Запрос.УстановитьПараметр("СвойствоВесБрутто6", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто6"));
Запрос.УстановитьПараметр("СвойствоВесБрутто7", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто7"));
Запрос.УстановитьПараметр("СвойствоВесБрутто8", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто8"));
Запрос.УстановитьПараметр("СвойствоВесБрутто9", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто9"));
Запрос.УстановитьПараметр("СвойствоВесБрутто10", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесБрутто10"));
Запрос.УстановитьПараметр("СвойствоВесТары1", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары1"));
Запрос.УстановитьПараметр("СвойствоВесТары2", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары2"));
Запрос.УстановитьПараметр("СвойствоВесТары3", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары3"));
Запрос.УстановитьПараметр("СвойствоВесТары4", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары4"));
Запрос.УстановитьПараметр("СвойствоВесТары5", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары5"));
Запрос.УстановитьПараметр("СвойствоВесТары6", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары6"));
Запрос.УстановитьПараметр("СвойствоВесТары7", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары7"));
Запрос.УстановитьПараметр("СвойствоВесТары8", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары8"));
Запрос.УстановитьПараметр("СвойствоВесТары9", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары9"));
Запрос.УстановитьПараметр("СвойствоВесТары10", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВесТары10"));

МассивРезультатов   = Запрос.ВыполнитьПакет();
ДанныеПечати        = МассивРезультатов[0].Выбрать();
ВыборкаПоДокументам = МассивРезультатов[1].Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

ПервыйДокумент = Истина;
//й=0;
Пока ДанныеПечати.Следующий() Цикл
//й=й+1;
//Сообщить(й);
// Найдем в выборке товары по текущему документу
СтруктураПоиска = Новый Структура("Ссылка", ДанныеПечати.Ссылка);
НайденСледующий = ВыборкаПоДокументам.НайтиСледующий(СтруктураПоиска);

// Если в накладной только услуги - перейдем к следующему документу
Если НайденСледующий Тогда
ВыборкаПоТоварам = ВыборкаПоДокументам.Выбрать();
Иначе
Продолжить;
КонецЕсли;

// Макет необходимо получать для каждого документа, т.к. размеры колонок изменяются динамически
Макет = ПолучитьМакет("ПриемоСдаточныйАкт");
//Сообщить(Макет);

Если Не ПервыйДокумент Тогда
ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ПервыйДокумент    = Ложь;
НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;

// Выводим шапку приемо-сдаточного акта
ОбластьМакета = Макет.ПолучитьОбласть("ШапкаТаб");
ОбластьМакета.Параметры.ТекстЗаголовка = "Приемо-сдаточный акт № "+ДанныеПечати.Номер+" от "+ Формат(Дата(ДанныеПечати.Дата), "ДФ='дд ММММ гггг'");
ПредставлениеОрг = ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Организация, ДанныеПечати.Дата), "ПолноеНаименование, ЮридическийАдрес");
ОбластьМакета.Параметры.ПолучательЛома = ПредставлениеОрг;

Если ДанныеПечати.Контрагент.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ЮрЛицо Тогда
Представление = ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Контрагент, ДанныеПечати.Дата), "ПолноеНаименование, ЮридическийАдрес");
ОбластьМакета.Параметры.ПоставщикЛома = Представление;
Иначе
Представление = ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Контрагент, ДанныеПечати.Дата), "ПолноеНаименование");
ОбластьМакета.Параметры.ПоставщикЛома = Представление;
КонецЕсли;

Представление = ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Контрагент, ДанныеПечати.Дата), "ИНН") + ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Контрагент, ДанныеПечати.Дата), "КПП");
ОбластьМакета.Параметры.ПоставщикИНН = Представление;

Представление = ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Контрагент, ДанныеПечати.Дата), "НомерСчета,Банк,БИК,КоррСчет");
ОбластьМакета.Параметры.ПоставщикБанк = Представление;

Если ДанныеПечати.Контрагент.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ЮрЛицо Тогда

Иначе
Представление = ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ДанныеПечати.Контрагент, ДанныеПечати.Дата), "ЮридическийАдрес");
ОбластьМакета.Параметры.Паспорт = ДанныеПечати.Контрагент.ДополнительнаяИнформация+" ,"+Представление;
КонецЕсли;

ОбластьМакета.Параметры.Транспорт = ДанныеПечати.ТС;
ОбластьМакета.Параметры.Акт = ДанныеПечати.АктСобств;
Описание = ДанныеПечати.ВидЛома;
ОбластьМакета.Параметры.Описание = Описание;

ТабличныйДокумент.Вывести(ОбластьМакета);

Вес = 0;
Сум = 0;

// Выводим строки таблицы Товары
ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаб");

Пока ВыборкаПоТоварам.Следующий() Цикл

ОбластьМакета.Параметры.Вид = ВыборкаПоТоварам.Номенклатура;
ОбластьМакета.Параметры.ВесБрутто = ВыборкаПоТоварам.ВесБрутто;
ОбластьМакета.Параметры.ВесТары = ВыборкаПоТоварам.ВесТары;
ОбластьМакета.Параметры.Засоренность = ВыборкаПоТоварам.Засоренность;
ОбластьМакета.Параметры.Количество = ВыборкаПоТоварам.Количество;
ОбластьМакета.Параметры.Цена = ВыборкаПоТоварам.Цена;
ОбластьМакета.Параметры.Сумма = ВыборкаПоТоварам.Сумма;
Вес = Вес + ВыборкаПоТоварам.Количество;
Сум = Сум + ВыборкаПоТоварам.Сумма;
ТабличныйДокумент.Вывести(ОбластьМакета);

КонецЦикла;

// Выводим подвал
ОбластьМакета = Макет.ПолучитьОбласть("ПодвалТаб");
ОбластьМакета.Параметры.Сум = Сум;
ОбластьМакета.Параметры.Вес = Вес;

// Выводим Сумму прописью
ОбластьМакета.Параметры.СумПр = РаботаСКурсамиВалют.СформироватьСуммуПрописью(Сум, ДанныеПечати.Валюта);
ОбластьМакета.Параметры.ВесПр = СформироватьВесПрописью(Вес);

ТабличныйДокумент.Вывести(ОбластьМакета);

УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, НомерСтрокиНачало, ОбъектыПечати, ДанныеПечати.Ссылка);

КонецЦикла;

ТабличныйДокумент.АвтоМасштаб = Истина;

Если ПривилегированныйРежим() Тогда
УстановитьПривилегированныйРежим(Ложь);
КонецЕсли;

Возврат ТабличныйДокумент;

КонецФункции // СформироватьПечатнуюФормуПриемоСдаточногоАкта()



Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ПриемоСдаточныйАкт", "Приемо-сдаточный акт", СформироватьПечатнуюФормуПриемоСдаточногоАкта(МассивОбъектов[0], ОбъектыПечати));
КонецПроцедуры // Печать()


что из этого нужно перенести в обработку?

Последний раз редактировалось: zerbite; 15 Янв 2016, 11:21. Причина: Объединение сообщений

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 40
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Весь текст функции: "Функция СформироватьПечатнуюФормуПриемоСдаточногоАкта"
И в конце заменить <<Возврат ТабличныйДокумент>> на <<ТабличныйДокумент.Показать()>>
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн LexaK

  • *****
  • Сообщений: 1174
  • РЕПУТАЦИЯ: 313
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
у меня на БП3.0 вызов внешней печатной формы работает так,
пример: замените на свои данные/названия/наименования
    ...
        лкПечатьСчФ = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("Счет-фактура (общий)");
МодульДополнительныеОтчетыИОбработки = ОбщегоНазначения.ОбщийМодуль("ДополнительныеОтчетыИОбработки"); //? почему так, не разбирался, работает-же
Обработка = МодульДополнительныеОтчетыИОбработки.ПолучитьОбъектВнешнейОбработки(лкПечатьСчФ);
Обработка.Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода)
    ...
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн zerbite

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-26
  • Сайт: 
  • Профессия: Программист 1С
Весь текст функции: "Функция СформироватьПечатнуюФормуПриемоСдаточногоАкта"
И в конце заменить <<Возврат ТабличныйДокумент>> на <<ТабличныйДокумент.Показать()>>
сейчас если печатаешь из документа то результат выходит в спец.форму (обработку) печать документов
как на скрине во вложениях. А если заменить этого не будет.

и потом через стандартный механизм можно сразу не сколько документов туда отправить (и даже разных видов)
Добавлено: 19 Янв 2016, 09:38

у меня на БП3.0 вызов внешней печатной формы работает так,
пример: замените на свои данные/названия/наименования
    ...
        лкПечатьСчФ = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("Счет-фактура (общий)");
МодульДополнительныеОтчетыИОбработки = ОбщегоНазначения.ОбщийМодуль("ДополнительныеОтчетыИОбработки"); //? почему так, не разбирался, работает-же
Обработка = МодульДополнительныеОтчетыИОбработки.ПолучитьОбъектВнешнейОбработки(лкПечатьСчФ);
Обработка.Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода)
    ...

добрый день, спасибо за ваш ответ... я такое уже видел, но в УТ11 нету этих общих модулей... к сожалению... а аналогов я не смог найти...
я сейчас реализовал вот так
Процедура ПечатьИзВПФ(ИмяВПФ);  //
    СсылкаНаВПФ = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяВПФ);
    Если СсылкаНаВПФ.Пустая() Тогда
        Сообщить("В справочнике 'Внешние обработки' не нашли внешнюю печатную форму с наименованием '"+ИмяВПФ+"'");
        Возврат;
    КонецЕсли;
       
    Попытка
        ИмяВременногоФайла = КаталогВременныхФайлов()+"тмп_впф.epf";
    Исключение
        Сообщить ("Невозможно создать файл обработке в каталоге временных файлов <<"+
        +КаталогВременныхФайлов()+">>. Возможно, не хватает прав доступа в Windows в папку для данного сеанса 1С ");
        Возврат;
    КонецПопытки;   
   
    ДвоичныеДанные = СсылкаНаВПФ.ХранилищеОбработки.Получить();       
    ДвоичныеДанные.Записать(ИмяВременногоФайла);
   
    Попытка
        ОбрОбъект = ВнешниеОбработки.Создать(ИмяВременногоФайла);
        //ОбрОбъект.ДокОбъект = ЭтотОбъект; // НЕ исп. метод скопировать. Передать ТАК - особенности ВДГБ;
    Исключение
        Сообщить("Ошибка создания объекта из временного файла обработки "+ИмяВременногоФайла);
        Возврат;
    КонецПопытки;
   
    МассивОбъектовНазначения = Новый Массив;
    МассивОбъектовНазначения.Добавить(Объект.ПрихНакл);

ОбъектыПечати =    Новый СписокЗначений;

КоллекцияПечатныхФорм = Новый ТаблицаЗначений;
КоллекцияПечатныхФорм.Колонки.Добавить("ИмяМакета");
КоллекцияПечатныхФорм.Колонки.Добавить("ИмяВРЕГ");
КоллекцияПечатныхФорм.Колонки.Добавить("СинонимМакета");
КоллекцияПечатныхФорм.Колонки.Добавить("ТабличныйДокумент");
КоллекцияПечатныхФорм.Колонки.Добавить("Экземпляров");
КоллекцияПечатныхФорм.Колонки.Добавить("Картинка");
КоллекцияПечатныхФорм.Колонки.Добавить("ПолныйПутьКМакету");
КоллекцияПечатныхФорм.Колонки.Добавить("ИмяФайлаПечатнойФормы");
стр=КоллекцияПечатныхФорм.Добавить();
стр.ИмяМакета="ПриемоСдаточныйАкт";
стр.ИмяВРЕГ="ПРИЕМОСДАТОЧНЫЙАКТ";
стр.Экземпляров=1;

//ИмяМакета=ПриемоСдаточныйАкт, ИмяВРЕГ=ПРИЕМОСДАТОЧНЫЙАКТ, СинонимМакета=, ТабличныйДокумент=, Экземпляров=1, Картинка=, ПолныйПутьКМакету=, ИмяФайлаПечатнойФормы=,

// Проба печати
    Попытка
        ОбрОбъект.печать(МассивОбъектовНазначения, КоллекцияПечатныхФорм, ОбъектыПечати, Ложь);
        //ТаблДок.Вывести();
    Исключение
        А=1; // Точка останова для отладки!
        Сообщить(ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() )); // ВНЕШНЮЮ печатную форму из справончика ВПФ можно спокойно поправить!
    КонецПопытки;   
           
КонецПроцедуры   

как я понимаю печатная форма формируется но не выводиться, а изменять с Возврат ТабличныйДокумент на ТабличныйДокумент.Показать(); - я бы не хотел.

есть идеи как этого добиться?

Оффлайн Psm_2015

  • **
  • Сообщений: 53
  • РЕПУТАЦИЯ: 3
  • КПД: 6%
  • Регистрация: 2015-06-12
  • Сайт: 
  • Профессия: Ученик 1С
Чего Вы в конечном итоге добиться хотите? Поправить эту внешнюю обработку или сделать такую же, но для другого документа? Или разобраться как все работает?

Оффлайн zerbite

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-26
  • Сайт: 
  • Профессия: Программист 1С
Чего Вы в конечном итоге добиться хотите? Поправить эту внешнюю обработку или сделать такую же, но для другого документа? Или разобраться как все работает?
нет, ВПФ у меня уже написана, она работает верно из документа или журнала, я теперь хочу распечатать этот документ (Приходная накладная) из другой обработки и в перспективе добавить в эту печать распечатку еще и РКО (ссылка на который у меня есть в главной обработке)

я делаю Обработку АРМ (автоматическое рабочее место) типа рабочего стола, чтобы из одного места были доступны все функции для работы.
Добавлено: 19 Янв 2016, 15:17

ответ оказался очень простой

 	ВыполняемаяОбработка=НайтиВПФ();
    Если ВыполняемаяОбработка.Пустая() Тогда
        Возврат;
    КонецЕсли;
    ОбъектыНазначения=Новый Массив;
    ОбъектыНазначения.Добавить(Объект.ПрихНакл);
    //Если УправлениеПечатьюКлиент.ПроверитьДокументыПроведены(ОбъектыНазначения) Тогда
        ПараметрыОткрытия=Новый Структура("ИсточникДанных, ПараметрыИсточника");
        ПараметрыОткрытия.ИсточникДанных=ВыполняемаяОбработка;
        ПараметрыОткрытия.ПараметрыИсточника=Новый Структура("ИдентификаторКоманды, ОбъектыНазначения");
        ПараметрыОткрытия.ПараметрыИсточника.ИдентификаторКоманды="ПриемоСдаточныйАкт";
        ПараметрыОткрытия.ПараметрыИсточника.ОбъектыНазначения=ОбъектыНазначения;
       
        ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия);
   
код должен выполняться на клиенте, а функция НайтиВПФ() - должны быть на сервере и возвращать ссылку из Справочники.ДополнительныеОтчетыИОбработки

Последний раз редактировалось: zerbite; 19 Янв 2016, 15:17. Причина: Объединение сообщений


Теги: УТ11 8.3 
 

Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 13705
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3341
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6780
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3801
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1020
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
alex0402
122 Сообщений
Norfolk
52 Сообщений
MuI_I_Ika MuI_I_Ika
52 Сообщений
LexaK
46 Сообщений
друган
20 Сообщений
alexandr_ll
20 Сообщений
AsadRoman
20 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 1015
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal