Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Янв 2017, 04:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод запроса)  (Прочитано 776 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
Я начинающий программист, не могу найти ошибку, может она и очевидная!
При открытии документа необходимо чтобы поле Номенклатура в Таблице Товары заполнилось содержимым из Справочника.Номенклатура.Наименование
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Запрос = Новый Запрос;
Запрос.Текст = ("ВЫБРАТЬ
             | Номенклатура.Наименование
             |ИЗ
             | Справочник.Номенклатура КАК Номенклатура");
РезультатЗапроса = Запрос.Выполнить().Выгрузить();
Для Каждого ТЗ Из РезультатЗапроса Цикл
Элементы.ТоварыНоменклатура = ТЗ.Наименование;
КонецЦикла;

КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Вывод запроса)
« Ответ #1: 12 Янв 2016, 08:58 »
какой сакральный смысл в этой глупости?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн TerverVl

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 7
  • КПД: 21%
  • Регистрация: 2015-12-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Вывод запроса)
« Ответ #2: 12 Янв 2016, 15:06 »
Как звучит задание в оригинале?
Речь идёт о строке табличной части документа и её реквизите "Номенклатура" или
о свойстве "Заголовок" элемента формы?
Ну и чтобы хоть что-то работало должно быть так:
Цитировать
Элементы.ТоварыНоменклатура.Заголовок = ТЗ.Наименование;
Хотя смысла такой формулировке задания нет. Как из в выгрузке РезультатаЗапроса в ТаблицуЗначений.
Чтобы это имело хоть какой-то смысл, запрос должен возвращать единственное значение, например группу(Родителя) номенклатуры из первой строки табличной части
и уже далее подставлять её как заголовок для колонки.

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
Re: Вывод запроса)
« Ответ #3: 13 Янв 2016, 06:44 »
Как звучит задание в оригинале?


Конфа самописная. Есть документ ВводНачОстатков и Справочник Номенклатура. При создании на сервере документа, необоходимо заполнение его таблицы содержимым справочника (Справочник.Номенклатура.Наименование)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Вывод запроса)
« Ответ #4: 13 Янв 2016, 06:47 »
Прям обязательно при создании на сервере? или все таки по кнопке "Заполнить по справочнику"?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн TerverVl

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 7
  • КПД: 21%
  • Регистрация: 2015-12-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Вывод запроса)
« Ответ #5: 13 Янв 2016, 07:05 »
Тогда так:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                 |    Номенклатура.Ссылка КАК Номенклатура
                 |ИЗ
                 |    Справочник.Номенклатура КАК Номенклатура";

    Объект.Товары.Загрузить(Запрос.Выполнить().Выгрузить());
       
КонецПроцедуры
И действительно лучше сделать команду формы, и уже по команде заполнять табличную часть.

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
Re: Вывод запроса)
« Ответ #6: 13 Янв 2016, 07:28 »
Спасибо Помогло)
Добавлено: 13 Янв 2016, 09:37

А как по этой таблице рассчитать СуммуДокумента, значение которой потом можно передать в реквизит?

Последний раз редактировалось: Анатолий Анпилогов; 13 Янв 2016, 09:37. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Вывод запроса)
« Ответ #7: 13 Янв 2016, 09:39 »
сумма документа в ПередЗаписью() рассчитывается
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн TerverVl

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 7
  • КПД: 21%
  • Регистрация: 2015-12-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Вывод запроса)
« Ответ #8: 13 Янв 2016, 09:46 »
И лучше это сделать в модуле объекта, не формы.
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
СуммаДокумента = Товары.Итог("Сумма");
КонецПроцедуры

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
Re: Вывод запроса)
« Ответ #9: 15 Янв 2016, 10:56 »
И лучше это сделать в модуле объекта, не формы.
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
СуммаДокумента = Товары.Итог("Сумма");
КонецПроцедуры

Все хорошо) Только надо было вызвать как объекты) И нормально пошло)

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
Объект.СуммаДокумента = Объект.Товары.Итог("Сумма");
КонецПроцедуры


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 7785
Последний ответ 14 Июн 2012, 17:44
от Alex1111
"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1333
Последний ответ 11 Май 2016, 15:29
от LexaK
Ошибка при выполнении запроса - "неоднозначное поле"

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9991
Последний ответ 21 Апр 2011, 16:00
от Marta_Li
"Зависание" запроса после обращения к регистру бухгалтерии

Автор ShkerinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3501
Последний ответ 03 Ноя 2011, 14:06
от Shkerin
Результат простого запроса "Ошибка чтения значения"

Автор 2CaspРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 7988
Последний ответ 28 Май 2014, 10:41
от 2Casp

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
187 Сообщений
alex0402
58 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
crow1983
37 Сообщений
alexandr_ll
27 Сообщений
LexaK
24 Сообщений
sertak sertak
22 Сообщений
BuhRust
19 Сообщений
Vzonder
18 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 174
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal