Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Июл 2017, 21:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подсчет разных данных в одном документе  (Прочитано 620 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет. я новичок в этом деле, прошу не пинать!:D 

Вообщем такая ситуация, есть документ (табель уч.раб.времени), в нем отмечаются раб.дни сотрудника.
Но категории сотрудников разные. Знаю как вывести общ. итог, а вот как вывести в разные реквизиты документа суммы по должностям? не знаю(( прошу помочь !!!

Пример:

Иванов И.И. - слесарь - отработал 100 часов
Петрова М.И. - повар - отработала 36 часов
Сидоров А.Н. - слесарь - отработал 50 часов

нужно чтобы в реквизит "ЧасыСлесаря" записалось = 150 часов, а в реквизит "ЧасыПовара" = 36 часов
Как это воспроизвести программно????:btbzdb:


1С:Предприятие 8.3 (8.3.7.1776)
Самописная


Заранее СПАСИБО!


Оффлайн HumanVIL

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 3
  • КПД: 38%
  • Регистрация: 2016-01-07
  • Сайт: 
  • Профессия: Программист 8.1
Ну в целом, для конкретного случая программно это могло бы выглядеть так:
ТабличнаяЧастьТабеляПриИзменении вешается допустим на событие ТЧ ПриИзменении.
&НаКлиенте
Процедура ТабличнаяЧастьТабеляПриИзменении(Элемент)

Структура = Новый Структура;

ТЧ = Объект.ТабличнаяЧастьТабеля;
ПолучитьИтогиТЧ(ТЧ, Структура);

Объект.ЧасыСлесаря = Структура.ЧасыСлесаря;
Объект.ЧасыПовара = Структура.ЧасыПовара;

КонецПроцедуры

&НаСервереБезКонтекста
Процедура ПолучитьИтогиТЧ(ТЧ, Структура)

ТЗ = ТЧ.Выгрузить();
ТЗ.Свернуть("Должность", "Сумма");

СтрТЗ = ТЗ.Найти(Справочники.Должности.Слесарь, "Должность");
Если СтрТЗ = Неопределено Тогда
   Структура.Вставить("ЧасыСлесаря", 0);
Иначе
   Структура.Вставить("ЧасыСлесаря", СтрТЗ.Сумма);
КонецЕсли;

СтрТЗ = ТЗ.Найти(Справочники.Должности.Повар, "Должность");
Если СтрТЗ = Неопределено Тогда
   Структура.Вставить("ЧасыПовара", 0);
Иначе
   Структура.Вставить("ЧасыПовара", СтрТЗ.Сумма);
КонецЕсли;

КонецПроцедуры

Но, надо понимать, что универсальности тут ровно на две должности, к тому же жестко прописанных.
Собственно, используя отдельные реквизиты документа для этой цели, по другому и не выйдет...
Наверно, лучше показывать пользователю соответствующие отчеты, введя например в регистр измерение по должности.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Адуреть! Чувак! СПАСИБО!!!!
Я уже и не надеялся (

СПАСИБО!!!!


Ну в целом, для конкретного случая программно это могло бы выглядеть так:
ТабличнаяЧастьТабеляПриИзменении вешается допустим на событие ТЧ ПриИзменении.
&НаКлиенте
Процедура ТабличнаяЧастьТабеляПриИзменении(Элемент)

Структура = Новый Структура;

ТЧ = Объект.ТабличнаяЧастьТабеля;
ПолучитьИтогиТЧ(ТЧ, Структура);

Объект.ЧасыСлесаря = Структура.ЧасыСлесаря;
Объект.ЧасыПовара = Структура.ЧасыПовара;

КонецПроцедуры

&НаСервереБезКонтекста
Процедура ПолучитьИтогиТЧ(ТЧ, Структура)

ТЗ = ТЧ.Выгрузить();
ТЗ.Свернуть("Должность", "Сумма");

СтрТЗ = ТЗ.Найти(Справочники.Должности.Слесарь, "Должность");
Если СтрТЗ = Неопределено Тогда
   Структура.Вставить("ЧасыСлесаря", 0);
Иначе
   Структура.Вставить("ЧасыСлесаря", СтрТЗ.Сумма);
КонецЕсли;

СтрТЗ = ТЗ.Найти(Справочники.Должности.Повар, "Должность");
Если СтрТЗ = Неопределено Тогда
   Структура.Вставить("ЧасыПовара", 0);
Иначе
   Структура.Вставить("ЧасыПовара", СтрТЗ.Сумма);
КонецЕсли;

КонецПроцедуры

Но, надо понимать, что универсальности тут ровно на две должности, к тому же жестко прописанных.
Собственно, используя отдельные реквизиты документа для этой цели, по другому и не выйдет...
Наверно, лучше показывать пользователю соответствующие отчеты, введя например в регистр измерение по должности.


 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6890
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3636
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1728
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 6413
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6356
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
93 Сообщений
oleg-x
83 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
44 Сообщений
AIFrame
42 Сообщений
Амал
30 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений
wise wise
21 Сообщений

* Кто онлайн

  • Точка Гостей: 340
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal