Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2017, 21:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывести данные на печать  (Прочитано 672 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Онлайн Каримдат

  • ***
  • Сообщений: 220
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2014-04-06
    • Skype: winkarollo
  • Сайт: 
  • Профессия: Ученик 1С
Уважаемые форумчане. Прошу подсказать.
Сделал внешнюю обработку. С помощью Конструктора выходной формы сделал следующий запрос:
ВЫБРАТЬ
УстановкаЦенНоменклатурыТовары.Цена,
УстановкаЦенНоменклатурыТовары.Номенклатура.Размер,
ПРЕДСТАВЛЕНИЕ(УстановкаЦенНоменклатурыТовары.Номенклатура.Размер)
ИЗ
Документ.УстановкаЦенНоменклатуры.Товары КАК УстановкаЦенНоменклатурыТовары
ГДЕ
УстановкаЦенНоменклатурыТовары.Ссылка = &Ссылка
И УстановкаЦенНоменклатурыТовары.ТипЦен = &ТипЦен

Выводится то что нужно, но.
Как сделать чтобы кнопка Печать формировала этикетку вот такого вида как в прикреплённом файле?

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн HumanVIL

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 3
  • КПД: 38%
  • Регистрация: 2016-01-07
  • Сайт: 
  • Профессия: Программист 8.1
Можно использовать "Макет". Нарисовать в нем нужную этикетку. И в данном случае использовать свойство ячейки "Ориентация текста", в размере приблизительно 90.

Онлайн Каримдат

  • ***
  • Сообщений: 220
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2014-04-06
    • Skype: winkarollo
  • Сайт: 
  • Профессия: Ученик 1С
Макет нарисовал. Как его связать с кнопкой Печать, чтобы он выводил нужные реквизиты в нужные колонки? Вот с этим у меня пока трудность.

Оффлайн Psm_2015

  • **
  • Сообщений: 53
  • РЕПУТАЦИЯ: 3
  • КПД: 6%
  • Регистрация: 2015-06-12
  • Сайт: 
  • Профессия: Ученик 1С
Макет нарисовал. Как его связать с кнопкой Печать, чтобы он выводил нужные реквизиты в нужные колонки? Вот с этим у меня пока трудность.
1) гуглим "связать макет с кнопкой печать"
2) идем по ссылке "Печать в 1С"
3) адаптируем к своему варианту

Оффлайн HumanVIL

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 3
  • КПД: 38%
  • Регистрация: 2016-01-07
  • Сайт: 
  • Профессия: Программист 8.1
Смотрите. Вот типовой код, полученный (практический полностью) конструктором запроса с обработкой результата с выводом в табличный документ.

Нам нужен внешний отчет, на форму выводим реквизит ТабДокФорма, с типом ТабличныйДокумент. Создаем макет, как во вложении (для задания именованной области - выделяем строки и ищем кнопку "Назначить имя", как один из вариантов). Хотя, если использовать конструктор, то он и макет сам нарисует.
На форме вешаем команду, назначаем ей процедуру ВыполнитьПечать.

И смотрим результат. Пробуем, меняем. И понимаем.) Все просто.

&НаКлиенте
Процедура ВыполнитьПечать(Команда)

//ТабДок = Новый ТабличныйДокумент; //<- если просто выводим таб док на печать

ВыполнитьПечатьНаСервере(ТабДокФорма); //<- если табличный документ на форме

//ТабДокФорма.Показать();

КонецПроцедуры

Процедура ВыполнитьПечатьНаСервере(ТабДок)

ЭтотОбъект = РеквизитФормыВЗначение("Отчет");

Макет = ЭтотОбъект.ПолучитьМакет("Макет");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Номенклатура.Код,
| Номенклатура.Наименование
|ИЗ
| Справочник.Номенклатура КАК Номенклатура";

Результат = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);

КонецПроцедуры

В вашем случае, можно оставить одну область с двумя колонками Цена и Размер, и выводить её в детальных записях.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
alex0402
65 Сообщений
MuI_I_Ika MuI_I_Ika
47 Сообщений
crow1983
35 Сообщений
alexandr_ll
33 Сообщений
LexaK
32 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 289
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal