Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2017, 13:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: По табличной части документа  (Прочитано 1822 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн asiya

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-30
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! как можно заполнить табличную часть документа из регистра остатков?


Оффлайн Artem6237

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2015-08-15
  • Сайт: 
  • Профессия: Программист 1С
Пишете запрос к регистру, далее делаете выборку из результата, в цикле по выборке заполняете вашу коллекцию данными.

Оффлайн asiya

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-30
  • Сайт: 
  • Профессия: Ученик 1С
можно вложить картини на эту тему?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
книжки прочитать - не предлагать? :kmtu:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн asiya

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-30
  • Сайт: 
  • Профессия: Ученик 1С
хорошо было б

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну так читайте
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн asiya

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-30
  • Сайт: 
  • Профессия: Ученик 1С
можете предложить книжку на эту тему? Практическое пособие разработчика( Радченько )там ответ не нашла

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 67
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
asiya, плохо читали и поисковиками пользоваться вообще не хотите. Читайте ТУТ, может поможет. И еще Вам - СЮДА
Если я Вам помог, нажми - Спасибо!

Оффлайн valchara

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Бухгалтер
Как минимум запрос к регистру должен вернуть таблицу, структура которой совпадает с заполняемой ТЧ.
Кроме того не забудьте, что с регистром можно работать только на сервере.

Общая схема примерно такая. Из формы получаете объект и вызываете его метод для заполнения. Содержимое метода зависит от регистра и вашей ТЧ.
 
&НаСервере
Процедура ЗаполнитьНаСервере()
ДокОбъект=ДанныеФормыВЗначение(Объект,Тип("ДокументОбъект.АктСверки"));
ДокОбъект.ЗаполнитьПоКонтрагенту();
ЗначениеВДанныеФормы(ДокОбъект,Объект);
КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)
ЗаполнитьНаСервере();
КонецПроцедуры
   

Оффлайн FonS

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-01-04
  • Сайт: 
Вот пример кода в модуле формы документа
&НаКлиенте
Процедура Заполнить(Команда)
      ЗаполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНаСервере()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ РАЗЛИЧНЫЕ
| РазмещениеЖивотныхОстатки.Животное,
| РазмещениеЖивотныхОстатки.Клетка,
| РазмещениеЖивотныхОстатки.КоличествоОстаток КАК Количество,
| ИнвентаризацияЖивотные.КоличествоФакт
|ИЗ
| РегистрНакопления.РазмещениеЖивотных.Остатки КАК РазмещениеЖивотныхОстатки
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.Инвентаризация.Животные КАК ИнвентаризацияЖивотные
| ПО РазмещениеЖивотныхОстатки.Животное = ИнвентаризацияЖивотные.Животное
| И РазмещениеЖивотныхОстатки.Клетка = ИнвентаризацияЖивотные.Клетка";   

   Результат = Запрос.Выполнить();

   Объект.Животные.Загрузить(Результат.Выгрузить());

КонецПроцедуры // ЗаполнитьНаСервере()
Соответственно табличная часть документа








Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4024
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6982
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4021
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6646
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6675
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
96 Сообщений
Dethmontt Dethmontt
71 Сообщений
alex0402
63 Сообщений
MuI_I_Ika MuI_I_Ika
61 Сообщений
wise wise
47 Сообщений
Сергей Федоров Сергей Федоров
41 Сообщений
ilyay ilyay
39 Сообщений
BuhRust
22 Сообщений
ilnur75
20 Сообщений
videomause
20 Сообщений

* Кто онлайн

  • Точка Гостей: 772
  • Точка Скрытых: 0
  • Точка Пользователей: 16
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal