Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2017, 01:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка печати наклеек  (Прочитано 1209 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн burza

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-29
  • Сайт: 
  • Профессия: Ученик 1С
Помогите пожалуйста! В обработке нада фильтровать все по стране. Не могу понять где ошибся, ошибку выдает:{Форма.ОсновнаяФормаПечати.Форма(73)}: Ошибка при вызове метода контекста (Выполнить)

вот код:
ЗапСп = новый Запрос;
        ЗапСп.Текст = "ВЫБРАТЬ
                  |Партнеры.Ссылка КАК Ссылка,
                  |ЕСТЬNULL(ПартнерыСегментаНеОтправлятьПочту.НеОтправлятьПочту, ЛОЖЬ) КАК НеОтправлятьПочту
                  |ИЗ
                  |    Справочник.Партнеры КАК Партнеры
                  |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ПартнерыСегмента КАК ПартнерыСегмента
                  |        ПО (ПартнерыСегмента.Партнер = Партнеры.Ссылка)
                  |        ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                  |            ПартнерыСегмента.Партнер КАК Партнер,
                  |            ИСТИНА КАК НеОтправлятьПочту
                  |        ИЗ
                  |            РегистрСведений.ПартнерыСегмента КАК ПартнерыСегмента
                  |        ГДЕ
                  |     
                  |        ПартнерыСегмента.Сегмент = &сегментНеОтправлятьПочту) КАК ПартнерыСегментаНеОтправлятьПочту
                  |       ПО (ПартнерыСегментаНеОтправлятьПочту.Партнер = Партнеры.Ссылка)
                  |     ГДЕ
                  |        Партнеры.КонтактнаяИнформация.Страна = &Страна";
                                                                         
                                                                                 
    Если НЕ ФильтрСегмент = Справочники.СегментыПартнеров.ПустаяСсылка() тогда
                ЗапСп.Текст = ЗапСп.Текст + " И ПартнерыСегмента.Сегмент = &параметрСегмент ";
                ЗапСп.УстановитьПараметр("параметрСегмент", ФильтрСегмент);
    КонецЕсли;

                 
    Если НЕ ФильтрСтрана = Справочники.СтраныМира.ПустаяСсылка() тогда
                ЗапСп.Текст = ЗапСп.Текст + "Партнеры.КонтактнаяИнформация.Страна = &параметСтрана ";
                ЗапСп.УстановитьПараметр("параметрСтрана", ФильтрСтрана);
    КонецЕсли;

И сама обработка : https://drive.google.com/file/d/0B2dcPjksZLAIYVB1ZjRFNE1YWDQ/view?usp=sharing


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6075
  • РЕПУТАЦИЯ: 712
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Запрос на сервере выполняется?

Оффлайн burza

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-29
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 348
  • РЕПУТАЦИЯ: 65
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Разработчик 1С
burza, запустил вашу обработку никакой ошибки не проявилось. При каких настройках она возникает?
Если я Вам помог, нажми - Спасибо!

Оффлайн burza

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-29
  • Сайт: 
  • Профессия: Ученик 1С
burza, запустил вашу обработку никакой ошибки не проявилось. При каких настройках она возникает?

при указании страны

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 348
  • РЕПУТАЦИЯ: 65
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Разработчик 1С
О какой стране идет речь, нет такого реквизита? Бизнес-регион?
Если я Вам помог, нажми - Спасибо!

Оффлайн burza

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-29
  • Сайт: 
  • Профессия: Ученик 1С
или вот это починить тоже подходит мне, только когда выбираю родителя группы он его только и отображает а не из всех подчиненных регионов которые в нем есть.
вот обработка. https://drive.google.com/file/d/0B2dcPjksZLAIZm5iaDJ0Wl9yUkU/view?usp=sharing

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 348
  • РЕПУТАЦИЯ: 65
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Разработчик 1С
burza, укажите просто вид сравнения "В ИЕРАРХИИ"
Если я Вам помог, нажми - Спасибо!

Оффлайн burza

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-29
  • Сайт: 
  • Профессия: Ученик 1С
burza, укажите просто вид сравнения "В ИЕРАРХИИ"

И звените меня конечно, но не напишите как нада)

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 348
  • РЕПУТАЦИЯ: 65
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Разработчик 1С
Заменить вот эту конструкцию
Если НЕ ФильтрБизнесРегион = Справочники.БизнесРегионы.ПустаяСсылка() тогда
ЗапСп.Текст = ЗапСп.Текст + " И Партнеры.БизнесРегион = &параметрБизнесРегион ";
ЗапСп.УстановитьПараметр("параметрБизнесРегион", ФильтрБизнесРегион);
КонецЕсли;
на
Если НЕ ФильтрБизнесРегион = Справочники.БизнесРегионы.ПустаяСсылка() тогда
ЗапСп.Текст = ЗапСп.Текст + " И Партнеры.БизнесРегион В ИЕРАРХИИ (&параметрБизнесРегион) ";
ЗапСп.УстановитьПараметр("параметрБизнесРегион", ФильтрБизнесРегион);
КонецЕсли;
Если я Вам помог, нажми - Спасибо!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
74 Сообщений
alexandr_ll
37 Сообщений
LexaK
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
crow1983
31 Сообщений
sertak sertak
26 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений
Vzonder
17 Сообщений

* Кто онлайн

  • Точка Гостей: 219
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal