Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Мар 2017, 21:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сохранение почтовых вложений средством 1с  (Прочитано 1209 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. нужно написать обработку которая будет собирать и сохранять на комп вложения с почты. Немного разобрался как это сделать, но появился вопрос: как обрабатывать только не прочитанные и с вложениями сообщения. вот что я сейчас имею:
&НаСервере
Процедура ПолучитьНаСервере()
    Профиль=Новый ИнтернетПочтовыйПрофиль;
    Профиль.АдресСервераIMAP = Объект.IMAPСервер;
    Профиль.ПользовательIMAP=Объект.Логин;
    Профиль.ПарольIMAP=Объект.Пароль;   
    Профиль.АдресСервераSMTP = Объект.АдресSMTPСервера;
    Профиль.Таймаут = Объект.ВремяОжиданияСервера;
    Профиль.Пароль           = Объект.Пароль;
    Профиль.Пользователь     = Объект.Логин;
    Профиль.ПортIMAP         = Объект.ПортPOP3;
    Профиль.ПортSMTP         = Объект.ПортSMTP;
    Профиль.ИспользоватьSSLSMTP=Истина;
    Профиль.ИспользоватьSSLIMAP=Истина;
   
   
   
    ИнтернетПочта = Новый ИнтернетПочта;
   
    Попытка
        ИнтернетПочта.Подключиться(Профиль,ПротоколИнтернетПочты.IMAP);
    Исключение
        Сообщить(ОписаниеОшибки());
        Сообщить("Произошли ошибки при проверке настроек учетной записи.
        |Описание ошибки приведено в окне сообщения.");
        Возврат;
    КонецПопытки;
   
    //Выбираем все  письма в массив
    МассивСообщений = Новый Массив;
    МассивСообщений = ИнтернетПочта.Выбрать(Истина);             
   
    //Разбираем каждое письмо, и выполняем необходимые действия
    Для Каждого Письмо Из МассивСообщений Цикл
       
        //Получение вложений в писье
        Вложения = Письмо.Вложения;
        Тема      =  Письмо.Тема;
        Тексты      =  Письмо.Тексты;
       
        Попытка
            Для каждого Вложение Из Письмо.Вложения
                Цикл
                Вложение.Данные.Записать("C:\Users\......\Desktop\ДляФайлов\"+Вложение.ИмяФайла+".xls");
                Сообщить("Вложения успешно сохранены...");
            КонецЦикла;
        Исключение
            Сообщить("Ошибка сохранения вложений!");
        КонецПопытки;
       
    КонецЦикла;                   
   
    ИнтернетПочта.Отключиться();
КонецПроцедуры

при таком раскладе соответственно обрабатываются все сообщения и ранее просмотренные тоже. может есть какое-то свойство у самого письма??


Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
ИнтернетПочта (InternetMail)
Выбрать (Get)
Синтаксис:

Выбрать(<УдалятьСообщения>, <МассивЗаголовковСообщенийИлиИдентификаторов>, <ОтмечатьКакПрочтенные>)
Параметры:

<УдалятьСообщения> (необязательный)

Тип: Булево.
Истина - удалять выбранные сообщения с сервера.
Значение по умолчанию: Истина.
<МассивЗаголовковСообщенийИлиИдентификаторов> (необязательный)

Тип: Массив.
Массив, содержащий либо заголовки сообщений, либо серверные идентификаторы сообщений, которые необходимо получить.
Для IMAP соединения массив может содержать порядковые номера сообщений в текущем почтовом ящике (см. ТекущийПочтовыйЯщик).
Значение по умолчанию: Пустой массив.
<ОтмечатьКакПрочтенные> (необязательный)

Тип: Булево.
Отмечать письма на сервере как прочтенные.
Актуален только для IMAP, для протокола POP3 единственное допустимое значение - Истина.

В режиме совместимости Версия8_3_5 значения по умолчанию следующие:
если задан второй параметр (МассивЗаголовковСообщенийИлиИдентификаторов), то - Истина,
в противном случае - Ложь.

Значение по умолчанию: Истина.
Возвращаемое значение:

Тип: Массив.
Массив объектов типа ИнтернетПочтовоеСообщение.
Если параметр МассивЗаголовковСообщенийИлиИдентификаторов содержит пустой массив или не был указан, то возвращаются все сообщения с сервера в полном объеме.
Описание:

Используется для получения сообщений с сервера.

Доступность:

Тонкий клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Добавлено: 28 Дек 2015, 18:06

А дальше перебирайте сообщения
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн TerverVl

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 7
  • КПД: 21%
  • Регистрация: 2015-12-28
  • Сайт: 
  • Профессия: Программист 1С
Идентификатор (UID)
Использование:

Чтение и запись.
Описание:

Тип: Массив.
Содержит строку, идентифицирующую сообщение. Данный идентификатор сообщения уникален в пределах почтового ящика и остается неизменным на протяжении всего времени существования этого сообщения в почтовом ящике на сервере. После объединения частичных сообщений, результирующее сообщение может содержать несколько идентификаторов, поэтому свойство имеет тип Массив.

ИЛИ используй свойство ИдентификаторСообщения
Но придётся идентификаторы всех обработанных писем хранить в регистре сведений.

Оффлайн TrigubovichL

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2015-11-06
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
МассивСообщений = ИнтернетПочта.Выбрать(Истина);

При таком раскладе выбранные письма удаляются.
Так что не стоит беспокоиться о повторной их обработке.

А если без удаления "Выбрать", можно по заданной дате получения (или за заданный период) обрабатывать, а остальные пропускать.


Теги:
 

Сохранение документов в формате *.pdf с компьютеров, подключенных к серверу через удаленное подключение к рабочему столу

Автор NeutrinoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 439
Последний ответ 20 Июл 2016, 15:59
от Neutrino
Сохранение сгенерированных колонок и данных их ячеек в таблице значений документа

Автор LonerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1463
Последний ответ 06 Мар 2014, 07:48
от sdilshod
Как при сохранение одного документа, менять идентичный реквизит в другом документе

Автор kipishioРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 4607
Последний ответ 20 Фев 2015, 21:23
от vitasw
сохранение изменений данных справочнике в регистре сведений

Автор primusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 5880
Последний ответ 25 Авг 2011, 16:07
от primus
Сохранение изображение в базу данных 1с 8.2 управляемое приложение

Автор beztrudРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 9427
Последний ответ 16 Дек 2011, 15:25
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
alex0402
115 Сообщений
Norfolk
51 Сообщений
LexaK
45 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
друган
21 Сообщений
AsadRoman
20 Сообщений
alexandr_ll
20 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 248
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal