Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2017, 11:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с расчетом себестоимости в УТ 11.1.10.131  (Прочитано 651 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дмитрий Котляров

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 1
  • КПД: 100%
  • Регистрация: 2015-09-29
  • Сайт: 
Добрый день, помогите пожалуйста разобраться с проблемой.
При закрытии месяца выдает ошибку расчета себестоимости, точнее их две и по двум товарам, вот в качестве примера один из них.
2 ошибки привожу в скриншотах.
пишет что есть не корректный остаток в регистре по складу Транзит, количество равно 0, а себестоимость отлична от нуля.

далее привожу два отчета и движения в регистре по этому товару и складу за июнь 2015 года.
самое для меня интересное и не понятное, что в регистре есть измерение "раздел учета". и если его включить в группировки ("отчет себестоимость за июнь2015 (развернутый))", то остатки идут по разделу "Товары на складах", а обороты по "пустому" разделу учета.
а если я открываю движения в регистре (что прикрепил в виде таблице и скрина) то там все движения идут по разделу "Товары на складах"

а главное что как я ни мучил базу, я не смог добиться чтобы отчет показал мне строку из регистра, где остаток кол-ва 0, а себестоимость не ноль.

на всякий случай привожу процедуру с запросами которые дают эту ошибку, которые находятся в модуле менеджера в документе "РасчетСебестоимостиТоваров"

Процедура ПроверитьКорректностьОстатковВРегистреСебестоимостьТоваров(Дата, Организация)

Запрос = Новый Запрос;
Запрос.Текст = "
|ВЫБРАТЬ
| Организации.Ссылка КАК Организация
|ИЗ
| Справочник.Организации КАК Организации
|ГДЕ
| &Организация = ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка)
| ИЛИ &Организация = НЕОПРЕДЕЛЕНО
| ИЛИ Организации.Ссылка = &Организация";
Запрос.УстановитьПараметр("Организация", Организация);

МассивОрганизаций = Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Организация");

Запрос.Текст = "
|ВЫБРАТЬ
| Таб.РазделУчета                        КАК РазделУчета,
| Таб.ВидЗапасов                         КАК ВидЗапасов,
| Таб.Организация                        КАК Организация,
| АналитикаНоменклатуры.Номенклатура     КАК Номенклатура,
| АналитикаНоменклатуры.Номенклатура.Код КАК КодНоменклатуры,
| АналитикаНоменклатуры.Характеристика   КАК Характеристика,
| АналитикаНоменклатуры.Склад            КАК Склад,
| Таб.Количество                         КАК Количество,
| Таб.Стоимость                          КАК Стоимость,
| Таб.СтоимостьБезНДС                    КАК СтоимостьБезНДС,
| Таб.СуммаДопРасходов                   КАК СуммаДопРасходов,
| Таб.СуммаДопРасходовБезНДС             КАК СуммаДопРасходовБезНДС,
| Таб.СтоимостьРегл                      КАК СтоимостьРегл
|
|ИЗ
| (ВЫБРАТЬ
| Т.РазделУчета                   КАК РазделУчета,
| Т.ВидЗапасов                    КАК ВидЗапасов,
| Т.Организация                   КАК Организация,
| Т.АналитикаУчетаНоменклатуры    КАК АналитикаУчетаНоменклатуры,
| Т.КоличествоОстаток             КАК Количество,
| Т.СтоимостьОстаток              КАК Стоимость,
| Т.СтоимостьБезНДСОстаток        КАК СтоимостьБезНДС,
| Т.СуммаДопРасходовОстаток       КАК СуммаДопРасходов,
| Т.СуммаДопРасходовБезНДСОстаток КАК СуммаДопРасходовБезНДС,
| Т.СтоимостьРеглОстаток          КАК СтоимостьРегл
| ИЗ
| РегистрНакопления.СебестоимостьТоваров.Остатки(&ГраницаДатаОкончания,
| Организация В (&МассивОрганизаций)) КАК Т
| ) КАК Таб
|
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.АналитикаУчетаНоменклатуры КАК АналитикаНоменклатуры
| ПО Таб.АналитикаУчетаНоменклатуры = АналитикаНоменклатуры.КлючАналитики
|
|ГДЕ
| Таб.Количество = 0
| И НЕ(Таб.Стоимость = 0
| И Таб.СтоимостьБезНДС = 0
| И Таб.СуммаДопРасходов = 0
| И Таб.СуммаДопРасходовБезНДС = 0
| И Таб.СтоимостьРегл = 0)";

Запрос.УстановитьПараметр("МассивОрганизаций", МассивОрганизаций);
Запрос.УстановитьПараметр("ГраницаДатаОкончания", Новый Граница(КонецМесяца(Дата), ВидГраницы.Включая));

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл

ПредставлениеТовара = НоменклатураКлиентСервер.ПредставлениеНоменклатуры(Выборка.Номенклатура, Выборка.Характеристика);
ПредставлениеТовара = ПредставлениеТовара + ", код: " + Выборка.КодНоменклатуры;
ПредставлениеТовара = ПредставлениеТовара + ", склад: " + Выборка.Склад + ", организация: " + Выборка.Организация;
ПредставлениеТовара = ПредставлениеТовара + ", раздел учета: " + Выборка.РазделУчета;
Если ЗначениеЗаполнено(Выборка.ВидЗапасов) Тогда
ПредставлениеТовара = ПредставлениеТовара + ", вид запасов: " + Выборка.ВидЗапасов;
КонецЕсли;
ПредставлениеНекорректногоОстатка = "Количество = 0"
+ ?(Выборка.Стоимость <> 0,", Стоимость = " + Выборка.Стоимость, "")
+ ?(Выборка.СтоимостьБезНДС <> 0,", СтоимостьБезНДС = " + Выборка.СтоимостьБезНДС, "")
+ ?(Выборка.СуммаДопРасходов <> 0,", СуммаДопРасходов = " + Выборка.СуммаДопРасходов, "")
+ ?(Выборка.СуммаДопРасходовБезНДС <> 0,", СуммаДопРасходовБезНДС = " + Выборка.СуммаДопРасходовБезНДС, "")
+ ?(Выборка.СтоимостьРегл <> 0,", СтоимостьРегл = " + Выборка.СтоимостьРегл, "");

ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
НСтр("ru = 'По номенклатуре %1 обнаружен некорректный остаток в регистре ""Себестоимость товаров"" на дату %3 : %2'"),
ПредставлениеТовара,
ПредставлениеНекорректногоОстатка,
КонецМесяца(Дата));

ЗаписьЖурналаРегистрации(
НСтр("ru = 'Расчет себестоимости'"),
УровеньЖурналаРегистрации.Ошибка,
,
Строка(Выборка.Номенклатура) + " (" + СокрЛП(Выборка.КодНоменклатуры) + ")",
ТекстОшибки,
РежимТранзакцииЗаписиЖурналаРегистрации.Транзакционная);

КонецЦикла;

КонецПроцедуры

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 840
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4069
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1533
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2925
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3138
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
96 Сообщений
Dethmontt Dethmontt
71 Сообщений
alex0402
65 Сообщений
MuI_I_Ika MuI_I_Ika
61 Сообщений
wise wise
56 Сообщений
ilyay ilyay
39 Сообщений
Сергей Федоров Сергей Федоров
36 Сообщений
magnifico61
22 Сообщений
BuhRust
21 Сообщений
ilnur75
21 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal