Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Май 2017, 01:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите новичку  (Прочитано 492 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Александр Бардайкин8

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-22
  • Сайт: 
Добрый день!
Пользователь вводит начальную дату и конечную дату, и необходимо вывести остатки по каждому дню (т. е. по тем дням которые входят в этот диапазон дат)
Можно сделать с помощью запроса в цикле, но это очень грубая ошибка будет:(
Подскажите пожалуйста, можно ли это осуществить другим способом?

Спасибо :)


Оффлайн Андрей Сисюкин

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 9
  • КПД: 43%
  • Регистрация: 2015-12-17
    • Skype: dark_daedal
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Помогите новичку
« Ответ #1: 27 Дек 2015, 17:17 »
Используй в запросе итоги типа этого:
ИТОГИ СУММА(...)) ПО
   Период ПЕРИОДАМИ(ДЕНЬ, &дата_начала, &дата_окончания)

Ну и при выборке из запроса используй выборку по группировкам, а группировка "Период"

Ну или в цикле по каждому дню.

Других способов выбора остатки на каждый день нет. Так как тип периода для таблицы обороты - это за какой период группируются, но выбираются данные только в те периоды, когда есть движения.


Добавлено: 27 Дек 2015, 17:40

Забыл указать, что когда открываешь выборку, то нужно указать третьим параметром "ВСЕ".

для наглядности - примерно так:

   запрос = новый запрос;
   запрос.Текст = "ВЫБРАТЬ
                  |   ТоварыНаСкладахОстаткиИОбороты.Номенклатура КАК Номенклатура,
                  |   ТоварыНаСкладахОстаткиИОбороты.КоличествоНачальныйОстаток КАК КоличествоНачальныйОстаток,
                  |   ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток КАК КоличествоКонечныйОстаток,
                  |   ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход КАК КоличествоПриход,
                  |   ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход КАК КоличествоРасход
                  |ИЗ
                  |   РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(&начало_периода, &конец_периода, День, ДвиженияИГраницыПериода, Номенклатура = &Номенклатура) КАК ТоварыНаСкладахОстаткиИОбороты
                  |ИТОГИ
                  |   СУММА(КоличествоНачальныйОстаток),
                  |   СУММА(КоличествоКонечныйОстаток),
                  |   СУММА(КоличествоПриход),
                  |   СУММА(КоличествоРасход)
                  |ПО
                  |   Номенклатура,
                  |   ТоварыНаСкладахОстаткиИОбороты.Период ПЕРИОДАМИ(ДЕНЬ, &начало_периода, &конец_периода)";
                              
   запрос.Параметры.Вставить("начало_периода", начало_периода);
   запрос.Параметры.Вставить("конец_периода", конец_периода);
   запрос.Параметры.Вставить("Номенклатура", Номенклатура);
   результат = запрос.Выполнить();
   
   выборка_номенклатура = результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   пока выборка_номенклатура.Следующий() цикл
      Если выборка_номенклатура.ТипЗаписи() = ТипЗаписиЗапроса.ИтогПоГруппировке тогда
         выборка_период = выборка_номенклатура.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "период", "ВСЕ");
         пока выборка_период.Следующий() цикл
            Сообщить("" + выборка_период.КоличествоНачальныйОстаток + " - " + выборка_период.КоличествоПриход + " - "
                                        + выборка_период.КоличествоРасход + " - " + выборка_период.КоличествоКонечныйОстаток);   
         КонецЦикла;
      КонецЕсли;
   КонецЦикла;
 

Последний раз редактировалось: Андрей Сисюкин; 27 Дек 2015, 17:40. Причина: Объединение сообщений

Оффлайн Александр Бардайкин8

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-22
  • Сайт: 
Re: Помогите новичку
« Ответ #2: 27 Дек 2015, 18:26 »
Спасибо большое, то что надо :zebzdr:


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3851
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5106
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5414
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3443
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1670
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
89 Сообщений
wise wise
68 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
49 Сообщений
Dethmontt Dethmontt
46 Сообщений
Сергей Федоров Сергей Федоров
29 Сообщений
ilyay ilyay
28 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 231
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal