Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июл 2017, 21:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Процедура ОбработкаВыбора  (Прочитано 1145 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lea

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-08
  • Сайт: 
  • Профессия: Ученик 1С
В пользовательском режиме не выбираются соответствующие документы при нажатии на документ основание, но выборка работает. Подскажите как заполнить ДокументОснование?

Процедура АбонентОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
   // Вставить содержимое обработчика.
   //выбираю все документы абонента   
      Запрос=Новый Запрос;
    Запрос.УстановитьПараметр("Абонент",ВыбранноеЗначение.Ссылка);
    Запрос.Текст= "ВЫБРАТЬ
                  |   ВыдачаКниг.Ссылка                
               |ИЗ
                  |   Документ.ВыдачаКниг КАК ВыдачаКниг
                  |ГДЕ
                  |   ВыдачаКниг.Абонент = &Абонент";
    Сообщить("Работает"+ВыбранноеЗначение);
    Выборка = Запрос.Выполнить().Выбрать();   
    Пока Выборка.Следующий() Цикл
ДокументОснование=Выборка.Ссылка.ПолучитьОбъект();
Сообщить("Выборка"+Выборка.Ссылка.ПолучитьОбъект());
КонецЦикла;

 КонецПроцедуры


Оффлайн Psm_2015

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 3
  • КПД: 5%
  • Регистрация: 2015-06-12
  • Сайт: 
  • Профессия: Ученик 1С
Если это то, о чем я думаю, то попробуйте так:
		Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = Строка(Выборка.Ссылка);
Сообщение.КлючДанных = Выборка.Ссылка;
Сообщение.Сообщить();

Оффлайн Lea

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-08
  • Сайт: 
  • Профессия: Ученик 1С
Если это то, о чем я думаю, то попробуйте так:
		Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = Строка(Выборка.Ссылка);
Сообщение.КлючДанных = Выборка.Ссылка;
Сообщение.Сообщить();
Мне нужно чтобы при выборе абонента открывался список документов только его при нажатии на кнопку документ основание

Оффлайн 1Cnastroika


Мне нужно чтобы при выборе абонента открывался список документов только его при нажатии на кнопку документ основание

Можно сделать через таблицу значений.
Выгрузите результат запроса в таблицу значений.
ТЗ = Запрос.Выполнить().Выгрузить();

По кнопке "Выбрать" делайте выбор строки ТЗ.
    Результат = ТЗ.ВыбратьСтроку("Выберите документ основание.");
       
    Если Результат <> Неопределено Тогда
        ДокументОснование = Результат.Ссылка;
    КонецЕсли;

Оффлайн Lea

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-08
  • Сайт: 
  • Профессия: Ученик 1С

Мне нужно чтобы при выборе абонента открывался список документов только его при нажатии на кнопку документ основание

Можно сделать через таблицу значений.
Выгрузите результат запроса в таблицу значений.
ТЗ = Запрос.Выполнить().Выгрузить();

По кнопке "Выбрать" делайте выбор строки ТЗ.
    Результат = ТЗ.ВыбратьСтроку("Выберите документ основание.");
       
    Если Результат <> Неопределено Тогда
        ДокументОснование = Результат.Ссылка;
    КонецЕсли;

Если я вас правильно поняла, то выдает ошибку что ТЗ переменная не определена
Процедура АбонентОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
// Вставить содержимое обработчика.
//выбираю все документы абонента   
  Запрос=Новый Запрос;
Запрос.УстановитьПараметр("Абонент",ВыбранноеЗначение.Ссылка);
Запрос.Текст= "ВЫБРАТЬ
               | ВыдачаКниг.Ссылка              
   |ИЗ
               | Документ.ВыдачаКниг КАК ВыдачаКниг
               |ГДЕ
               | ВыдачаКниг.Абонент = &Абонент";
Сообщить("Работает"+ВыбранноеЗначение);
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ДокументОснование=Выборка.Ссылка.ПолучитьОбъект();
Сообщить("Выборка"+Выборка.Ссылка.ПолучитьОбъект());
ТЗ = Запрос.Выполнить().Выгрузить();
КонецЦикла;
 
КонецПроцедуры
Процедура ВыбратьНажатие(Элемент)
Результат = ТЗ.ВыбратьСтроку("Выберите документ основание.");     
    Если Результат <> Неопределено Тогда
        ДокументОснование = Результат.Ссылка;
    КонецЕсли;
КонецПроцедуры
Добавлено: 26 Дек 2015, 20:41


Мне нужно чтобы при выборе абонента открывался список документов только его при нажатии на кнопку документ основание

Можно сделать через таблицу значений.
Выгрузите результат запроса в таблицу значений.
ТЗ = Запрос.Выполнить().Выгрузить();

По кнопке "Выбрать" делайте выбор строки ТЗ.
    Результат = ТЗ.ВыбратьСтроку("Выберите документ основание.");
       
    Если Результат <> Неопределено Тогда
        ДокументОснование = Результат.Ссылка;
    КонецЕсли;
я все поняла, получилось,спасибо!

Оффлайн 1Cnastroika

Когда результат запроса выгружается в ТЗ, то выборка из результата запроса и обход результата запроса не нужны.
Эта часть кода не нужна:
  Выборка = Запрос.Выполнить().Выбрать();    
     Пока Выборка.Следующий() Цикл
ДокументОснование=Выборка.Ссылка.ПолучитьОбъект();
Сообщить("Выборка"+Выборка.Ссылка.ПолучитьОбъект());
КонецЦикла;

Вместо этого кода нужно написать:
    ТЗ = Запрос.Выполнить().Выгрузить();

И нужно обеспечить видимость переменной ТЗ в процедуре, в которой происходит обращение к ТЗ. Значение переменной ТЗ устанавливается при выборе абонента. Нужно, чтобы переменная ТЗ была определена при выборе Документа до выбора абонента.


 

Процедура "ОбработкаПроведения"

Автор demon3Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 896
Последний ответ 22 Июн 2016, 14:46
от demon3
Процедура "Подсчет площади"

Автор Seregin63Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2331
Последний ответ 28 Ноя 2013, 13:00
от Seregin63
1c 8.2: как называется процедура/функция, которая вызывается при вводе значения в поле на форме?

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1343
Последний ответ 08 Сен 2014, 08:28
от cska-fanat-kz
Процедура госрегистрации ИП и юрлиц будет проходить в течение трех дней

Автор newsРаздел Новости

Ответов: 0
Просмотров: 682
Последний ответ 03 Апр 2014, 15:16
от news
Процедура Инициализации при создании внешней обработки таб. частей

Автор crow1983Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 10799
Последний ответ 23 Авг 2010, 16:51
от crow1983

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
105 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
Golickoff Golickoff
49 Сообщений
ilyay ilyay
49 Сообщений
AIFrame
47 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
LexaK
22 Сообщений

* Кто онлайн

  • Точка Гостей: 221
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal