Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Июл 2017, 01:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не могу задать корректное значение пустого поля (ссылочный тип) в проверяемом документе  (Прочитано 669 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Jack_78

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-03
  • Сайт: 
  • Профессия: Ученик 1С
Создаю Внешнюю обработку:

&НаКлиенте
Процедура КлиентыОсновногоПоставщика(Команда)
   
   КлиентыОсновногоПоставщикаНаСервере();
   
КонецПроцедуры
&наСервере
Процедура КлиентыОсновногоПоставщикаНаСервере()
   
   Значение = ""; // Здесь должно быть корректное значение пустого поля в проверяемом документе
   Выборка = Документы.ПоступлениеТоваров.Выбрать(, ,Новый Структура("Поставщик", Значение));
   Пока Выборка.Следующий() Цикл
       Сообщение = Новый СообщениеПользователю;
      Сообщение.Текст = Строка(Выборка.Ссылка);
      Сообщение.Сообщить();
   
   КонецЦикла;

КонецПроцедуры

И не могу корректно задать значение пустого поля в проверяемом реквизите. Поле ссылочного типа.
Для Конкретных значений все получается. Например
Значение = "Поставщик01"


Оффлайн LexaK

  • *****
  • Сообщений: 1251
  • РЕПУТАЦИЯ: 344
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте так
...
Значение = Справочники.Контрагенты.ПустаяСсылка();
...

как правило, для таких задач, используют запрос с параметрами.
там например можно еще задать условие по периоду, Проведен/Не Проведен, ПомеченНаУдаление и т.д.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для Конкретных значений все получается. Например
Значение = "Поставщик01"

строка для конкретного значения ссылочного типа? ну ну :trhregerhg:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 662
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 821
Последний ответ 02 Дек 2016, 12:58
от Jalib
В строке номер "1" табличной части "Состав набора": Не заполнено значение реквиз

Автор ХеляРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6532
Последний ответ 18 Сен 2011, 16:07
от Хеля
В строке "1" табличной части "Состав набора": Не заполнено значение реквизитов Цена

Автор rusalkaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2173
Последний ответ 11 Апр 2014, 16:52
от rusalka
Не работают поля "налоговый" и "бухгалтерский"

Автор oleg_e1Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2228
Последний ответ 31 Дек 2011, 11:36
от AntonB

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
92 Сообщений
oleg-x
73 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
40 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
lansy
22 Сообщений
Dethmontt Dethmontt
22 Сообщений

* Кто онлайн

  • Точка Гостей: 241
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal