Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Май 2017, 08:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не могу задать корректное значение пустого поля (ссылочный тип) в проверяемом документе  (Прочитано 622 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Jack_78

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-03
  • Сайт: 
  • Профессия: Ученик 1С
Создаю Внешнюю обработку:

&НаКлиенте
Процедура КлиентыОсновногоПоставщика(Команда)
   
   КлиентыОсновногоПоставщикаНаСервере();
   
КонецПроцедуры
&наСервере
Процедура КлиентыОсновногоПоставщикаНаСервере()
   
   Значение = ""; // Здесь должно быть корректное значение пустого поля в проверяемом документе
   Выборка = Документы.ПоступлениеТоваров.Выбрать(, ,Новый Структура("Поставщик", Значение));
   Пока Выборка.Следующий() Цикл
       Сообщение = Новый СообщениеПользователю;
      Сообщение.Текст = Строка(Выборка.Ссылка);
      Сообщение.Сообщить();
   
   КонецЦикла;

КонецПроцедуры

И не могу корректно задать значение пустого поля в проверяемом реквизите. Поле ссылочного типа.
Для Конкретных значений все получается. Например
Значение = "Поставщик01"


Оффлайн LexaK

  • *****
  • Сообщений: 1216
  • РЕПУТАЦИЯ: 333
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте так
...
Значение = Справочники.Контрагенты.ПустаяСсылка();
...

как правило, для таких задач, используют запрос с параметрами.
там например можно еще задать условие по периоду, Проведен/Не Проведен, ПомеченНаУдаление и т.д.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для Конкретных значений все получается. Например
Значение = "Поставщик01"

строка для конкретного значения ссылочного типа? ну ну :trhregerhg:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 517
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 696
Последний ответ 02 Дек 2016, 12:58
от Jalib
В строке номер "1" табличной части "Состав набора": Не заполнено значение реквиз

Автор ХеляРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6414
Последний ответ 18 Сен 2011, 16:07
от Хеля
В строке "1" табличной части "Состав набора": Не заполнено значение реквизитов Цена

Автор rusalkaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2053
Последний ответ 11 Апр 2014, 16:52
от rusalka
Не работают поля "налоговый" и "бухгалтерский"

Автор oleg_e1Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2096
Последний ответ 31 Дек 2011, 11:36
от AntonB

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
89 Сообщений
wise wise
68 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
49 Сообщений
Dethmontt Dethmontt
48 Сообщений
Сергей Федоров Сергей Федоров
29 Сообщений
ilyay ilyay
28 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 538
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal