Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Мар 2017, 10:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не могу задать корректное значение пустого поля (ссылочный тип) в проверяемом документе  (Прочитано 574 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Jack_78

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-03
  • Сайт: 
  • Профессия: Ученик 1С
Создаю Внешнюю обработку:

&НаКлиенте
Процедура КлиентыОсновногоПоставщика(Команда)
   
   КлиентыОсновногоПоставщикаНаСервере();
   
КонецПроцедуры
&наСервере
Процедура КлиентыОсновногоПоставщикаНаСервере()
   
   Значение = ""; // Здесь должно быть корректное значение пустого поля в проверяемом документе
   Выборка = Документы.ПоступлениеТоваров.Выбрать(, ,Новый Структура("Поставщик", Значение));
   Пока Выборка.Следующий() Цикл
       Сообщение = Новый СообщениеПользователю;
      Сообщение.Текст = Строка(Выборка.Ссылка);
      Сообщение.Сообщить();
   
   КонецЦикла;

КонецПроцедуры

И не могу корректно задать значение пустого поля в проверяемом реквизите. Поле ссылочного типа.
Для Конкретных значений все получается. Например
Значение = "Поставщик01"


Оффлайн LexaK

  • *****
  • Сообщений: 1173
  • РЕПУТАЦИЯ: 313
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте так
...
Значение = Справочники.Контрагенты.ПустаяСсылка();
...

как правило, для таких задач, используют запрос с параметрами.
там например можно еще задать условие по периоду, Проведен/Не Проведен, ПомеченНаУдаление и т.д.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1096
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для Конкретных значений все получается. Например
Значение = "Поставщик01"

строка для конкретного значения ссылочного типа? ну ну :trhregerhg:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 399
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 570
Последний ответ 02 Дек 2016, 12:58
от Jalib
В строке номер "1" табличной части "Состав набора": Не заполнено значение реквиз

Автор ХеляРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6283
Последний ответ 18 Сен 2011, 16:07
от Хеля
В строке "1" табличной части "Состав набора": Не заполнено значение реквизитов Цена

Автор rusalkaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1962
Последний ответ 11 Апр 2014, 16:52
от rusalka
Не работают поля "налоговый" и "бухгалтерский"

Автор oleg_e1Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1995
Последний ответ 31 Дек 2011, 11:36
от AntonB

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
146 Сообщений
alex0402
113 Сообщений
Norfolk
51 Сообщений
LexaK
47 Сообщений
MuI_I_Ika MuI_I_Ika
37 Сообщений
друган
21 Сообщений
AsadRoman
20 Сообщений
alexandr_ll
19 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 314
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal