Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2017, 17:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не удается установить postgresql94-contrib-9.4.2-1.1C.x86_64  (Прочитано 1499 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн garett

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-14
  • Сайт: 
Добрый день всем! :-) Нужна помощь - пробую поставить Postgre 9.4.2-1.1C (x86_64) на CentOS 6.7 - скачал пакеты:
postgresql94-9.4.2-1.1C.x86_64.rpm
postgresql94-contrib-9.4.2-1.1C.x86_64.rpm
postgresql94-libs-9.4.2-1.1C.x86_64.rpm
postgresql94-server-9.4.2-1.1C.x86_64.rpm

Ставлю следующим образом:
yum install postgresql94-libs-9.4.2-1.1C.x86_64.rpm
yum install postgresql94-9.4.2-1.1C.x86_64.rpm
yum install postgresql94-server-9.4.2-1.1C.x86_64.rpm
С этими тремя пакетами все проходит нормально, находятся зависимости, автоматически устанавливаются. А вот postgresql94-contrib-9.4.2-1.1C.x86_64.rpm почему-то не хочет ставиться:
Resolving Dependencies
--> Running transaction check
---> Package postgresql94-contrib.x86_64 0:9.4.2-1.1C will be installed
--> Processing Dependency: libicui18n.so.36()(64bit) for package: postgresql94-contrib-9.4.2-1.1C.x86_64
--> Processing Dependency: libicuuc.so.36()(64bit) for package: postgresql94-contrib-9.4.2-1.1C.x86_64
--> Finished Dependency Resolution
Error: Package: postgresql94-contrib-9.4.2-1.1C.x86_64 (/postgresql94-contrib-9.4.2-1.1C.x86_64)
           Requires: libicuuc.so.36()(64bit)
Error: Package: postgresql94-contrib-9.4.2-1.1C.x86_64 (/postgresql94-contrib-9.4.2-1.1C.x86_64)
           Requires: libicui18n.so.36()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

При этом я ставил и icu и libicu, вот что выдается по rpm -qa:
rpm -qa | grep libicu
libicu-4.2.1-12.el6.x86_64
libicu-devel-4.2.1-12.el6.x86_64

rpm -qa | grep icu
icu-4.2.1-12.el6.x86_64
libicu-4.2.1-12.el6.x86_64
libicu-devel-4.2.1-12.el6.x86_64

Подскажите, пожалуйста, в чем тут может быть загвоздка? Заранее благодарен :)

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн nigel

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-21
  • Сайт: 
Изменен формат кластера, создаваемого PostgreSQL 9.4.2-1.1C
Новый формат кластера идентичен формату кластера, создаваемого стандартной версией PostgreSQL.
В кластере формат хранения типа данных timestamp установлен со значением integer_datetimes=on в соответствии с форматом, используемым стандартной версией PostgreSQL.

Поддержка этой версии в 1С:Предприятии 8.3 реализована в версии 8.3.3 и старше.

Для использования PostgreSQL 9.4.2-1.1C с версиями 1С:Предприятия ниже 8.3.3 необходимо его собрать с установленым значением параметра integer_datetimes=off

Cписок поддерживаемых дистрибутивов Linux:
    RPM
        Centos 5.7, RedHat 5, Fedora 8, ASP Linux 12(14)
       Должны быть установлены:
           yum install readline
           yum install libtermcap
           yum install krb5-libs
           yum install openssl
      yum install icu

        Centos 6, RedHat 6, Fedora 9-16  (необходима установка openssl098e)
       Должны быть установлены:
           yum install readline
           yum install libtermcap
           yum install krb5-libs
           yum install openssl
       Необходима установка дополнительных пакетов совместимости:
           yum install openssl098e
           yum install compat-readline5
           yum install compat-libtermcap
      yum install compat-libicu36
    DEB
   Ubuntu 12.04
   Необходима установка icu
   sudo apt-get install libicu48

Дополнительные модули:
   plperl
   plpython
   test
   devel
   docs
Пробуйте, запрос тех зависимостей у меня пропал. Но вот при установке доп. модулей опять появились зависимости, которые я не смог решить... Они необходимы к установке?


Теги: postgresql 
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
alex0402
74 Сообщений
alexandr_ll
38 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
LexaK
31 Сообщений
crow1983
31 Сообщений
sertak sertak
24 Сообщений
BuhRust
18 Сообщений
Vzonder
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 826
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal