Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Янв 2017, 10:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Пользователь ИБ  (Прочитано 612 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Artjomrgv

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 10
  • КПД: 10%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Здравствуйте форумчане. Нужна помощь. В документе есть поле ответственный , хочу чтобы оно заполнялось автоматически из справочника сотрудники в зависимости от пользователя информационной базы . Сделал в модуле формы следующее.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Объект.Ответственный=Ответственный()
КонецПроцедуры

Функция Ответственный ()   
Если ПользователиИнформационнойБазы.ТекущийПользователь().Имя= "Иванов.И.И."      
Тогда Сотрудник=Справочники.Сотрудники.НайтиПоКоду("000000011");
КонецЕсли;
Если ПользователиИнформационнойБазы.ТекущийПользователь().Имя= "Петров П.П."      
Тогда Сотрудник=Справочники.Сотрудники.НайтиПоКоду("000000001");
   Возврат   Сотрудник   
КонецФункции

Если Иванов создает документ то в поле ответственный  стоит Иванов все верно. Но вот если Петров откроет документ который уже создал и провел Иванов, то в поле ответственный стоит уже Петров. Не понимаю почему, ведь модуль должен срабатывать только при создании.


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Пользователь ИБ
« Ответ #1: 13 Дек 2015, 17:03 »
Естественно. Ответственного нужно заполнять только для нового документа

Оффлайн Artjomrgv

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 10
  • КПД: 10%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Re: Пользователь ИБ
« Ответ #2: 13 Дек 2015, 17:31 »
Естественно. Ответственного нужно заполнять только для нового документа
Не понимая почему просто при  открытии документа, не при создании, а при открытии меняется поле ответственный в зависимости от пользователя ИБ.

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2640
  • РЕПУТАЦИЯ: 318
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Re: Пользователь ИБ
« Ответ #3: 13 Дек 2015, 17:32 »
Потому, что вы кадый раз при создании на сервере устанавливаете ответсвенного, а не только для нового.
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Artjomrgv

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 10
  • КПД: 10%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Re: Пользователь ИБ
« Ответ #4: 14 Дек 2015, 00:06 »
Потому, что вы кадый раз при создании на сервере устанавливаете ответсвенного, а не только для нового.

Но Петров же не создал документ, он просто открыл документ созданный Ивановым?
 Вообщем проблему я решил добавил Объект.Ответственный=Ответственный() в Процедуру ОбработкаЗаполнения на модуле объекта, но честно говоря до конца не понял.

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2640
  • РЕПУТАЦИЯ: 318
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Re: Пользователь ИБ
« Ответ #5: 14 Дек 2015, 03:53 »
Ну почитайте о процедуре - присозданиинасервере , хотябы в синтаксис помощнике

Отправлено с моего Boost через Tapatalk

Помог? Нажми - Спасибо :)
skype: Soprov1C


Теги:
 

Можно ли установить такой режим работы, чтобы пользователь не мог изменять докум

Автор DDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2522
Последний ответ 01 Дек 2009, 21:51
от KRLUYDMILA
Как сделать, чтоб пользователь с определенной ролью не видел определенные записи справочника

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 478
Последний ответ 11 Июл 2016, 11:34
от vitasw
Перенесено: 1С Документооборот: пользователь не видит файл, прикрепленный к задаче

Автор cska-fanat-kzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1260
Последний ответ 28 Апр 2014, 16:58
от cska-fanat-kz
Настройка прав. Пользователь заходит в базу, но документов не видит.

Автор VentDeathРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1327
Последний ответ 14 Окт 2015, 18:47
от дфтын
Надо что бы пользователь мог сам выбирать значения составного типа. Как ? )

Автор ВопросРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1361
Последний ответ 12 Ноя 2009, 10:59
от Belgafood

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
69 Сообщений
MuI_I_Ika MuI_I_Ika
45 Сообщений
LexaK
35 Сообщений
alexandr_ll
34 Сообщений
crow1983
31 Сообщений
sertak sertak
27 Сообщений
Vzonder
21 Сообщений
BuhRust
20 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 965
  • Точка Скрытых: 0
  • Точка Пользователей: 16
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal