Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Янв 2017, 12:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как реализовать автоматическое заполнение полей на форме  (Прочитано 474 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fine

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!

На форме есть поле с ссылкой на справочник "Клиенты". Мне необходимо, чтобы при выборе клиента на форме полю "Номер клиента" автоматически присваивалось значение номера клиента со справочника.


Оффлайн Artjomrgv

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 10
  • КПД: 10%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Здравствуйте!

На форме есть поле с ссылкой на справочник "Клиенты". Мне необходимо, чтобы при выборе клиента на форме полю "Номер клиента" автоматически присваивалось значение номера клиента со справочника.

Если для управляемого приложения то примерно так.
&НаКлиенте
Процедура КлиентПриИзменении(Элемент)   
Отбор =Новый Структура("Ключ", Объект.Клиенты);   
Форма=ПолучитьФорму("Справочник.Клиенты.Форма.ФормаЭлемента", Отбор);
Объект.Номер= Форма.Объект.Код;
КонецПроцедуры

Оффлайн Fine

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!

На форме есть поле с ссылкой на справочник "Клиенты". Мне необходимо, чтобы при выборе клиента на форме полю "Номер клиента" автоматически присваивалось значение номера клиента со справочника.

Если для управляемого приложения то примерно так.
&НаКлиенте
Процедура КлиентПриИзменении(Элемент)   
Отбор =Новый Структура("Ключ", Объект.Клиенты);   
Форма=ПолучитьФорму("Справочник.Клиенты.Форма.ФормаЭлемента", Отбор);
Объект.Номер= Форма.Объект.Код;
КонецПроцедуры

Большое Вам спасибо! У меня вот такой обработчик получился:

&НаКлиенте
Процедура КлиентПриИзменении(Элемент)
   
   Отбор = Новый Структура("Ключ", Объект.Клиент);   
   Форма = ПолучитьФорму("Справочник.Клиенты.Форма.ФормаЭлемента", Отбор);
   Объект.ЕгоНомер = Форма.Объект.Телефон;
   
КонецПроцедуры

Оффлайн Artjomrgv

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 10
  • КПД: 10%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 5733
Последний ответ 16 Авг 2012, 21:50
от Will
Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 266
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 950
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1038
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2076
Последний ответ 30 Ноя 2011, 07:10
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
69 Сообщений
MuI_I_Ika MuI_I_Ika
45 Сообщений
LexaK
35 Сообщений
alexandr_ll
34 Сообщений
crow1983
31 Сообщений
sertak sertak
27 Сообщений
Vzonder
21 Сообщений
BuhRust
20 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 833
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal