Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июл 2017, 11:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как реализовать автоматическое заполнение полей на форме  (Прочитано 661 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fine

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!

На форме есть поле с ссылкой на справочник "Клиенты". Мне необходимо, чтобы при выборе клиента на форме полю "Номер клиента" автоматически присваивалось значение номера клиента со справочника.


Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Здравствуйте!

На форме есть поле с ссылкой на справочник "Клиенты". Мне необходимо, чтобы при выборе клиента на форме полю "Номер клиента" автоматически присваивалось значение номера клиента со справочника.

Если для управляемого приложения то примерно так.
&НаКлиенте
Процедура КлиентПриИзменении(Элемент)   
Отбор =Новый Структура("Ключ", Объект.Клиенты);   
Форма=ПолучитьФорму("Справочник.Клиенты.Форма.ФормаЭлемента", Отбор);
Объект.Номер= Форма.Объект.Код;
КонецПроцедуры

Оффлайн Fine

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!

На форме есть поле с ссылкой на справочник "Клиенты". Мне необходимо, чтобы при выборе клиента на форме полю "Номер клиента" автоматически присваивалось значение номера клиента со справочника.

Если для управляемого приложения то примерно так.
&НаКлиенте
Процедура КлиентПриИзменении(Элемент)   
Отбор =Новый Структура("Ключ", Объект.Клиенты);   
Форма=ПолучитьФорму("Справочник.Клиенты.Форма.ФормаЭлемента", Отбор);
Объект.Номер= Форма.Объект.Код;
КонецПроцедуры

Большое Вам спасибо! У меня вот такой обработчик получился:

&НаКлиенте
Процедура КлиентПриИзменении(Элемент)
   
   Отбор = Новый Структура("Ключ", Объект.Клиент);   
   Форма = ПолучитьФорму("Справочник.Клиенты.Форма.ФормаЭлемента", Отбор);
   Объект.ЕгоНомер = Форма.Объект.Телефон;
   
КонецПроцедуры

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 6749
Последний ответ 16 Авг 2012, 21:50
от Will
Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1434
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2086
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2373
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2330
Последний ответ 30 Ноя 2011, 07:10
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
92 Сообщений
oleg-x
79 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
45 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений
wise wise
21 Сообщений

* Кто онлайн

  • Точка Гостей: 1017
  • Точка Скрытых: 0
  • Точка Пользователей: 19
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal