Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Май 2017, 18:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как реализовать автоматическое заполнение полей на форме  (Прочитано 570 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fine

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!

На форме есть поле с ссылкой на справочник "Клиенты". Мне необходимо, чтобы при выборе клиента на форме полю "Номер клиента" автоматически присваивалось значение номера клиента со справочника.


Оффлайн Artjomrgv

  • ***
  • Сообщений: 124
  • РЕПУТАЦИЯ: 12
  • КПД: 10%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Здравствуйте!

На форме есть поле с ссылкой на справочник "Клиенты". Мне необходимо, чтобы при выборе клиента на форме полю "Номер клиента" автоматически присваивалось значение номера клиента со справочника.

Если для управляемого приложения то примерно так.
&НаКлиенте
Процедура КлиентПриИзменении(Элемент)   
Отбор =Новый Структура("Ключ", Объект.Клиенты);   
Форма=ПолучитьФорму("Справочник.Клиенты.Форма.ФормаЭлемента", Отбор);
Объект.Номер= Форма.Объект.Код;
КонецПроцедуры

Оффлайн Fine

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!

На форме есть поле с ссылкой на справочник "Клиенты". Мне необходимо, чтобы при выборе клиента на форме полю "Номер клиента" автоматически присваивалось значение номера клиента со справочника.

Если для управляемого приложения то примерно так.
&НаКлиенте
Процедура КлиентПриИзменении(Элемент)   
Отбор =Новый Структура("Ключ", Объект.Клиенты);   
Форма=ПолучитьФорму("Справочник.Клиенты.Форма.ФормаЭлемента", Отбор);
Объект.Номер= Форма.Объект.Код;
КонецПроцедуры

Большое Вам спасибо! У меня вот такой обработчик получился:

&НаКлиенте
Процедура КлиентПриИзменении(Элемент)
   
   Отбор = Новый Структура("Ключ", Объект.Клиент);   
   Форма = ПолучитьФорму("Справочник.Клиенты.Форма.ФормаЭлемента", Отбор);
   Объект.ЕгоНомер = Форма.Объект.Телефон;
   
КонецПроцедуры

Оффлайн Artjomrgv

  • ***
  • Сообщений: 124
  • РЕПУТАЦИЯ: 12
  • КПД: 10%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 6314
Последний ответ 16 Авг 2012, 21:50
от Will
Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1310
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1959
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2181
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2225
Последний ответ 30 Ноя 2011, 07:10
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
98 Сообщений
Dethmontt Dethmontt
74 Сообщений
alex0402
64 Сообщений
MuI_I_Ika MuI_I_Ika
55 Сообщений
wise wise
46 Сообщений
Сергей Федоров Сергей Федоров
41 Сообщений
ilyay ilyay
40 Сообщений
ilnur75
22 Сообщений
videomause
22 Сообщений
BuhRust
22 Сообщений

* Кто онлайн

  • Точка Гостей: 379
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal