Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 11:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите доделать отчет Шахматка  (Прочитано 530 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Міша Угера

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-11
  • Сайт: 
Добрый вечер ! помогите доделать отчет типа Шахматка
по вертикали название Профсоюз
по горизонтали номер путевки и фамилия
пересекаться должно по сумме
1с 7.7 комплексная

Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
ВыбНачПериода = НачалоИнтервала();
ВыбКонПериода = КонецИнтервала();
тФирма = Константа.БазФирма.ПолнНаименование;

//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|ОбрабатыватьДокументы НеПроведенные;
|Обрабатывать НеПомеченныеНаУдаление;
|НачДата = Документ.Путевка.НачДата;
|КонДата = Документ.Путевка.КонДата;
|Профсоюз = Документ.Путевка.Профсоюз;
|Путевка = Документ.Путевка.Путевка;
|ФИО = Документ.Путевка.ФИО;
|Сумма = Документ.Путевка.Сумма;
|Флаг = Документ.Путевка.Флаг;
|Функция СуммаСумма = Сумма(Сумма);
|Группировка Профсоюз без групп;
|Группировка Путевка без групп;
|Условие(Флаг=1);
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

Таб = СоздатьОбъект("Таблица");
Если Константа.ФормыНаУкраинском = Да Тогда
Таб.ИсходнаяТаблица("Сформировать");
КонецЕсли;
Таб.ВывестиСекцию("Шапка|Начало");

Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
ном = 0;
Пока Запрос.Группировка("Профсоюз") = 1 Цикл
Таб.Присоединитьсекцию("Шапка|Профсоюз");
КонецЦикла;
ном = ном + 1;
Таб.ВывестиСекцию("Строка|Начало");
Пока Запрос.Группировка("Профсоюз") = 1 Цикл
Таб.Присоединитьсекцию("Строка|Профсоюз");
КонецЦикла;

Таб.ВывестиСекцию("Итого|Начало");
Таб.Присоединитьсекцию("Итого|Профсоюз");
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.ВывестиСекцию("Подвал");
Таб.Показать("Печать ЖурналПутевка","");
КонецПроцедуры
//}}ПРОЦЕДУРА_ПЕЧАТИ

сама таблица


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
93 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
45 Сообщений
AIFrame
41 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal