Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Янв 2017, 11:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите доделать отчет Шахматка  (Прочитано 406 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Міша Угера

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-11
  • Сайт: 
Добрый вечер ! помогите доделать отчет типа Шахматка
по вертикали название Профсоюз
по горизонтали номер путевки и фамилия
пересекаться должно по сумме
1с 7.7 комплексная

Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
ВыбНачПериода = НачалоИнтервала();
ВыбКонПериода = КонецИнтервала();
тФирма = Константа.БазФирма.ПолнНаименование;

//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|ОбрабатыватьДокументы НеПроведенные;
|Обрабатывать НеПомеченныеНаУдаление;
|НачДата = Документ.Путевка.НачДата;
|КонДата = Документ.Путевка.КонДата;
|Профсоюз = Документ.Путевка.Профсоюз;
|Путевка = Документ.Путевка.Путевка;
|ФИО = Документ.Путевка.ФИО;
|Сумма = Документ.Путевка.Сумма;
|Флаг = Документ.Путевка.Флаг;
|Функция СуммаСумма = Сумма(Сумма);
|Группировка Профсоюз без групп;
|Группировка Путевка без групп;
|Условие(Флаг=1);
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

Таб = СоздатьОбъект("Таблица");
Если Константа.ФормыНаУкраинском = Да Тогда
Таб.ИсходнаяТаблица("Сформировать");
КонецЕсли;
Таб.ВывестиСекцию("Шапка|Начало");

Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
ном = 0;
Пока Запрос.Группировка("Профсоюз") = 1 Цикл
Таб.Присоединитьсекцию("Шапка|Профсоюз");
КонецЦикла;
ном = ном + 1;
Таб.ВывестиСекцию("Строка|Начало");
Пока Запрос.Группировка("Профсоюз") = 1 Цикл
Таб.Присоединитьсекцию("Строка|Профсоюз");
КонецЦикла;

Таб.ВывестиСекцию("Итого|Начало");
Таб.Присоединитьсекцию("Итого|Профсоюз");
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.ВывестиСекцию("Подвал");
Таб.Показать("Печать ЖурналПутевка","");
КонецПроцедуры
//}}ПРОЦЕДУРА_ПЕЧАТИ

сама таблица


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
alex0402
55 Сообщений
MuI_I_Ika MuI_I_Ika
48 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
31 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
17 Сообщений

* Кто онлайн

  • Точка Гостей: 991
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal