Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 07:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Связь табличной части Товары и ВидыЗапасов  (Прочитано 742 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xDD

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-11-18
  • Сайт: 
  • Профессия: Программист 8.1
Из Розницы выгружается Отчет о розничных продажах в тч товары есть колонка Виды оплаты (Наличная, безналичная).
В тч Виды запасов добавлена такая же колонка. Необходимо в соответствии с количеством по виду оплаты заполнить тч ВидыЗапасов.
За счет того, что тч Виды запасов формируется автоматически (за счет определения остатка товара по его типу запасов, за счет определения ГТД), то никакой связи между тч Товары и Виды Запасов нет - одна рассчитывается на основе другой.
На текущий момент сложность в чем  - Виде запасов 1 строка, номенклатуры 664 - V, товар собственный.
Но в тч Товары 2 строки - 1 строка наличная оплата, 2 строка - безналичная.
Получается что в виде запасов нужно строку разбить на 2 по виду оплаты и заполнить их.   

тч товары

N   Номенклатура   Ед. изм.   Продано   Цена   Сумма   Вид оплаты
1   664 - V           шт.           1,000   5 705,00   5 705,00   Платежная карта
2   664 - V           шт.           1,000   5 705,00   5 705,00   Безналичная
..............................................................................................
7   664 - V           шт.           2,000   5 705,00   11 410,00   Платежная карта

тч Виды Запасов
НомерСтроки   Номенклатура   ВидЗапасов      Количество   Партнер                   ВидОплаты   ИсходныйНомерСтроки   НомерГТД
        1               664 - V   Собственный товар   4   Розничный покупатель                                      1   

Подскажите у кого есть мысли, как должен выглядеть алгоритм правильного перебора, чтобы заполнить ВидОплаты в ВидеЗапасов.

Думаю двигаться вот в этом направлении:

ТЗТовары = Объект.Товары.Выгрузить();
ТЗТовары.Свернуть("Номенклатура,Характеристика,ВидОплаты","Количество,Сумма,СуммаНДС");
ТЗВидыЗапасов =  Объект.ВидыЗапасов;
Для каждого эл Из ТЗВидыЗапасов  Цикл

         Для каждого элТовар Из ТЗТовары Цикл
       
           Если эл.Номенклатура = элТовар.Номенклатура Тогда
              ПараметрыОтбора = Новый Структура;
              ПараметрыОтбора.Вставить("Номенклатура", эл.Номенклатура);
              НайденныеСтроки1 = ТЗВидыЗапасов.НайтиСтроки(ПараметрыОтбора);
              НайденныеСтроки2 = ТЗТовары.НайтиСтроки(ПараметрыОтбора);
              Если НайденныеСтроки1.Количество()< НайденныеСтроки2.Количество() Тогда
               Сообщить("Всего одна строка нужно делить!");  ///////////////////////////////думаю вот здесь брать ТЗ ТЗВидыЗапасов
удалять строку, далее циклом добавлять 2 строки
              Иначе
                 Если элТовар.Количество >=эл.Количество и  эл.ВидОплаты.Пустая() Тогда
                    эл.ВидОплаты = элТовар.ВидОплаты;
                    элТовар.Количество = элТовар.Количество - эл.Количество;
                 КонецЕсли;
                
              КонецЕсли;
           КонецЕсли;
       
        КонецЦикла;

КонецЦикла;   




Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1946
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3057
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3090
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 666
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 248
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
176 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
41 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 290
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal