Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Янв 2017, 19:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Связь табличной части Товары и ВидыЗапасов  (Прочитано 441 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xDD

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-11-18
  • Сайт: 
  • Профессия: Программист 8.1
Из Розницы выгружается Отчет о розничных продажах в тч товары есть колонка Виды оплаты (Наличная, безналичная).
В тч Виды запасов добавлена такая же колонка. Необходимо в соответствии с количеством по виду оплаты заполнить тч ВидыЗапасов.
За счет того, что тч Виды запасов формируется автоматически (за счет определения остатка товара по его типу запасов, за счет определения ГТД), то никакой связи между тч Товары и Виды Запасов нет - одна рассчитывается на основе другой.
На текущий момент сложность в чем  - Виде запасов 1 строка, номенклатуры 664 - V, товар собственный.
Но в тч Товары 2 строки - 1 строка наличная оплата, 2 строка - безналичная.
Получается что в виде запасов нужно строку разбить на 2 по виду оплаты и заполнить их.   

тч товары

N   Номенклатура   Ед. изм.   Продано   Цена   Сумма   Вид оплаты
1   664 - V           шт.           1,000   5 705,00   5 705,00   Платежная карта
2   664 - V           шт.           1,000   5 705,00   5 705,00   Безналичная
..............................................................................................
7   664 - V           шт.           2,000   5 705,00   11 410,00   Платежная карта

тч Виды Запасов
НомерСтроки   Номенклатура   ВидЗапасов      Количество   Партнер                   ВидОплаты   ИсходныйНомерСтроки   НомерГТД
        1               664 - V   Собственный товар   4   Розничный покупатель                                      1   

Подскажите у кого есть мысли, как должен выглядеть алгоритм правильного перебора, чтобы заполнить ВидОплаты в ВидеЗапасов.

Думаю двигаться вот в этом направлении:

ТЗТовары = Объект.Товары.Выгрузить();
ТЗТовары.Свернуть("Номенклатура,Характеристика,ВидОплаты","Количество,Сумма,СуммаНДС");
ТЗВидыЗапасов =  Объект.ВидыЗапасов;
Для каждого эл Из ТЗВидыЗапасов  Цикл

         Для каждого элТовар Из ТЗТовары Цикл
       
           Если эл.Номенклатура = элТовар.Номенклатура Тогда
              ПараметрыОтбора = Новый Структура;
              ПараметрыОтбора.Вставить("Номенклатура", эл.Номенклатура);
              НайденныеСтроки1 = ТЗВидыЗапасов.НайтиСтроки(ПараметрыОтбора);
              НайденныеСтроки2 = ТЗТовары.НайтиСтроки(ПараметрыОтбора);
              Если НайденныеСтроки1.Количество()< НайденныеСтроки2.Количество() Тогда
               Сообщить("Всего одна строка нужно делить!");  ///////////////////////////////думаю вот здесь брать ТЗ ТЗВидыЗапасов
удалять строку, далее циклом добавлять 2 строки
              Иначе
                 Если элТовар.Количество >=эл.Количество и  эл.ВидОплаты.Пустая() Тогда
                    эл.ВидОплаты = элТовар.ВидОплаты;
                    элТовар.Количество = элТовар.Количество - эл.Количество;
                 КонецЕсли;
                
              КонецЕсли;
           КонецЕсли;
       
        КонецЦикла;

КонецЦикла;   




Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1261
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2555
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2426
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 437
Последний ответ 23 Июн 2015, 14:25
от news
Как вывести число прописью по-русски, с указанием сотых в дробной части?

Автор БухРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8302
Последний ответ 12 Ноя 2009, 16:12
от DDD

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
58 Сообщений
MuI_I_Ika MuI_I_Ika
50 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
31 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 393
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal