Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 08:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите новичку потключить и настроить ШК  (Прочитано 2578 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн oleg200411

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-31
  • Сайт: 
  • Профессия: Ученик 1С
Конфа бухгалтерия торговля и склад 7.7
При пике сканера в карточке товара определяет и перезаписывает код как 0
при наборе в документе вместо соответствующего товара определяет любой другой которыому не задан штрих код


Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
// Эта процедура в глобальном модуле отлавливает данные от сканера штрих кода,
// когда не открыта ни одна из форм, использующих сканер в своей работе.
// Пришедшие данные в данном случае пропускаются, чтобы не заполнять буфер сканера
Если РаботаСоСканеромШтрихКода=2 Тогда
Если Событие="BarCodeValue" Тогда
СканерШтрихКода.ПосылкаДанных = 1;
КонецЕсли;
КонецЕсли;
КонецПроцедуры

// ===============================
Процедура глУстановкаШтрихКода(Конт,Данные) Экспорт
// Разбор строки данных от сканера штрих кода - определение формата штрих-кода
Если ШтрихКодИмеетПрефикс=1 Тогда
Если Найти("MPJS",Лев(Данные,1))=0 Тогда
Предупреждение("Формат считанного штрих-кода не предназначен для товаров.");
Возврат;
Иначе
Данные=Сред(Данные,2,СтрДлина(Данные)-1);
КонецЕсли;
КонецЕсли;
// Запись полученного штрих-кода
Если ПустоеЗначение(Конт.ШтрихКод)=1 Тогда
Конт.ШтрихКод=Число(Данные);
Иначе
Если Вопрос("Штрих-код уже задан. Переписать?", 4 )=6 Тогда
Конт.ШтрихКод=Число(Данные);
КонецЕсли;
КонецЕсли;
КонецПроцедуры
               

Что делать?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
135 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 405
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal