Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Ноя 2018, 09:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как Заполнить форму програмно  (Прочитано 2650 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Есть регистр накопления «Остатки товара» в котором хранится информация о остатках товара. Остатки вывожу через сообщить. Я создал не основную форму списка остатки товара содержащую табличное поле. Как программно обратится к данной форме и заполнить из регистра остатки товара.

На данный момент вот такая процедура
Процедура ОткрытьФормы(Кнопка)
Остатки=РегистрыНакопления.ОстаткиТоваров.Остатки();   
Для каждого стр Из Остатки  Цикл
Сообщить("Остатки "+Стр.Номенклатура+"кол"+стр.Количество );    
КонецЦикла;    
КонецПроцедуры


Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
ЭтаФорма

ТабЧасть = ЭтаФорма.ТабЧасть.Получить();

Можно поставить в табчасти - типзначения и выбрать регистр накопления.

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Если нужно установить отбор в регистре, то можно использовать следующее
ЭлементыФормы.ТабЧасть.ОтборСтрок.ИмяПоля.Значение = Элемент.Значение;
ЭлементыФормы.ТабЧасть.ОтборСтрок.ИмяПоля.Использование = Истина;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1101
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Зачем вам остатки из ТАБЛИЧНОЙ ЧАСТИ привязанной к регистру. Получайте их из самого РЕГИСТРА!
Например так:

Запрос = Новый Запрос;
   
    Запрос.Текст = "ВЫБРАТЬ
                   |    ОстаткиНоменклатурыОстатки.Номенклатура,
                   |    ОстаткиНоменклатурыОстатки.КоличествоОстаток
                   |ИЗ
                   |    РегистрНакопления.ОстаткиНоменклатуры.Остатки КАК ОстаткиНоменклатурыОстатки";
   
    Выборка = Запрос.Выполнить().Выбрать();
   
    Пока Выборка.Следующий() Цикл
       
        Сообщить("Остаток "+Выборка.Номенклатура+" - "+Выборка.КоличествоОстаток);
       
    КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

1с83 КА 2.4 Как добавить кнопку "Движения документа" на форму самописного документа?

Автор buketov.avРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 222
Последний ответ 26 Сен 2018, 11:45
от buketov.av
Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2707
Последний ответ 18 Янв 2017, 12:32
от sertak
Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 995
Последний ответ 15 Май 2017, 08:59
от ZSS
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 4018
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5788
Последний ответ 13 Июн 2017, 12:17
от Whisper

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

wise wise
58 Сообщений
oleg-x
57 Сообщений
AIFrame AIFrame
47 Сообщений
alex0402
44 Сообщений
alexandr_ll
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
42 Сообщений
LexaK
31 Сообщений
BuhRust
28 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 564
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal