Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 06:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите пожалуйста!  (Прочитано 1820 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн voodoo200

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-22
  • Сайт: 
  • Профессия: Программист 7.7
Вобщем задача такова - Есть 2 справочника Сотрудники и Люди в Сотрудниках лежит информация по работе в Люди лежит личная (д.р м.р и. т.д) как выгрузить данные (кроме уволенных) из обоих справочников в txt файл? Помогите оч срочно надо.


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
ФайлИс = СтрЗаменить(Строка(РабочаяДата()),"."," ") + ".txt";   
ФайлИстории = КаталогИБ()   + ФайлИс;   
Файл = СоздатьОбъект("Текст");
СпрСотрудники = СоздатьОбъект("Справочник.Сотрудники");
СпрСотрудники.ВыбратьЭлементы(1);
Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
Файл.Открыть(ФайлИстории);
Файл.ДобавитьСтроку(СпрСотрудники.Наименование);
Файл.ДобавитьСтроку(СпрСотрудники.КемРаботает);
Файл.ДобавитьСтроку(СпрСотрудники.Зарплата);
Файл.Записать(ФайлИстории);
КонецЦикла;
  <_<
ФайлИс1 = СтрЗаменить(Строка(РабочаяДата()),"."," ") + ".txt";   
ФайлИстории1 = КаталогИБ()   + ФайлИс1;   
Файл1 = СоздатьОбъект("Текст");
СпрЛюди = СоздатьОбъект("Справочник.Люди");
СпрЛюди.ВыбратьЭлементы(1);
Пока СпрЛюди.ПолучитьЭлемент() = 1 Цикл
Файл1.Открыть(ФайлИстории1);
Файл1.ДобавитьСтроку(СпрЛюди.Наименование);
Файл1.ДобавитьСтроку(СпрЛюди.СКемСпит);   :thwrt:
Файл1.ДобавитьСтроку(СпрЛюди.ЗаЧтоНеНавидитПрограммиста);   ui;;t;
Файл1.Записать(ФайлИстории1);
КонецЦикла;

 :wacko:

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
ФайлИс1 = СтрЗаменить(Строка(РабочаяДата()),"."," ") + ".txt"; 
меняй на
ФайлИс1 = СтрЗаменить(Строка(РабочаяДата()),"."," ") + "Lydi.txt"; 

в первый раз не пойдет  - скажет файла нет либо агрегатка не обнаружена,
НО создаст их !!!
Запусти ишшо раз и все сделается.

Последний раз редактировалось: prog1c7.7; 22 Дек 2010, 16:52

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
//да, забыл про уволенных:
//после
Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
//добавь
Если
СпрСотрудники.ХарактерРаботы=Перечисление.ХарактерРаботы.ТрудовыеОтношенияПрекращены тогда
Продолжить;
КонецЕсли;



Оффлайн voodoo200

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-22
  • Сайт: 
  • Профессия: Программист 7.7
Спасибо!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
162 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
61 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
Alter
29 Сообщений
ilyay ilyay
29 Сообщений
Анюта17
29 Сообщений

* Кто онлайн

  • Точка Гостей: 289
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal