Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Окт 2017, 20:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удалить  (Прочитано 177 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cwiki

  • Модератор
  • *****
  • Сообщений: 8287
  • РЕПУТАЦИЯ: 10
  • КПД: 0%
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Программист 8.1
Удалить
« Первое сообщение: 05 Дек 2015, 01:09 »
Раздел:
Общие объекты
Подразделы:
Построитель отчета
ИмяОбъекта:
ИзмеренияПостроителяОтчета
ТипСтатьи:
Методы
ИзмеренияПостроителяОтчета.Удалить (ReportBuilderDimensions.Delete)
ИзмеренияПостроителяОтчета (ReportBuilderDimensions)
Удалить (Delete)
Синтаксис:
Удалить(<Измерение>)
Параметры:
<Измерение> (обязательный)
Тип: ИзмерениеПостроителяОтчета.
Удаляемое измерение.
Описание:
Удаляет измерение из коллекции.

Доступность:
Сервер, толстый клиент, внешнее соединение.
Пример:
// Пример 1
Для Индекс=0 По ПостроительОтчета.ИзмеренияСтроки.Количество()-1 Цикл
    ТекущаяСтрока=ПостроительОтчета.ИзмеренияСтроки[Индекс];
    Если ТекущаяСтрока.Имя = ВыбИмя Тогда
        ПутьКДанным = ТекущаяСтрока.ПутьКДанным;
        ПостроительОтчета.ИзмеренияСтроки.Удалить(ТекущаяСтрока);
        Прервать;
    КонецЕсли;
КонецЦикла;

// Пример 2
Если ПостроительОтчета.ИзмеренияКолонки.Количество()>0 Тогда
    ТекущаяКолонка=ПостроительОтчета.ИзмеренияКолонки[0];
    ПостроительОтчета.ИзмеренияКолонки.Удалить(ТекущаяКолонка);
КонецЕсли;




     


Теги:
 


* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
88 Сообщений
alex0402
49 Сообщений
AIFrame
43 Сообщений
Oldman06
31 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
30 Сообщений
vitasw
29 Сообщений
Golickoff Golickoff
28 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
Liv98 Liv98
15 Сообщений
DmitriyF DmitriyF
14 Сообщений

* Кто онлайн

  • Точка Гостей: 309
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal