Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 03:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: В поле табличной части документа не выводятся данные из запроса  (Прочитано 440 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн inkassator

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-02
  • Сайт: 
  • Профессия: Ученик 1С
Нужно чтобы при выборе сотрудника, подставлялись данные в два поля табличной части документа.
Значит в верхней функции запрос выводит данные, а в нижней нет. Хотя вроде все одинаково, ну кроме названия полей.
В чем может быть ошибка в нижнем запросе?

&НаКлиенте
Процедура ВыдачаПриемВооруженияФИОПриИзменении(Элемент)
   // Вставить содержимое обработчика.
СтрТабл=Элементы.ВыдачаПриемВооружения.ТекущиеДанные;
СтрТабл.Оружие=ПолучитьНомерВыданногоОружия(СтрТабл.ФИО);
СтрТабл.Лицензия=ПолучитьНомерЛицензииНаОружие(СтрТабл.ФИО);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьНомерВыданногоОружия(ВладелецРазрешенияНаОружие)
Запрос=Новый Запрос;
Запрос.Текст="ВЫБРАТЬ ВладелецРазрешенияНаОружие,ОружиеСотрудникаИнкассации 
 | ИЗ Справочник.РазрешенияНаОружие
 | ГДЕ ВладелецРазрешенияНаОружие=&ВладелецРазрешенияНаОружие";
     Запрос.УстановитьПараметр("ВладелецРазрешенияНаОружие",ВладелецРазрешенияНаОружие);
     Результат=Запрос.Выполнить().Выбрать();
  Если Результат.Следующий()> 0 Тогда
     Возврат Результат.ОружиеСотрудникаИнкассации;
  КонецЕсли;

КонецФункции

 &НаСервереБезКонтекста
Функция ПолучитьНомерЛицензииНаОружие(ВладелецРазрешенияНаОружие)
Запрос=Новый Запрос;
Запрос.Текст="ВЫБРАТЬ Лицензии.НомерРазрешения,Лицензии.ВладелецРазрешенияНаОружие
 | ИЗ Справочник.РазрешенияНаОружие КАК Лицензии
 | ГДЕ ВладелецРазрешенияНаОружие=&ВладелецРазрешенияНаОружие";
     Запрос.УстановитьПараметр("ВладелецРазрешенияНаОружие",ВладелецРазрешенияНаОружие);
     Результат=Запрос.Выполнить().Выбрать();
  Если Результат.Следующий()> 0 Тогда
     Возврат Результат.НомерРазрешения;
  КонецЕсли;
 
КонецФункции


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Может поле не заполнено? Отладчик что говорит?
Почему одним запросов не выбрать оба поля в структуру и не вернуть на клиент структуру с уже 2-мя полями? зачем 2 раза гонять запрос!?


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4189
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7229
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4275
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7234
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6877
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
93 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
49 Сообщений
ilyay ilyay
44 Сообщений
AIFrame
40 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 155
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal