Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2017, 17:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Префикс подразделений в КА  (Прочитано 443 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн magnifico61

  • ***
  • Сообщений: 203
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
В КА при создании обособленного подразделения есть поле "Префикс кассовых документов". Как я понимаю он используется для печатных форм и имеет вид Номер/Префикс кассовых документов. Этот код я нашел в модуле "УчетНДСФормированиеДвижений". Но вот вся проблема в том, что это поле не доступно.
Подскажите как мне сделать префикс (вида Номер/Префикс) для обособленного подразделения?

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн magnifico61

  • ***
  • Сообщений: 203
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Как поставить префикс разобрался. Теперь не понятно почему он ищет префикс по организации, а не по подразделению.

Процедура ДополнитьНомерИндексомОбособленногоПодразделения(СтруктураШапкиДокумента, НомерДокумента) Экспорт

РеквизитыОрганизации = ОбщегоНазначения.ПолучитьЗначенияРеквизитов(
СтруктураШапкиДокумента.Организация, "ГоловнаяОрганизация,ЦифровойИндексОбособленногоПодразделения");
Если НЕ ЗначениеЗаполнено(РеквизитыОрганизации.ГоловнаяОрганизация) Тогда
Возврат;
КонецЕсли;
Если ЗначениеЗаполнено(РеквизитыОрганизации.ЦифровойИндексОбособленногоПодразделения) Тогда
НомерДокумента = НомерДокумента + "/" + РеквизитыОрганизации.ЦифровойИндексОбособленногоПодразделения;
КонецЕсли;

КонецПроцедуры


Теги:
 

Префикс документу "ГГГГММДД/"

Автор NuuqРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1865
Последний ответ 02 Мар 2010, 06:48
от Slin
Можно ли получить префикс документа при "пользовательском" редактировании макета в БП 3.0?

Автор kornilov_rvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3409
Последний ответ 21 Фев 2014, 14:33
от MuI_I_Ika
Префикс в печатной форме Комплесной автоматизации

Автор MiBРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1570
Последний ответ 06 Апр 2014, 20:37
от MiB
Буквенный префикс в нумерации элементов номенклатуры

Автор Шамиль05Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 766
Последний ответ 23 Окт 2015, 11:24
от Шамиль05
Префикс у объектов при обмене между КА и УПП

Автор digoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1943
Последний ответ 14 Янв 2011, 17:32
от digo

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
155 Сообщений
alex0402
80 Сообщений
alexandr_ll
37 Сообщений
LexaK
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
crow1983
27 Сообщений
sertak sertak
22 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
15 Сообщений
Vzonder
14 Сообщений

* Кто онлайн

  • Точка Гостей: 657
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal