Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Июл 2017, 19:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Префикс подразделений в КА  (Прочитано 672 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн magnifico61

  • ****
  • Сообщений: 297
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
В КА при создании обособленного подразделения есть поле "Префикс кассовых документов". Как я понимаю он используется для печатных форм и имеет вид Номер/Префикс кассовых документов. Этот код я нашел в модуле "УчетНДСФормированиеДвижений". Но вот вся проблема в том, что это поле не доступно.
Подскажите как мне сделать префикс (вида Номер/Префикс) для обособленного подразделения?


Оффлайн magnifico61

  • ****
  • Сообщений: 297
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Как поставить префикс разобрался. Теперь не понятно почему он ищет префикс по организации, а не по подразделению.

Процедура ДополнитьНомерИндексомОбособленногоПодразделения(СтруктураШапкиДокумента, НомерДокумента) Экспорт

РеквизитыОрганизации = ОбщегоНазначения.ПолучитьЗначенияРеквизитов(
СтруктураШапкиДокумента.Организация, "ГоловнаяОрганизация,ЦифровойИндексОбособленногоПодразделения");
Если НЕ ЗначениеЗаполнено(РеквизитыОрганизации.ГоловнаяОрганизация) Тогда
Возврат;
КонецЕсли;
Если ЗначениеЗаполнено(РеквизитыОрганизации.ЦифровойИндексОбособленногоПодразделения) Тогда
НомерДокумента = НомерДокумента + "/" + РеквизитыОрганизации.ЦифровойИндексОбособленногоПодразделения;
КонецЕсли;

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
96 Сообщений
oleg-x
75 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
53 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
40 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 278
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal