Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Мар 2017, 01:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Префикс подразделений в КА  (Прочитано 527 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн magnifico61

  • ***
  • Сообщений: 221
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
В КА при создании обособленного подразделения есть поле "Префикс кассовых документов". Как я понимаю он используется для печатных форм и имеет вид Номер/Префикс кассовых документов. Этот код я нашел в модуле "УчетНДСФормированиеДвижений". Но вот вся проблема в том, что это поле не доступно.
Подскажите как мне сделать префикс (вида Номер/Префикс) для обособленного подразделения?


Оффлайн magnifico61

  • ***
  • Сообщений: 221
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Как поставить префикс разобрался. Теперь не понятно почему он ищет префикс по организации, а не по подразделению.

Процедура ДополнитьНомерИндексомОбособленногоПодразделения(СтруктураШапкиДокумента, НомерДокумента) Экспорт

РеквизитыОрганизации = ОбщегоНазначения.ПолучитьЗначенияРеквизитов(
СтруктураШапкиДокумента.Организация, "ГоловнаяОрганизация,ЦифровойИндексОбособленногоПодразделения");
Если НЕ ЗначениеЗаполнено(РеквизитыОрганизации.ГоловнаяОрганизация) Тогда
Возврат;
КонецЕсли;
Если ЗначениеЗаполнено(РеквизитыОрганизации.ЦифровойИндексОбособленногоПодразделения) Тогда
НомерДокумента = НомерДокумента + "/" + РеквизитыОрганизации.ЦифровойИндексОбособленногоПодразделения;
КонецЕсли;

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
158 Сообщений
alex0402
123 Сообщений
MuI_I_Ika MuI_I_Ika
55 Сообщений
Norfolk
52 Сообщений
LexaK
49 Сообщений
alexandr_ll
20 Сообщений
друган
20 Сообщений
AsadRoman
18 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 249
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal