Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Сен 2020, 07:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: вынести итоговую сумму документов в список управляемой формы конфигуратор 1с  (Прочитано 3816 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Товарищи программисты,
Я новичок в этом деле и создан простую инф.базу
Прошу вашей помощи в решении задачи - вынести сумму документов в список упр. формы

т.к. мой шеф не хочет заходить в каждый документ и смотреть общ. сумму :xfbnsdfb:

Подскажите пожалуйста пути решения!

Заранее Спасибо!


Оффлайн Дмитрий Сенин

  • Бог просто бог
  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • May the code be with you
  • Регистрация: 2015-11-27
  • Компания: ИГЭУ им. В.И.Ленина
  • Профессия: Разработчик 1С
Не совсем понял: Вам надо сумму всех доков вынести или сумму каждого дока в форму списка?

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
каждого в отдельности.

1. ООО "Авангард" дата сумма
2. .....   25.11.15 15000 руб.


Оффлайн cast

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 4
  • КПД: 8%
  • Регистрация: 2015-05-09
  • Сайт: 
В данных документа добавь поле СуммаДокумента
В модуле объекта

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   СуммаДокумента = 0;
   Для Каждого СтрТЧ ИЗ ТЧП Цикл
      СуммаДокумента = СуммаДокумента + СтрТЧ.Сумма;
      
   КонецЦикла;

КонецПроцедуры

Потом выводишь список документа там галочки поставишь и всё.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Пишет что ...


МодульОбъекта(26,25)}: Переменная не определена (ТЧП)
   Для Каждого СтрТЧ ИЗ <<?>>ТЧП Цикл (Проверка: Сервер)
Что не так?

Оффлайн cast

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 4
  • КПД: 8%
  • Регистрация: 2015-05-09
  • Сайт: 
ТЧП Имя табличной части документа. Подставь из документа

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
тема закрыта.
Всем спасибо!



p.s. за "недорого" любой дк может. а ты дельный совет дай.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1103
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В данных документа добавь поле СуммаДокумента
В модуле объекта

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   СуммаДокумента = 0;
   Для Каждого СтрТЧ ИЗ ТЧП Цикл
      СуммаДокумента = СуммаДокумента + СтрТЧ.Сумма;
      
   КонецЦикла;

КонецПроцедуры

Потом выводишь список документа там галочки поставишь и всё.


СуммаДокумента = ТЧП.Итог("Сумма");

ВСЕ! ))
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


 

Для объекта конфигурации есть возможность выбирать способ редактирования ("в диалоге", "в списке", "обоими способами)" и выбора ("из формы", "быстрый выбор", "обоими способами")

Автор MusulmaninРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 315
Последний ответ 06 Апр 2020, 10:53
от Musulmanin
Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2860
Последний ответ 21 Сен 2017, 10:33
от Insider
Элемент формы СписокЗначений с типом СписокЗначений

Автор Людмила КиреенковаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1143
Последний ответ 20 Мар 2019, 10:20
от AIFrame
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1160
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6551
Последний ответ 03 Авг 2011, 11:45
от t955938

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
oooo800
39 Сообщений
LexaK
31 Сообщений
Дмитрий Джей Дмитрий Джей
29 Сообщений
IL2016
28 Сообщений
antoneus antoneus
24 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
illiona
10 Сообщений

* Кто онлайн

  • Точка Гостей: 281
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal