Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2017, 20:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: вынести итоговую сумму документов в список управляемой формы конфигуратор 1с  (Прочитано 1215 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Товарищи программисты,
Я новичок в этом деле и создан простую инф.базу
Прошу вашей помощи в решении задачи - вынести сумму документов в список упр. формы

т.к. мой шеф не хочет заходить в каждый документ и смотреть общ. сумму :xfbnsdfb:

Подскажите пожалуйста пути решения!

Заранее Спасибо!


Оффлайн Дмитрий Сенин

  • Бог просто бог
  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • May the code be with you
  • Регистрация: 2015-11-27
  • Компания: ИГЭУ им. В.И.Ленина
  • Профессия: Разработчик 1С
Не совсем понял: Вам надо сумму всех доков вынести или сумму каждого дока в форму списка?

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
каждого в отдельности.

1. ООО "Авангард" дата сумма
2. .....   25.11.15 15000 руб.


Оффлайн cast

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 4
  • КПД: 9%
  • Регистрация: 2015-05-09
  • Сайт: 
В данных документа добавь поле СуммаДокумента
В модуле объекта

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   СуммаДокумента = 0;
   Для Каждого СтрТЧ ИЗ ТЧП Цикл
      СуммаДокумента = СуммаДокумента + СтрТЧ.Сумма;
      
   КонецЦикла;

КонецПроцедуры

Потом выводишь список документа там галочки поставишь и всё.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Пишет что ...


МодульОбъекта(26,25)}: Переменная не определена (ТЧП)
   Для Каждого СтрТЧ ИЗ <<?>>ТЧП Цикл (Проверка: Сервер)
Что не так?

Оффлайн cast

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 4
  • КПД: 9%
  • Регистрация: 2015-05-09
  • Сайт: 
ТЧП Имя табличной части документа. Подставь из документа

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
тема закрыта.
Всем спасибо!



p.s. за "недорого" любой дк может. а ты дельный совет дай.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В данных документа добавь поле СуммаДокумента
В модуле объекта

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   СуммаДокумента = 0;
   Для Каждого СтрТЧ ИЗ ТЧП Цикл
      СуммаДокумента = СуммаДокумента + СтрТЧ.Сумма;
      
   КонецЦикла;

КонецПроцедуры

Потом выводишь список документа там галочки поставишь и всё.


СуммаДокумента = ТЧП.Итог("Сумма");

ВСЕ! ))
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
63 Сообщений
MuI_I_Ika MuI_I_Ika
46 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
32 Сообщений
sertak sertak
27 Сообщений
Vzonder
22 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 252
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal