Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Окт 2017, 12:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: вынести итоговую сумму документов в список управляемой формы конфигуратор 1с  (Прочитано 1706 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Товарищи программисты,
Я новичок в этом деле и создан простую инф.базу
Прошу вашей помощи в решении задачи - вынести сумму документов в список упр. формы

т.к. мой шеф не хочет заходить в каждый документ и смотреть общ. сумму :xfbnsdfb:

Подскажите пожалуйста пути решения!

Заранее Спасибо!


Оффлайн Дмитрий Сенин

  • Бог просто бог
  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • May the code be with you
  • Регистрация: 2015-11-27
  • Компания: ИГЭУ им. В.И.Ленина
  • Профессия: Разработчик 1С
Не совсем понял: Вам надо сумму всех доков вынести или сумму каждого дока в форму списка?

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
каждого в отдельности.

1. ООО "Авангард" дата сумма
2. .....   25.11.15 15000 руб.


Оффлайн cast

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 4
  • КПД: 8%
  • Регистрация: 2015-05-09
  • Сайт: 
В данных документа добавь поле СуммаДокумента
В модуле объекта

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   СуммаДокумента = 0;
   Для Каждого СтрТЧ ИЗ ТЧП Цикл
      СуммаДокумента = СуммаДокумента + СтрТЧ.Сумма;
      
   КонецЦикла;

КонецПроцедуры

Потом выводишь список документа там галочки поставишь и всё.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Пишет что ...


МодульОбъекта(26,25)}: Переменная не определена (ТЧП)
   Для Каждого СтрТЧ ИЗ <<?>>ТЧП Цикл (Проверка: Сервер)
Что не так?

Оффлайн cast

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 4
  • КПД: 8%
  • Регистрация: 2015-05-09
  • Сайт: 
ТЧП Имя табличной части документа. Подставь из документа

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
тема закрыта.
Всем спасибо!



p.s. за "недорого" любой дк может. а ты дельный совет дай.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1098
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В данных документа добавь поле СуммаДокумента
В модуле объекта

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   СуммаДокумента = 0;
   Для Каждого СтрТЧ ИЗ ТЧП Цикл
      СуммаДокумента = СуммаДокумента + СтрТЧ.Сумма;
      
   КонецЦикла;

КонецПроцедуры

Потом выводишь список документа там галочки поставишь и всё.


СуммаДокумента = ТЧП.Итог("Сумма");

ВСЕ! ))
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 183
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4692
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3323
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4824
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 516
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
93 Сообщений
alex0402
50 Сообщений
AIFrame
42 Сообщений
Oldman06
31 Сообщений
vitasw
29 Сообщений
Golickoff Golickoff
28 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
25 Сообщений
Liv98 Liv98
20 Сообщений
DmitriyF DmitriyF
14 Сообщений

* Кто онлайн

  • Точка Гостей: 1143
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal