Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 19:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: вынести итоговую сумму документов в список управляемой формы конфигуратор 1с  (Прочитано 1503 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Товарищи программисты,
Я новичок в этом деле и создан простую инф.базу
Прошу вашей помощи в решении задачи - вынести сумму документов в список упр. формы

т.к. мой шеф не хочет заходить в каждый документ и смотреть общ. сумму :xfbnsdfb:

Подскажите пожалуйста пути решения!

Заранее Спасибо!


Оффлайн Дмитрий Сенин

  • Бог просто бог
  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • May the code be with you
  • Регистрация: 2015-11-27
  • Компания: ИГЭУ им. В.И.Ленина
  • Профессия: Разработчик 1С
Не совсем понял: Вам надо сумму всех доков вынести или сумму каждого дока в форму списка?

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
каждого в отдельности.

1. ООО "Авангард" дата сумма
2. .....   25.11.15 15000 руб.


Оффлайн cast

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 4
  • КПД: 8%
  • Регистрация: 2015-05-09
  • Сайт: 
В данных документа добавь поле СуммаДокумента
В модуле объекта

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   СуммаДокумента = 0;
   Для Каждого СтрТЧ ИЗ ТЧП Цикл
      СуммаДокумента = СуммаДокумента + СтрТЧ.Сумма;
      
   КонецЦикла;

КонецПроцедуры

Потом выводишь список документа там галочки поставишь и всё.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Пишет что ...


МодульОбъекта(26,25)}: Переменная не определена (ТЧП)
   Для Каждого СтрТЧ ИЗ <<?>>ТЧП Цикл (Проверка: Сервер)
Что не так?

Оффлайн cast

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 4
  • КПД: 8%
  • Регистрация: 2015-05-09
  • Сайт: 
ТЧП Имя табличной части документа. Подставь из документа

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
тема закрыта.
Всем спасибо!



p.s. за "недорого" любой дк может. а ты дельный совет дай.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В данных документа добавь поле СуммаДокумента
В модуле объекта

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   СуммаДокумента = 0;
   Для Каждого СтрТЧ ИЗ ТЧП Цикл
      СуммаДокумента = СуммаДокумента + СтрТЧ.Сумма;
      
   КонецЦикла;

КонецПроцедуры

Потом выводишь список документа там галочки поставишь и всё.


СуммаДокумента = ТЧП.Итог("Сумма");

ВСЕ! ))
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
95 Сообщений
oleg-x
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
45 Сообщений
AIFrame
42 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 386
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal