Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2017, 21:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывести в табличную часть макета, картинку из навигационнойссылке  (Прочитано 270 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mauar

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-29
  • Сайт: 
Храню картинку в справочнике сотрудники так:

&НаКлиенте
Процедура ЗагрузитьШтамп(Команда)
ПолученныеДанныеАдрес = "";
Если ПоместитьФайл(ПолученныеДанныеАдрес, , Объект.ПодписьШтамп, Истина, УникальныйИдентификатор)Тогда ДанныеАдресШтампа = ПолученныеДанныеАдрес;
ВыбранныйФайл = Новый Файл(Объект.ПодписьШтамп);
Модифицированность = Истина;
КонецЕсли;
КонецПроцедуры

Выводится картинка в реквизит ДанныеАдресШтампа строковой тип, на форме вид ПолеКартинки

Тут я при закрытии сохраняю эту картинку как навигационную ссылку в реквизит "Штамп" с типом временноехранилище:

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ЭтоАдресВременногоХранилища(ДанныеАдресШтампа) Тогда РежимСжатия = Новый СжатиеДанных(9); ДанныеСохранения = ПолучитьИзВременногоХранилища(ДанныеАдресШтампа);
ТекущийОбъект.Штамп = Новый ХранилищеЗначения(ДанныеСохранения, РежимСжатия);
КонецЕсли;
КонецПроцедуры
 

Тут я при открытии вывожу загруженную картинку:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Если НЕ Параметры.Ключ.Пустая()
Тогда ДанныеАдресШтампа = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Штамп");
КонецЕсли;
КонецПроцедуры

Всё работает.

Теперь мне нужно эту самую загруженную картинку загрузить в рисунок макета табличной части,
заполняю макет, пытаясь вывести эту картинку так:

Если СПечатямиМакет=Истина 
Тогда ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
ДанныеМенеджера = Справочники.Сотрудники.НайтиПоКоду(АктПечать.ДоговорКонтрагента.Менеджер.Код).ПолучитьОбъект();
Если ДанныеМенеджера <> NULL Тогда
Если ДанныеМенеджера.ИмеетПравоПодписи = Истина
Тогда ШтампМенеджера = ПолучитьНавигационнуюСсылку(ДанныеМенеджера.Ссылка, "Штамп");

Если ЗначениеЗаполнено(ШтампМенеджера )
Тогда
ОбластьМакета.Рисунки.D1.Картинка = ШтампМенеджера ; КонецЕсли; ТабДок.Вывести(ОбластьМакета);


Ничего не получается, не хочет выводить он этот штамп в картинку, преобразование делал.


При этом спокойно выводит эту картинку в текстовый реквизит с видом картинка из любой другой формы, любого другого документа.
Как эту картинку вывести в макет?

 



Теги:
 

Часть четвертая: переход на «1С» версии «3.0». Где в программе находятся «Параметры учета»? Алгоритм настройки кадрового учета в новой версии программы «1С»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 2829
Последний ответ 20 Мар 2015, 12:58
от 1cwiki
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1946
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
табличная часть, реквизит "сумма"

Автор otabekРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1758
Последний ответ 01 Мар 2014, 22:27
от DmitriyF
часть уплаченного НДФЛ не попадает в справку 2-ндфл

Автор КаринаСРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1218
Последний ответ 30 Янв 2015, 02:08
от MuI_I_Ika
Уменьшение закупочной цены-уменьшение прибыли на часть товара

Автор AinaРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2590
Последний ответ 13 Дек 2012, 18:46
от Aina

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
alex0402
65 Сообщений
MuI_I_Ika MuI_I_Ika
47 Сообщений
crow1983
35 Сообщений
alexandr_ll
33 Сообщений
LexaK
32 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 284
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal