Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Июл 2017, 05:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывести в табличную часть макета, картинку из навигационнойссылке  (Прочитано 348 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mauar

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-29
  • Сайт: 
Храню картинку в справочнике сотрудники так:

&НаКлиенте
Процедура ЗагрузитьШтамп(Команда)
ПолученныеДанныеАдрес = "";
Если ПоместитьФайл(ПолученныеДанныеАдрес, , Объект.ПодписьШтамп, Истина, УникальныйИдентификатор)Тогда ДанныеАдресШтампа = ПолученныеДанныеАдрес;
ВыбранныйФайл = Новый Файл(Объект.ПодписьШтамп);
Модифицированность = Истина;
КонецЕсли;
КонецПроцедуры

Выводится картинка в реквизит ДанныеАдресШтампа строковой тип, на форме вид ПолеКартинки

Тут я при закрытии сохраняю эту картинку как навигационную ссылку в реквизит "Штамп" с типом временноехранилище:

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ЭтоАдресВременногоХранилища(ДанныеАдресШтампа) Тогда РежимСжатия = Новый СжатиеДанных(9); ДанныеСохранения = ПолучитьИзВременногоХранилища(ДанныеАдресШтампа);
ТекущийОбъект.Штамп = Новый ХранилищеЗначения(ДанныеСохранения, РежимСжатия);
КонецЕсли;
КонецПроцедуры
 

Тут я при открытии вывожу загруженную картинку:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Если НЕ Параметры.Ключ.Пустая()
Тогда ДанныеАдресШтампа = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Штамп");
КонецЕсли;
КонецПроцедуры

Всё работает.

Теперь мне нужно эту самую загруженную картинку загрузить в рисунок макета табличной части,
заполняю макет, пытаясь вывести эту картинку так:

Если СПечатямиМакет=Истина 
Тогда ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
ДанныеМенеджера = Справочники.Сотрудники.НайтиПоКоду(АктПечать.ДоговорКонтрагента.Менеджер.Код).ПолучитьОбъект();
Если ДанныеМенеджера <> NULL Тогда
Если ДанныеМенеджера.ИмеетПравоПодписи = Истина
Тогда ШтампМенеджера = ПолучитьНавигационнуюСсылку(ДанныеМенеджера.Ссылка, "Штамп");

Если ЗначениеЗаполнено(ШтампМенеджера )
Тогда
ОбластьМакета.Рисунки.D1.Картинка = ШтампМенеджера ; КонецЕсли; ТабДок.Вывести(ОбластьМакета);


Ничего не получается, не хочет выводить он этот штамп в картинку, преобразование делал.


При этом спокойно выводит эту картинку в текстовый реквизит с видом картинка из любой другой формы, любого другого документа.
Как эту картинку вывести в макет?

 



Теги:
 

Часть четвертая: переход на «1С» версии «3.0». Где в программе находятся «Параметры учета»? Алгоритм настройки кадрового учета в новой версии программы «1С»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 3441
Последний ответ 20 Мар 2015, 12:58
от 1cwiki
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3043
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
табличная часть, реквизит "сумма"

Автор otabekРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2137
Последний ответ 01 Мар 2014, 22:27
от DmitriyF
часть уплаченного НДФЛ не попадает в справку 2-ндфл

Автор КаринаСРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1477
Последний ответ 30 Янв 2015, 02:08
от MuI_I_Ika
Уменьшение закупочной цены-уменьшение прибыли на часть товара

Автор AinaРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3227
Последний ответ 13 Дек 2012, 18:46
от Aina

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
91 Сообщений
oleg-x
83 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
44 Сообщений
AIFrame
42 Сообщений
Амал
30 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений
wise wise
21 Сообщений

* Кто онлайн

  • Точка Гостей: 239
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal