Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2017, 10:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С 8.2 В форме отчета не работает метод ПолучитьМакет  (Прочитано 634 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kaidj

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Процедура Команда1(Команда)
      Остатки = РегистрыНакопления.ОстаткиТоваров.Остатки();
      Макет = Отчеты.ОстаткиТоваров.ПолучитьМакет("Макет");
      ТабДок = Новый ТабличныйДокумент;
      Область = Макет.ПолучитьОбласть ("Шапка");
      ТабДок.Вывести(Область);
            Для Каждого Строка Из Остатки Цикл
            Область = Макет.ПолучитьОбласть("Строка");
            Область.Параметры.Номенклатура = Строка.Номенклатура;
            Область.Параметры.Объем = Строка.Объем;
            ТабДок.Вывести(Область);
      КонецЦикла;           
ТабДок.Показать();     
КонецПроцедуры

понимаю что косяк, ибо процедуру с кнопкой на сервере видимо бессмысленно выводить.
При нажатии на кнопку ни отчета ни ошибки не выводит, что с этим делать?


Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 348
  • РЕПУТАЦИЯ: 65
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Разработчик 1С
Процедура Команда1(Команда)
      Остатки = РегистрыНакопления.ОстаткиТоваров.Остатки();
      Макет = Отчеты.ОстаткиТоваров.ПолучитьМакет("Макет");
      ТабДок = Новый ТабличныйДокумент;
      Область = Макет.ПолучитьОбласть ("Шапка");
      ТабДок.Вывести(Область);
            Для Каждого Строка Из Остатки Цикл
            Область = Макет.ПолучитьОбласть("Строка");
            Область.Параметры.Номенклатура = Строка.Номенклатура;
            Область.Параметры.Объем = Строка.Объем;
            ТабДок.Вывести(Область);
      КонецЦикла;           
ТабДок.Показать();     
КонецПроцедуры

понимаю что косяк, ибо процедуру с кнопкой на сервере видимо бессмысленно выводить.
При нажатии на кнопку ни отчета ни ошибки не выводит, что с этим делать?
Вообще ничего не происходит, либо выводится пустой ТабличныйДокумент?
Если я Вам помог, нажми - Спасибо!

Оффлайн kaidj

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Процедура Команда1(Команда)
      Остатки = РегистрыНакопления.ОстаткиТоваров.Остатки();
      Макет = Отчеты.ОстаткиТоваров.ПолучитьМакет("Макет");
      ТабДок = Новый ТабличныйДокумент;
      Область = Макет.ПолучитьОбласть ("Шапка");
      ТабДок.Вывести(Область);
            Для Каждого Строка Из Остатки Цикл
            Область = Макет.ПолучитьОбласть("Строка");
            Область.Параметры.Номенклатура = Строка.Номенклатура;
            Область.Параметры.Объем = Строка.Объем;
            ТабДок.Вывести(Область);
      КонецЦикла;           
ТабДок.Показать();     
КонецПроцедуры

понимаю что косяк, ибо процедуру с кнопкой на сервере видимо бессмысленно выводить.
При нажатии на кнопку ни отчета ни ошибки не выводит, что с этим делать?
Вообще ничего не происходит, либо выводится пустой ТабличныйДокумент?

вообще ничего не происходит
Добавлено: 27 Ноя 2015, 10:54

Я так понял, "Макет" и "Остатки" каким то образом надо на сервере объявить а потом выводить Все на клиенте

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2640
  • РЕПУТАЦИЯ: 318
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
так 'то у вас что? управляемые формы? обычные? на клиенте ? на сервере?
Помог? Нажми - Спасибо :)
skype: Soprov1C


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 263
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 5065
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 947
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1486
Последний ответ 27 Май 2015, 10:02
от casper009
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1027
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
155 Сообщений
alex0402
74 Сообщений
alexandr_ll
38 Сообщений
crow1983
31 Сообщений
LexaK
31 Сообщений
MuI_I_Ika MuI_I_Ika
26 Сообщений
sertak sertak
23 Сообщений
BuhRust
18 Сообщений
дфтын дфтын
17 Сообщений
Vzonder
16 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal