Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поиск в основной форме обработки ссылок на формирование табличной части  (Прочитано 3526 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Добрый день!
Вот и настало время и мне задать сложный для меня вопрос.
Управление торговлей 10.2
Обработка - ПодборНоменклатуры, соответственно сылки для таб. частей из этого справочника.
В строке выбора программно определены 2 вида подбора - ПоСправочнику и ПоОстаткамТоваров
При задании выбора (ВНИМАНИЕ!) состав табличной части "ПодборНоменклатуры" меняется, хотя в форме Обработки табличная часть построена из 14(!) колонок, а отображается только :
4 - в случае выбора ПоСправочнику, и
5 - в случае выбора ПоОстаткамТоваров

Мне конкретно нужно добавить в отображаемое табличное поле 2 колонки : ЦЕНА и КОЛИЧЕСТВО
ГДЕ формируется состав колонок для отображения в табличном поле формы Обработки?
И
КАК добавить эти колонки - хоть из справочника, хоть из регистра сведений... УМА НЕ ПРИЛОЖУ. Бьюсь уже вторые сутки, спал всего 4 часа.



Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Если нужно - выложу фрагменты кода... правда База - 272 метра...

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Неужели такой сложный вопрос?? Подскажите плиз, очень нужно!

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Хорошо, пишу пока в чем разобрался- за формирование колонок табличной части "ПанельНоменклатурыДляПодбора" отвечает вот эта строчка кода:

Если ПодборПоСправочнику Тогда
      ЭлементыФормы.ПанельНоменклатураДляПодбора.ТекущаяСтраница   = ЭлементыФормы.ПанельНоменклатураДляПодбора.Страницы["ПоСправочнику"];
      ЭтаФорма.ЭлементыФормы.СправочникНоменклатура.ТекущаяКолонка = ЭтаФорма.ЭлементыФормы.СправочникНоменклатура.Колонки.Наименование;

Как найти и изменить Страницы["ПоСправочнику"]; ?? Помогите плиз

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Для полноты представления привожу полный текст процедуры:


Процедура ПриИзмененииВидаПодбора(СтруктураЗапроса)

   Перем Команда;

   мИмяРегистраДляПодбораСерий = "";

   ПодборПоСправочнику = ЗначениеНеЗаполнено(СтруктураЗапроса);
   
   СтруктураИсходныхПараметров.Свойство("Команда", Команда);

   Если мИспользоватьХарактеристики Тогда
      Если Команда = "ПодборВТабличнуюЧастьУслуги"
       ИЛИ Команда = "ПодборВТабличнуюЧастьВозвратнаяТара" Тогда
         Если ЭлементыФормы.ЗапрашиватьХарактеристику.Доступность Тогда
            СохранитьЗначение("ЗапрашиватьХарактеристикуПриПодборе", ЗапрашиватьХарактеристику);
         КонецЕсли;

         ЭлементыФормы.ЗапрашиватьХарактеристику.Доступность = Ложь;
         ЗапрашиватьХарактеристику                           = Ложь;
      Иначе
         ЭлементыФормы.ЗапрашиватьХарактеристику.Доступность = Истина;
         ЗапрашиватьХарактеристику                           = ВосстановитьЗначение("ЗапрашиватьХарактеристикуПриПодборе");
      КонецЕсли;
   КонецЕсли;

   ЭлементыФормы.КоманднаяПанельНоменклатураДляПодбора.Видимость = ПодборПоСправочнику;
   ЭлементыФормы.ИнфНадписьПараметрыПодбора.Видимость = Не ПодборПоСправочнику;
   ЭлементыФормы.КнопкаОбновить.Видимость             = Не ПодборПоСправочнику;
   ЭлементыФормы.НадписьДатаРасчетов.Видимость        = Не (ПодборПоСправочнику или ЗначениеНеЗаполнено(ДатаРасчетов));
   ЭлементыФормы.ДатаРасчетов.Видимость               = Не (ПодборПоСправочнику или ЗначениеНеЗаполнено(ДатаРасчетов));

   Если ПодборПоСправочнику Тогда
      ЭлементыФормы.ПанельНоменклатураДляПодбора.ТекущаяСтраница   = ЭлементыФормы.ПанельНоменклатураДляПодбора.Страницы["ПоСправочнику"];
      ЭтаФорма.ЭлементыФормы.СправочникНоменклатура.ТекущаяКолонка = ЭтаФорма.ЭлементыФормы.СправочникНоменклатура.Колонки.Наименование;
   Иначе
      ЭлементыФормы.ПанельНоменклатураДляПодбора.ТекущаяСтраница   = ЭлементыФормы.ПанельНоменклатураДляПодбора.Страницы["ПоЗапросу"];
      ЭтаФорма.ЭлементыФормы.НоменклатураДляПодбора.ТекущаяКолонка = ЭтаФорма.ЭлементыФормы.НоменклатураДляПодбора.Колонки.Номенклатура;
   КонецЕсли;

   // Заполним таблицу номенклатуры текущего родителя.
   Родитель = ПолучитьТекущегоРодителя();
   Родитель = ?(ЗначениеНеЗаполнено(Родитель), Справочники.Номенклатура.ПустаяСсылка(), Родитель);

   ПерезаполнитьТаблицуНоменклатуры(Родитель, СтруктураЗапроса);
   ОбновитьИнформационнуюНадписьПараметрыПодбора(СтруктураЗапроса);

КонецПроцедуры // ПриИзмененииВидаПодбора()

То, что нужно - в блоке "Если ПодборПоСправочнику Тогда"...

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Вроде разобрался - приведенный код абсолютно не причем, все дело в нескольких вкладках основной формы... Это в принципе действенная методика - когда надеятся, кроме как на самого себя, не на кого, срабатывает принцип"бросания в воду" - выплывет, научиться плавать; не выплывет - учи книжки дальше.. :)


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1755
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 267
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2273
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 290
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2753
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 258
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal