Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2017, 07:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Дополнительный отчет БП 3.0  (Прочитано 959 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн magnifico61

  • ***
  • Сообщений: 203
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Функция СведенияОВнешнейОбработке() Экспорт

РегистрационныеДанные = Новый Структура;
РегистрационныеДанные.Вставить("Наименование", "РасшифровкаПрибыль");
РегистрационныеДанные.Вставить("БезопасныйРежим", Ложь);
РегистрационныеДанные.Вставить("Версия", "1.0");
РегистрационныеДанные.Вставить("Вид", "ДополнительныйОтчет");
РегистрационныеДанные.Вставить("Информация", "Произвольное наименование");
РегистрационныеДанные.Вставить("ХранилищеВариантов", Неопределено);

///////////// команды /////////////////////////
тзКоманд = Новый ТаблицаЗначений;
тзКоманд.Колонки.Добавить("Идентификатор");
тзКоманд.Колонки.Добавить("Представление");
тзКоманд.Колонки.Добавить("Модификатор");
тзКоманд.Колонки.Добавить("ПоказыватьОповещение");
тзКоманд.Колонки.Добавить("Использование");
строкаКоманды = тзКоманд.Добавить();
строкаКоманды.Идентификатор = "1";
строкаКоманды.Представление = "Корректировка";
строкаКоманды.ПоказыватьОповещение = Истина;
строкаКоманды.Использование = "ОткрытиеФормы";
РегистрационныеДанные.Вставить("Команды", тзКоманд);
Возврат РегистрационныеДанные;
КонецФункции

Пытаюсь добавить в дополнительные отчеты в БП 3.0 и выдает ошибку

{ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(2907)}: Поле объекта не обнаружено (ХранилищеВариантов)
Если ВнешнийОбъектМетаданные.ХранилищеВариантов <> Неопределено Тогда
Не могу понять почему

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн vvashkarin

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2015-11-25
  • Сайт: 
Попробуйте без этой строчки:
- "РегистрационныеДанные.Вставить("ХранилищеВариантов", Неопределено);"

Добавлено: 26 Ноя 2015, 17:21

Еще лучше все таки обозначить типы колонок. но это не к теме ошибки))
тзКоманды = Новый ТаблицаЗначений;
тзКоманды .Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
тзКоманды .Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
тзКоманды .Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
тзКоманды .Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
тзКоманды .Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

Оффлайн magnifico61

  • ***
  • Сообщений: 203
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
та же самая ошибка

Оффлайн vvashkarin

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2015-11-25
  • Сайт: 
та же самая ошибка

Напишите расширение файла отчета

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Функция СведенияОВнешнейОбработке() Экспорт

    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("");

    ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "ВАШЕ ИМЯ ОБРАБОТКИ"); // <<<<< Укажите свое имя отчета
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    ПараметрыРегистрации.Вставить("Информация", "Дополнительный отчет");

    ТаблицаКоманд = ПолучитьТаблицуКоманд();

    ДобавитьКоманду(ТаблицаКоманд, "Открыть", "", "ОткрытиеФормы", Истина);

    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

    Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры
Все должно работать.
ХранилищеВариантов", Неопределено - это зачем вообще?
Варианты отчета и так неплохо сохраняются ,и без этих параметров.

Оффлайн magnifico61

  • ***
  • Сообщений: 203
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-12-04
  • Сайт: 
  • Профессия: Программист 1С
Все равно ошибка с хранилищем ((


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
74 Сообщений
alexandr_ll
38 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
LexaK
32 Сообщений
crow1983
31 Сообщений
sertak sertak
26 Сообщений
BuhRust
19 Сообщений
Vzonder
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 355
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal