Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 14:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать справочника номенклатура через запрос  (Прочитано 6282 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Справочник номенклатура иерархический.Как вывести элементы справочника в макет используя   метод выбрать().

Процедура ДействияФормыПечатьЧерезЗапрос(Кнопка)
   ТабДок=Новый ТабличныйДокумент();
   Макет=Справочники.Номенклатура.ПолучитьМакет("Печать");
   Область=Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(Область);
    Область=Макет.ПолучитьОбласть("Шапка");
   ТабДок.Вывести(Область);

   Запрос = Новый Запрос();
   Запрос.Текст= "ВЫБРАТЬ
                 |   Номенклатура.Ссылка,
                 |   Номенклатура.ПометкаУдаления,
                 |   Номенклатура.Предопределенный,
                 |   Номенклатура.Родитель,
                 |   Номенклатура.ЭтоГруппа,
                 |   Номенклатура.Код,
                 |   Номенклатура.Наименование,
                 |   Номенклатура.СтавкаНДС,
                 |   Номенклатура.Представление
                 |ИЗ
                 |   Справочник.Номенклатура КАК Номенклатура";
    Результат=Запрос.Выполнить();
             Выборка=Результат.Выбрать();
            Группа=Макет.ПолучитьОбласть("Группа");
            Элемент = Макет.ПолучитьОбласть("Элемент");
            
            Пока Выборка.Следующий() Цикл
      
      Если Выборка.ЭтоГруппа Тогда
         Группа.Параметры.Заполнить(Выборка);
         
         ТабДок.Вывести(Группа);
         Иначе
          Элемент.Параметры.Заполнить(Выборка);
         
         ТабДок.Вывести(Элемент);
              КонецЕсли
       
             КонецЦикла;
            
   
ТабДок.Показать();   

КонецПроцедуры


Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
Уточните пожалуйста, это был вопрос?
Если в макете имена параметров совпадают с именами полей запроса, то все вроде должно печататься.

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Печатается но не правильно.

Оффлайн DenPlus

  • ***
  • Сообщений: 106
  • РЕПУТАЦИЯ: 64
  • КПД: 60%
  • Регистрация: 2010-10-27
  • Компания: www.cosmocat.ru
1. УПОРЯДОЧИТЬ ПО Номенклатура.Наименование Иерархия
2. Выборка = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);

не то?

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Нет так печатаются только группы без элементов

Процедура ДействияФормыПечатьЧерезЗапрос(Кнопка)
   ТабДок=Новый ТабличныйДокумент();
   Макет=Справочники.Номенклатура.ПолучитьМакет("Печать");
   Область=Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(Область);
    Область=Макет.ПолучитьОбласть("Шапка");
   ТабДок.Вывести(Область);


   Запрос = Новый Запрос();
   Запрос.Текст="ВЫБРАТЬ
                |   Номенклатура.Код,
                |   Номенклатура.Наименование КАК Наименование,
                |   Номенклатура.СтавкаНДС,
                |   Номенклатура.ЭтоГруппа
                |ИЗ
                |   Справочник.Номенклатура КАК Номенклатура
                |
                |УПОРЯДОЧИТЬ ПО
                |   Наименование ИЕРАРХИЯ";
             Результат=Запрос.Выполнить();
              Выборка=Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
            Группа=Макет.ПолучитьОбласть("Группа");
             
              Пока Выборка.Следующий() Цикл
             
            Группа.Параметры.Заполнить(Выборка);
               ТабДок.Вывести(Группа);
               КонецЦикла;
               Выборка1=Выборка.Выбрать();
               Группа=Макет.ПолучитьОбласть("Элемент");

               Пока Выборка1.Следующий() Цикл
               Элемент=Макет.ПолучитьОбласть("Группа");
   
               Элемент.Параметры.Заполнить(Выборка1);
               ТабДок.Вывести(Группа);
   
                                   КонецЦикла;
            ТабДок.Показать(); 
 
   //}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ
КонецПроцедуры
            

Оффлайн Fateev_max

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2010-09-21
  • Сайт: 
Надо просто было упорядочить по иерархии в запросе.Тема закрыта


Процедура ДействияФормыПечатьЧерезЗапрос(Кнопка)
   ТабДок=Новый ТабличныйДокумент();
   Макет=Справочники.Номенклатура.ПолучитьМакет("Печать");
   Область=Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(Область);
    Область=Макет.ПолучитьОбласть("Шапка");
   ТабДок.Вывести(Область);


   Запрос = Новый Запрос();
   Запрос.Текст="ВЫБРАТЬ
                |   Номенклатура.Код,
                |   Номенклатура.Наименование КАК Наименование,
                |   Номенклатура.СтавкаНДС,
                |   Номенклатура.ЭтоГруппа
                |ИЗ
                |   Справочник.Номенклатура КАК Номенклатура
                |
                |УПОРЯДОЧИТЬ ПО
                |   Наименование ИЕРАРХИЯ";
            Результат=Запрос.Выполнить();
Выборка=Результат.Выбрать();
Группа=Макет.ПолучитьОбласть("Группа");
Элемент = Макет.ПолучитьОбласть("Элемент");

Пока Выборка.Следующий() Цикл

Если Выборка.ЭтоГруппа Тогда
Группа.Параметры.Заполнить(Выборка);

ТабДок.Вывести(Группа);
Иначе
Элемент.Параметры.Заполнить(Выборка);

ТабДок.Вывести(Элемент);
КонецЕсли

КонецЦикла;


ТабДок.Показать();

КонецПроцедуры


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6504
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4209
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 642
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2049
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 275
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
58 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 278
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal