Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Мар 2017, 04:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменить отбор в списке  (Прочитано 362 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! УТ 11.1.10 (8.3.7)

Есть динамический список документов ,в списке реквизит "СтатусРемонта" - СправочникСсылка.пмСтатусыСервиса
На форме сделал поле флажка (Отбор) по которому надо менять отбор списка,в свойствах поля ПриИзменении добавил процедуру..

&НаКлиенте
Процедура ОтборПриИзменении(Элемент)

    Если( Элементы.Отбор ) тогда
       
    Иначе
       
    КонецЕсли

КонецПроцедуры
И вот тут я перепробовал все мыслемое и не мыслемое, натолкните на мысль пожалуйста?!
СправочникСсылка.пмСтатусыСервиса.Выдан не должно входить в список.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>



Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Там все как то не то,много для обычных форм,и в основном так..,думаете я не искал в гугле?
В общем сделал так..
&НаКлиенте
Процедура ОтборПриИзменении(Элемент)


Если Отбор = Истина Тогда
ОтборПриИзмененииНаСервере();
Иначе
Список.Отбор.Элементы.Очистить();
КонецЕсли
КонецПроцедуры


&НаСервере
Процедура ОтборПриИзмененииНаСервере()

ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбора(Список.Отбор,"СтатусРемонта",Справочники.пмСтатусыСервиса.Выдан,ВидСравненияКомпоновкиДанных.НеРавно,,);

КонецПроцедуры


Теги:
 

Программный отбор в "Документы"

Автор SeolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3631
Последний ответ 06 Окт 2012, 18:08
от Seolkin
Отбор при "быстром выборе"

Автор Gregory78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2200
Последний ответ 15 Фев 2015, 12:13
от Gregory78
Отбор по номенклатуре в отчете "ВЕдомость выдачи мц"

Автор notaSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1584
Последний ответ 08 Авг 2015, 15:40
от ppkmlite
Отбор по дате проведения документа в обработке "Универсальные подбор и обработка объектов"

Автор rooflessРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2200
Последний ответ 25 Июн 2014, 15:30
от roofless
Отключение кнопки "Отключить отбор" на панели формы списка документа

Автор AlterMannРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 8605
Последний ответ 13 Мар 2013, 09:41
от AlterMann

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
144 Сообщений
alex0402
113 Сообщений
Norfolk
51 Сообщений
LexaK
47 Сообщений
MuI_I_Ika MuI_I_Ika
37 Сообщений
друган
21 Сообщений
AsadRoman
20 Сообщений
alexandr_ll
19 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 196
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal