Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Июл 2017, 21:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменить отбор в списке  (Прочитано 448 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! УТ 11.1.10 (8.3.7)

Есть динамический список документов ,в списке реквизит "СтатусРемонта" - СправочникСсылка.пмСтатусыСервиса
На форме сделал поле флажка (Отбор) по которому надо менять отбор списка,в свойствах поля ПриИзменении добавил процедуру..

&НаКлиенте
Процедура ОтборПриИзменении(Элемент)

    Если( Элементы.Отбор ) тогда
       
    Иначе
       
    КонецЕсли

КонецПроцедуры
И вот тут я перепробовал все мыслемое и не мыслемое, натолкните на мысль пожалуйста?!
СправочникСсылка.пмСтатусыСервиса.Выдан не должно входить в список.



Оффлайн SkyNetYar

  • ****
  • Сообщений: 351
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2014-10-25
  • Сайт: 
  • Профессия: Ученик 1С
Там все как то не то,много для обычных форм,и в основном так..,думаете я не искал в гугле?
В общем сделал так..
&НаКлиенте
Процедура ОтборПриИзменении(Элемент)


Если Отбор = Истина Тогда
ОтборПриИзмененииНаСервере();
Иначе
Список.Отбор.Элементы.Очистить();
КонецЕсли
КонецПроцедуры


&НаСервере
Процедура ОтборПриИзмененииНаСервере()

ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбора(Список.Отбор,"СтатусРемонта",Справочники.пмСтатусыСервиса.Выдан,ВидСравненияКомпоновкиДанных.НеРавно,,);

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
96 Сообщений
oleg-x
76 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
53 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
40 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 273
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal